C++ class library for eXtended Scientific Computing
This commit is contained in:
Ying-Chieh Liao 2001-08-11 15:54:45 +00:00
parent d1f976003a
commit 8b758224c2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=46078
8 changed files with 269 additions and 0 deletions

View file

@ -16,6 +16,7 @@
SUBDIR += ccmath
SUBDIR += cln
SUBDIR += concorde
SUBDIR += cxsc
SUBDIR += dcdflib
SUBDIR += eispack
SUBDIR += eval

21
math/cxsc/Makefile Normal file
View file

@ -0,0 +1,21 @@
# ex:ts=8
# New ports collection makefile for: cxsc
# Date created: Aug 11, 2001
# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= cxsc
PORTVERSION= 2.0b
CATEGORIES= math devel
MASTER_SITES= http://www.math.uni-wuppertal.de/wrswt/xsc/cxsc/
DISTNAME= ${PORTNAME}-2-0-beta
MAINTAINER= ports@FreeBSD.org
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GMAKE= yes
MAKE_ENV= INSTALL_DATA="${INSTALL_DATA}"
.include <bsd.port.mk>

1
math/cxsc/distinfo Normal file
View file

@ -0,0 +1 @@
MD5 (cxsc-2-0-beta.tar.gz) = 62e425fd15d756f460b7c11b2b3bb801

View file

@ -0,0 +1,42 @@
--- Makefile.orig Fri Aug 10 01:50:35 2001
+++ Makefile Sat Aug 11 23:35:31 2001
@@ -2,24 +2,23 @@
# (un-)installation prefix
# e.g. /usr/local/cxsc or local home directory
-export PREFIX=/home/user/cxsc
#========= the following commands should work on most Unix systems ========
-export CC=gcc# name of the C compiler
-export CCOPTS=-Wall# optional flags to give to the C compiler
+#export CC=gcc# name of the C compiler
+#export CCOPTS=-Wall# optional flags to give to the C compiler
export CCINC=-I. -I../.. -I../rts#
# additional include path
-export CCFLAGS=$(CCINC) $(CCOPTS)#
+export CCFLAGS=${CFLAGS} $(CCINC) $(CCOPTS)#
# extra flags to give to the C compiler
-export CXX=g++# name of the C++ compiler
-export CXXOPTS=-Wall -Winline# optional flags to give to the C++ compiler
+#export CXX=g++# name of the C++ compiler
+#export CXXOPTS=-Wall -Winline# optional flags to give to the C++ compiler
# -O3# at the moment without optimization
# (takes too much RAM)
export CXXINC=-I. -I.. -Irts/ -Ifi_lib#
# additional include path
-export CXXFLAGS=$(CXXINC) $(CXXOPTS)#
+export CXXFLAGS+=$(CXXINC) $(CXXOPTS)#
# extra flags to give to the C++ compiler
export AR=ar# put object file into archive
@@ -29,7 +28,7 @@
export RM=rm -f# remove files (forced)
export RMDIR=rm -rf# remove directory
-export INSTALL=install -m 644# copy files
+export INSTALL=${INSTALL_DATA}# copy files
export STRIP=strip -g# strip executables from debug symbols
export INSTDIR=install -d# create installation directory

View file

@ -0,0 +1,19 @@
--- src/Makefile.orig Sat Aug 11 22:56:38 2001
+++ src/Makefile Sat Aug 11 23:04:30 2001
@@ -72,11 +72,11 @@
$(INSTALL) ./libcxsc_inl.a $(PREFIX)/lib/
# $(STRIP) $(PREFIX)/lib/libcxsc_inl.a
# install header files
- $(INSTDIR) $(PREFIX)/include
- $(INSTALL) ./*.hpp ./*.inl ./*.h $(PREFIX)/include
- $(INSTALL) rts/*.h $(PREFIX)/include
- $(INSTALL) fi_lib/fi_lib.h $(PREFIX)/include
- $(INSTALL) ../cxscconf.h $(PREFIX)/include
+ $(INSTDIR) $(PREFIX)/include/cxsc
+ $(INSTALL) ./*.hpp ./*.inl ./*.h $(PREFIX)/include/cxsc
+ $(INSTALL) rts/*.h $(PREFIX)/include/cxsc
+ $(INSTALL) fi_lib/fi_lib.h $(PREFIX)/include/cxsc
+ $(INSTALL) ../cxscconf.h $(PREFIX)/include/cxsc
# and docs
uninstall:

1
math/cxsc/pkg-comment Normal file
View file

@ -0,0 +1 @@
C++ class library for eXtended Scientific Computing

18
math/cxsc/pkg-descr Normal file
View file

@ -0,0 +1,18 @@
Language eXtensions for Scientific Computation provide all features
indispensable for modern numerical software development, such as :
- Operator concept (user-defined operators)
- Overloading concept
- Module concept
- Dynamic arrays
- Controlled rounding
- Predefined arithmetic data types real, (extended real), complex,
interval, complex interval, and corresponding vector and matrix types
- Predefined arithmetic operators of highest accuracy for the arithmetic
data types
- Predefined elementary functions of highest accuracy for the arithmetic
data types
- Data type dotprecision for the exact representation of dot products
- Library of mathematical problem-solving routines with automatic result
verification and high accuracy
WWW: http://www.math.uni-wuppertal.de/~xsc/

166
math/cxsc/pkg-plist Normal file
View file

@ -0,0 +1,166 @@
lib/libcxsc.a
lib/libcxsc_inl.a
include/cxsc/RtsFunc.h
include/cxsc/RtsTyp.h
include/cxsc/a_defs.h
include/cxsc/a_fcth.h
include/cxsc/addbody.h
include/cxsc/b_64bt.h
include/cxsc/b_defs.h
include/cxsc/b_fcth.h
include/cxsc/b_lari.h
include/cxsc/b_lpi_.h
include/cxsc/body.h
include/cxsc/cdot.hpp
include/cxsc/cdot.inl
include/cxsc/cidot.hpp
include/cxsc/cidot.inl
include/cxsc/cimatrix.hpp
include/cxsc/cimatrix.inl
include/cxsc/cinterva.hpp
include/cxsc/cinterva.inl
include/cxsc/cinterval.hpp
include/cxsc/civeccmat.hpp
include/cxsc/civeccmat.inl
include/cxsc/civecimat.hpp
include/cxsc/civecimat.inl
include/cxsc/civecrmat.hpp
include/cxsc/civecrmat.inl
include/cxsc/civector.hpp
include/cxsc/civector.inl
include/cxsc/cmatimat.hpp
include/cxsc/cmatimat.inl
include/cxsc/cmatrix.hpp
include/cxsc/cmatrix.inl
include/cxsc/compiler.h
include/cxsc/complex.hpp
include/cxsc/complex.inl
include/cxsc/cvecimat.hpp
include/cxsc/cvecimat.inl
include/cxsc/cvecrmat.hpp
include/cxsc/cvecrmat.inl
include/cxsc/cvector.hpp
include/cxsc/cvector.inl
include/cxsc/cxscconf.h
include/cxsc/cxscmatr.hpp
include/cxsc/cxscvect.hpp
include/cxsc/d_defs.h
include/cxsc/d_fcth.h
include/cxsc/divbody.h
include/cxsc/divtrap.h
include/cxsc/dot.hpp
include/cxsc/dot_defs.hpp
include/cxsc/e_defs.h
include/cxsc/e_fcth.h
include/cxsc/except.hpp
include/cxsc/f_fcth.h
include/cxsc/fi_lib.h
include/cxsc/idot.hpp
include/cxsc/idot.inl
include/cxsc/imath.hpp
include/cxsc/imatrix.hpp
include/cxsc/imatrix.inl
include/cxsc/interval.hpp
include/cxsc/interval.inl
include/cxsc/intmatri.hpp
include/cxsc/intmatri.inl
include/cxsc/intmatrix.hpp
include/cxsc/intvecto.hpp
include/cxsc/intvecto.inl
include/cxsc/intvector.hpp
include/cxsc/ioflags.hpp
include/cxsc/iveccmat.hpp
include/cxsc/iveccmat.inl
include/cxsc/iveccvec.hpp
include/cxsc/iveccvec.inl
include/cxsc/iveclrmat.hpp
include/cxsc/iveclrmat.inl
include/cxsc/ivecrmat.hpp
include/cxsc/ivecrmat.inl
include/cxsc/ivector.hpp
include/cxsc/ivector.inl
include/cxsc/l_defs.h
include/cxsc/l_fcth.h
include/cxsc/l_imath.hpp
include/cxsc/l_imatrix.hpp
include/cxsc/l_interv.hpp
include/cxsc/l_interv.inl
include/cxsc/l_interval.hpp
include/cxsc/l_ivector.hpp
include/cxsc/l_real.hpp
include/cxsc/l_rmath.hpp
include/cxsc/l_rmath.inl
include/cxsc/l_rmatrix.hpp
include/cxsc/l_rvector.hpp
include/cxsc/limatrix.hpp
include/cxsc/limatrix.inl
include/cxsc/livecimat.hpp
include/cxsc/livecimat.inl
include/cxsc/liveclrmat.hpp
include/cxsc/liveclrmat.inl
include/cxsc/livecrmat.hpp
include/cxsc/livecrmat.inl
include/cxsc/livector.hpp
include/cxsc/livector.inl
include/cxsc/lrmatimat.hpp
include/cxsc/lrmatimat.inl
include/cxsc/lrmatrix.hpp
include/cxsc/lrmatrix.inl
include/cxsc/lrvecimat.hpp
include/cxsc/lrvecimat.inl
include/cxsc/lrvecivec.hpp
include/cxsc/lrvecivec.inl
include/cxsc/lrvecrmat.hpp
include/cxsc/lrvecrmat.inl
include/cxsc/lrvector.hpp
include/cxsc/lrvector.inl
include/cxsc/matrix.hpp
include/cxsc/matrix.inl
include/cxsc/mulbody.h
include/cxsc/o_defs.h
include/cxsc/o_fcth.h
include/cxsc/o_msg1.h
include/cxsc/o_name.h
include/cxsc/o_revs.h
include/cxsc/o_slct.h
include/cxsc/o_spec.h
include/cxsc/o_syst.h
include/cxsc/o_type.h
include/cxsc/p88rts.h
include/cxsc/r_defs.h
include/cxsc/r_fcth.h
include/cxsc/real.hpp
include/cxsc/real.inl
include/cxsc/rmath.hpp
include/cxsc/rmath.inl
include/cxsc/rmatrix.hpp
include/cxsc/rmatrix.inl
include/cxsc/rts_real.hpp
include/cxsc/rtsrmath.h
include/cxsc/rvector.hpp
include/cxsc/rvector.inl
include/cxsc/s_fcth.h
include/cxsc/subbody.h
include/cxsc/t_cnst.h
include/cxsc/t_cond.h
include/cxsc/t_ddev.h
include/cxsc/t_defs.h
include/cxsc/t_drea.h
include/cxsc/t_exc_.h
include/cxsc/t_fcth.h
include/cxsc/t_ieee.h
include/cxsc/t_mach.h
include/cxsc/t_name.h
include/cxsc/test.hpp
include/cxsc/testclss.hpp
include/cxsc/testcomp.hpp
include/cxsc/testdot.hpp
include/cxsc/testintv.hpp
include/cxsc/testmatr.hpp
include/cxsc/testsklr.hpp
include/cxsc/testvect.hpp
include/cxsc/vector.hpp
include/cxsc/vector.inl
include/cxsc/xscclass.hpp
include/cxsc/y_fcth.h
@dirrm include/cxsc