Update to 0.10.21.

Fix detection of libpng.
New plugin v4l2.
This commit is contained in:
Koop Mast 2010-03-31 10:40:29 +00:00
parent 01b027acee
commit 8b5d6d26e2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=251886
19 changed files with 94 additions and 20 deletions

View file

@ -59,7 +59,7 @@ _USE_GSTREAMER10_ALL= a52dec aalib annodex bz2 cairo cdaudio cdparanoia dts \
libcaca libmms libpng libvisual mm mp3 mpeg2enc mpeg2dec \
musepack nas neon ogg pango pulse python sdl shout2 sidplay \
sndfile spc soundtouch soup speex taglib \
theora vorbis wavpack x264 xvid
theora v4l2 vorbis wavpack x264 xvid
# other plugins
OTHER_GSTREAMER_PLUGINS+=bad good ugly core yes ${_USE_GSTREAMER10_ALL} fluendo-mp3 mad
@ -212,6 +212,8 @@ mpeg2enc_DEPENDS= multimedia/gstreamer-plugins-mpeg2enc
mplex_DEPENDS= multimedia/gstreamer-plugins-mplex
v4l2_DEPENDS= multimedia/gstreamer-plugins-v4l2
# XXX: This is a quick solution for ports with USE_GSTREAMER=python
# but without USE_PYTHON.
PYTHON_PKGNAMEPREFIX?= py*-

View file

@ -5,7 +5,7 @@
# $FreeBSD$
#
PORTREVISION= 2
PORTREVISION= 0
CATEGORIES= audio
COMMENT= GStreamer plugin for pulseaudio

View file

@ -6,7 +6,7 @@
# $MCom: ports/audio/gstreamer-plugins-taglib/Makefile,v 1.3 2008/03/19 14:05:32 ahze Exp $
#
PORTREVISION= 1
PORTREVISION= 0
CATEGORIES= audio
COMMENT= Gstreamer taglib plugin

View file

@ -6,7 +6,7 @@
# $MCom: ports/devel/gstreamer-plugins-gconf/Makefile,v 1.6 2008/03/19 14:05:33 ahze Exp $
#
PORTREVISION= 2
PORTREVISION= 0
CATEGORIES= devel
COMMENT= Gstreamer gconf plugin

View file

@ -6,7 +6,7 @@
# $MCom: ports/devel/gstreamer-plugins-soup/Makefile,v 1.3 2008/03/19 14:05:33 ahze Exp $
#
PORTREVISION= 2
PORTREVISION= 0
CATEGORIES= devel
COMMENT= Gstreamer soup http src plugin

View file

@ -6,7 +6,7 @@
# $MCom: ports/graphics/gstreamer-plugins-cairo/Makefile,v 1.6 2008/03/19 14:05:34 ahze Exp $
#
PORTREVISION= 1
PORTREVISION= 0
CATEGORIES= graphics
COMMENT= Gstreamer vector graphics plugin

View file

@ -6,7 +6,7 @@
# $MCom: ports/graphics/gstreamer-plugins-gdkpixbuf/Makefile,v 1.5 2008/03/19 14:05:34 ahze Exp $
#
PORTREVISION= 2
PORTREVISION= 0
CATEGORIES= graphics
COMMENT= Gstreamer image decoder plugin

View file

@ -6,7 +6,7 @@
# $MCom: ports/graphics/gstreamer-plugins-jpeg/Makefile,v 1.5 2008/03/19 14:05:34 ahze Exp $
#
PORTREVISION= 1
PORTREVISION= 0
CATEGORIES= graphics
COMMENT= Gstreamer jpeg encoder/decoder plugin

View file

@ -6,7 +6,7 @@
# $MCom: ports/graphics/gstreamer-plugins-libcaca/Makefile,v 1.5 2008/03/19 14:05:34 ahze Exp $
#
PORTREVISION= 2
PORTREVISION= 0
CATEGORIES= graphics
COMMENT= Gstreamer color ascii art plugin

View file

@ -5,7 +5,7 @@
# $FreeBSD$
# $MCom: ports/graphics/gstreamer-plugins-libpng/Makefile,v 1.5 2008/03/19 14:05:34 ahze Exp $
PORTREVISION= 1
PORTREVISION= 0
CATEGORIES= graphics
COMMENT= Gstreamer png plugin

View file

@ -103,6 +103,7 @@
SUBDIR += gstreamer-plugins-mpeg2enc
SUBDIR += gstreamer-plugins-theora
SUBDIR += gstreamer-plugins-ugly
SUBDIR += gstreamer-plugins-v4l2
SUBDIR += gstreamer-plugins-x264
SUBDIR += gstreamer-plugins-xvid
SUBDIR += gstreamermm

View file

@ -6,7 +6,7 @@
# $MCom: ports/multimedia/gstreamer-plugins-dv/Makefile,v 1.5 2008/03/19 14:05:36 ahze Exp $
#
PORTREVISION= 1
PORTREVISION= 0
CATEGORIES= multimedia
COMMENT= Gstreamer dv plugin

View file

@ -1,6 +1,6 @@
--- configure.orig 2008-08-10 13:30:19.813061935 -0500
+++ configure 2008-08-10 13:29:56.315341694 -0500
@@ -32905,7 +32905,7 @@
--- configure.orig 2010-02-11 17:29:54.000000000 +0100
+++ configure 2010-02-11 17:34:38.000000000 +0100
@@ -24271,7 +24271,7 @@ if test "${with_default_audiosink+set}"
else
@ -8,3 +8,22 @@
+ DEFAULT_VISUALIZER="$DEFAULT_VISUALIZER"
fi
@@ -26653,6 +26653,8 @@ $as_echo_n "checking Checking for up to
#ifdef __sun /* Solaris */
#include <sys/types.h>
#include <sys/videodev2.h>
+#elif __FreeBSD__
+#include <linux/videodev2.h>
#else /* Linux */
#include <linux/types.h>
#define _LINUX_TIME_H
@@ -26726,6 +26728,8 @@ $as_echo_n "checking struct v4l2_buffer
#ifdef __sun /* Solaris */
#include <sys/types.h>
#include <sys/videodev2.h>
+#elif __FreeBSD__
+#include <linux/videodev2.h>
#else /* Linux */
#include <linux/types.h>
#define _LINUX_TIME_H

View file

@ -0,0 +1,21 @@
--- sys/v4l2/gstv4l2object.h.orig 2010-02-11 17:52:41.000000000 +0100
+++ sys/v4l2/gstv4l2object.h 2010-02-11 17:57:50.000000000 +0100
@@ -38,13 +38,15 @@
*/
#include <sys/ioctl.h>
#include <sys/types.h>
-#ifndef __sun
+#ifdef __sun
+#include <sys/videodev2.h>
+#elif defined(__FreeBSD__)
+#include <linux/videodev2.h>
+#else /* linux */
#include <linux/types.h>
#define _LINUX_TIME_H
#define __user
#include <linux/videodev2.h>
-#else
-#include <sys/videodev2.h>
#endif
#include <gst/gst.h>

View file

@ -64,6 +64,8 @@ lib/gstreamer-%%VERSION%%/libgstrtpmanager.la
lib/gstreamer-%%VERSION%%/libgstrtpmanager.so
lib/gstreamer-%%VERSION%%/libgstrtsp.la
lib/gstreamer-%%VERSION%%/libgstrtsp.so
lib/gstreamer-%%VERSION%%/libgstshapewipe.la
lib/gstreamer-%%VERSION%%/libgstshapewipe.so
lib/gstreamer-%%VERSION%%/libgstsmpte.la
lib/gstreamer-%%VERSION%%/libgstsmpte.so
lib/gstreamer-%%VERSION%%/libgstspectrum.la
@ -97,6 +99,7 @@ share/locale/ca/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
share/locale/cs/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
share/locale/da/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
share/locale/de/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
share/locale/el/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
share/locale/en_GB/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
share/locale/es/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo
share/locale/eu/LC_MESSAGES/gst-plugins-good-%%VERSION%%.mo

View file

@ -0,0 +1,18 @@
# New ports collection makefile for: gstreamer-plugins-v4l2
# Date created: 27 Mar 2010
# Whom: Koop Mast <kwm@FreeBSD.org>
#
# $FreeBSD$
#
PORTREVISION= 0
CATEGORIES= multimedia
COMMENT= Gstreamer Video 4 Linux 2 source plugin
GST_PLUGIN= gst_v4l2
PKGNAMESUFFIX?= -plugins-v4l2
MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
.include "${MASTERDIR}/Makefile"

View file

@ -19,7 +19,7 @@ MASTER_SITES= http://gstreamer.freedesktop.org/src/gst-plugins-base/:base \
${MASTER_SITE_LOCAL:S|$|ahze/:good|} \
${MASTER_SITE_LOCAL:S|$|ahze/:bad|} \
${MASTER_SITE_LOCAL:S|$|ahze/:ugly|}
PKGNAMESUFFIX= -plugins${GST_PLUGIN_SUFFIX}
PKGNAMESUFFIX?= -plugins${GST_PLUGIN_SUFFIX}
MAINTAINER= multimedia@FreeBSD.org
COMMENT?= GStreamer written collection of plugins handling several media types
@ -37,7 +37,7 @@ BASE_DISTFILE= ${BASE_DISTNAME}${EXTRACT_SUFX}
BAD_PORTVERSION= 0.10.18
BAD_DISTNAME= gst-plugins-bad-${BAD_PORTVERSION}
BAD_DISTFILE= ${BAD_DISTNAME}${EXTRACT_SUFX}
GOOD_PORTVERSION= 0.10.17
GOOD_PORTVERSION= 0.10.21
GOOD_DISTNAME= gst-plugins-good-${GOOD_PORTVERSION}
GOOD_DISTFILE= ${GOOD_DISTNAME}${EXTRACT_SUFX}
UGLY_PORTVERSION= 0.10.14
@ -151,6 +151,7 @@ post-patch:
s|$$(top_builddir)/gst-libs/gst/cdda/libgstcdda-@GST_MAJORMINOR@.la|${LOCALBASE}/lib/libgstcdda-@GST_MAJORMINOR@.la|'
@${REINPLACE_CMD} -e 's|DEFAULT_AUDIOSINK="alsasink"|DEFAULT_AUDIOSINK="${DEFAULT_AUDIOSINK}"|; \
s|DEFAULT_AUDIOSRC="alsasrc"|DEFAULT_AUDIOSRC="${DEFAULT_AUDIOSRC}"|' \
-e 's|libpng12.pc|libpng14.pc|g' \
${WRKSRC}/configure
.include <bsd.port.post.mk>

View file

@ -80,6 +80,7 @@ GOOD_GST_ALL_PLUGINS+= \
soup \
speex \
taglib \
gst_v4l2 \
wavpack
# ugly
@ -131,7 +132,6 @@ CONFIGURE_ARGS+=--disable-tests \
--disable-osx_video \
--disable-directdrawsink \
--disable-directsoundsink \
--disable-v4l2src \
--disable-tarkin \
--enable-static \
--disable-sunaudio \
@ -456,6 +456,15 @@ gst_theora_PLIST_FILES= ${GST_LIB_DIR}/libgsttheora.la \
${GST_LIB_DIR}/libgsttheora.so
gst_theora_DIST= base
# gst_v4l2
gst_gst_v4l2_LIB_DEPENDS+= v4l2.0:${PORTSDIR}/multimedia/libv4l
gst_gst_v4l2_RUN_DEPENDS+= webcamd:${PORTSDIR}/multimedia/webcamd
gst_gst_v4l2_PLIST_FILES= ${GST_LIB_DIR}/libgstvideo4linux2.la \
${GST_LIB_DIR}/libgstvideo4linux2.so
gst_gst_v4l2_CONFIGURE_ARGS+= --enable-gst_v4l2
gst_gst_v4l2_GST_PLUGIN_DIR=sys/v4l2
gst_gst_v4l2_DIST= good
# vorbis
gst_vorbis_USE_GSTREAMER+= ogg
gst_vorbis_LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis

View file

@ -7,6 +7,6 @@ SIZE (gst-plugins-bad-0.10.18.tar.bz2) = 3028412
MD5 (gst-plugins-ugly-0.10.14.tar.bz2) = 0bc0d27bcce88c73ef6c81e88624e686
SHA256 (gst-plugins-ugly-0.10.14.tar.bz2) = 78dba9963e130cfd09f294b60219e6562459c5d848bc3b38a653db7f21fc850b
SIZE (gst-plugins-ugly-0.10.14.tar.bz2) = 1028518
MD5 (gst-plugins-good-0.10.17.tar.bz2) = 833546cd2b8bbf86b8ed083b00897918
SHA256 (gst-plugins-good-0.10.17.tar.bz2) = 4f41fbd325270416c9f55d900e470482a7d1e7efbdbb725ed03a085dec307ad6
SIZE (gst-plugins-good-0.10.17.tar.bz2) = 2671700
MD5 (gst-plugins-good-0.10.21.tar.bz2) = 9bc5c9b390edbb96bda42fc553eae5ae
SHA256 (gst-plugins-good-0.10.21.tar.bz2) = 24445a1cf56302ab4ad5f56055d5c3d81c704b8f9f6875fe78a25d4f72716d22
SIZE (gst-plugins-good-0.10.21.tar.bz2) = 2675836