mirror of
https://git.freebsd.org/ports.git
synced 2025-05-24 15:07:01 -04:00
math/py-pdal: Update to 3.4.5
This commit is contained in:
parent
66be3c6061
commit
889c6b737f
4 changed files with 20 additions and 35 deletions
|
@ -1,10 +1,9 @@
|
|||
PORTNAME= pdal
|
||||
DISTVERSION= 3.0.2
|
||||
PORTREVISION= 3
|
||||
DISTVERSION= 3.4.5
|
||||
CATEGORIES= math python
|
||||
MASTER_SITES= PYPI
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
DISTNAME= ${PORTNAME:tu}-${DISTVERSION}
|
||||
DISTNAME= ${PORTNAME}-${DISTVERSION}
|
||||
|
||||
MAINTAINER= lbartoletti@FreeBSD.org
|
||||
COMMENT= PDAL Python bindings
|
||||
|
@ -14,7 +13,9 @@ LICENSE= BSD3CLAUSE
|
|||
|
||||
BUILD_DEPENDS= ${PYNUMPY} \
|
||||
${PYTHON_PKGNAMEPREFIX}scikit-build>0:devel/py-scikit-build@${PY_FLAVOR} \
|
||||
${PREFIX}/share/cmake/pybind11/pybind11Config.cmake:devel/pybind11 \
|
||||
${PYTHON_PKGNAMEPREFIX}scikit-build-core>=0.2.0:devel/py-scikit-build-core@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pybind11>0:devel/py-pybind11@${PY_FLAVOR} \
|
||||
pybind11>0:devel/pybind11 \
|
||||
cmake:devel/cmake-core
|
||||
LIB_DEPENDS= libpdalcpp.so:math/pdal
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR} \
|
||||
|
@ -22,7 +23,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR}
|
|||
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
|
||||
|
||||
USES= compiler:c++11-lang ninja:build python
|
||||
USE_PYTHON= autoplist cython distutils
|
||||
USE_PYTHON= autoplist cython pep517
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/${PORTNAME}/libpdalpython*.so
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1645816636
|
||||
SHA256 (PDAL-3.0.2.tar.gz) = fbad878ccab49833a8c7fc6982f8cd98dc9421cc592a1cf762113655806bac15
|
||||
SIZE (PDAL-3.0.2.tar.gz) = 82845
|
||||
TIMESTAMP = 1724913480
|
||||
SHA256 (pdal-3.4.5.tar.gz) = 6e42ec8c368a9d1c14abf0eff13a5b9d28b6de08ef7c2ca2b4900a15186d46f4
|
||||
SIZE (pdal-3.4.5.tar.gz) = 89528
|
||||
|
|
|
@ -1,27 +0,0 @@
|
|||
--- pdal/pipeline.py.orig 2021-11-24 10:30:42 UTC
|
||||
+++ pdal/pipeline.py
|
||||
@@ -1,5 +1,5 @@
|
||||
-from __future__ import annotations
|
||||
|
||||
+
|
||||
import json
|
||||
import logging
|
||||
from typing import Any, Container, Dict, Iterator, List, Optional, Sequence, Union, cast
|
||||
@@ -19,7 +19,7 @@ LogLevelToPDAL = {
|
||||
logging.INFO: 2,
|
||||
logging.DEBUG: 8, # pdal::LogLevel::Debug5
|
||||
}
|
||||
-LogLevelFromPDAL = {v: k for k, v in LogLevelToPDAL.items()}
|
||||
+LogLevelFromPDAL = {v: k for k, v in list(LogLevelToPDAL.items())}
|
||||
|
||||
|
||||
class Pipeline(libpdalpython.Pipeline):
|
||||
@@ -106,7 +106,7 @@ class Pipeline(libpdalpython.Pipeline):
|
||||
if all(isinstance(stage, Reader) for stage in stages):
|
||||
stages = [*stages, Filter.merge()]
|
||||
for stage in stages:
|
||||
- stage2tag[stage] = stage.tag or _generate_tag(stage, stage2tag.values())
|
||||
+ stage2tag[stage] = stage.tag or _generate_tag(stage, list(stage2tag.values()))
|
||||
options = stage.options
|
||||
options["tag"] = stage2tag[stage]
|
||||
inputs = _get_input_tags(stage, stage2tag)
|
11
math/py-pdal/files/patch-pyproject.toml
Normal file
11
math/py-pdal/files/patch-pyproject.toml
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- pyproject.toml.orig 2024-08-29 06:50:13 UTC
|
||||
+++ pyproject.toml
|
||||
@@ -48,7 +48,7 @@ changelog = "https://github.com/PDAL/python/blob/main/
|
||||
changelog = "https://github.com/PDAL/python/blob/main/README.rst"
|
||||
|
||||
[build-system]
|
||||
-requires = ["scikit-build-core >= 0.9", "numpy >= 1.22", "pybind11[global]"]
|
||||
+requires = ["scikit-build-core >= 0.9", "numpy >= 1.22", "pybind11"]
|
||||
build-backend = "scikit_build_core.build"
|
||||
|
||||
|
Loading…
Add table
Reference in a new issue