mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
biology/py-crossmap: Update to 0.7.3
Several fixes and enhancements since 0.5.4 Changes: https://github.com/liguowang/CrossMap/releases PR: 284923 Reported by: alster@vinterdalen.se
This commit is contained in:
parent
e1197b1e58
commit
886844b5ec
5 changed files with 6 additions and 2991 deletions
|
@ -1,16 +1,14 @@
|
|||
PORTNAME= crossmap
|
||||
DISTVERSION= 0.5.4
|
||||
PORTREVISION= 1
|
||||
DISTVERSION= 0.7.3
|
||||
CATEGORIES= biology python
|
||||
MASTER_SITES= PYPI
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
DISTNAME= CrossMap-${DISTVERSION}
|
||||
|
||||
MAINTAINER= jwb@FreeBSD.org
|
||||
COMMENT= Lift over genomics coordinates between assemblies
|
||||
WWW= https://pypi.python.org/pypi/crossmap
|
||||
WWW= https://github.com/liguowang/CrossMap
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE= GPLv3+
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
|
||||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0.10.4:devel/py-nose@${PY_FLAVOR}
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1618936542
|
||||
SHA256 (CrossMap-0.5.4.tar.gz) = 3419a5bf422754c3acb1e59ec9bba1a6c9a19d3673e962ae832e429ef0f768e5
|
||||
SIZE (CrossMap-0.5.4.tar.gz) = 9511082
|
||||
TIMESTAMP = 1740057259
|
||||
SHA256 (crossmap-0.7.3.tar.gz) = c5793d1bbfea962b3f21d8cd9830a79a169b3a3ec6461555d819be125b391f6d
|
||||
SIZE (crossmap-0.7.3.tar.gz) = 33325
|
||||
|
|
File diff suppressed because it is too large
Load diff
|
@ -1,18 +0,0 @@
|
|||
--- lib/cmmodule/twoList.py.orig 2021-04-04 22:42:53 UTC
|
||||
+++ lib/cmmodule/twoList.py
|
||||
@@ -5,7 +5,7 @@ from operator import mul,add,sub
|
||||
def check_list(v1,v2):
|
||||
'''check if the length of two list is same'''
|
||||
if v1.size != v2.size:
|
||||
- raise ValueError,"the lenght of both arrays must be the same"
|
||||
+ raise ValueError("the length of both arrays must be the same")
|
||||
pass
|
||||
|
||||
def Add(v1,v2):
|
||||
@@ -50,4 +50,4 @@ def Min(v1,v2):
|
||||
def euclidean_distance(v1,v2):
|
||||
'''return euclidean distance'''
|
||||
check_list(v1,v2)
|
||||
- return (sum((v1.__sub__(v2))**2) / v1.size)**0.5
|
||||
\ No newline at end of file
|
||||
+ return (sum((v1.__sub__(v2))**2) / v1.size)**0.5
|
|
@ -1,10 +0,0 @@
|
|||
--- setup.py.orig 2021-04-05 15:27:07 UTC
|
||||
+++ setup.py
|
||||
@@ -11,7 +11,6 @@ def main():
|
||||
setup( name = "CrossMap",
|
||||
version = "0.5.2",
|
||||
python_requires='>=3.5',
|
||||
- py_modules = [ 'psyco_full' ],
|
||||
packages = find_packages( 'lib' ),
|
||||
package_dir = { '': 'lib' },
|
||||
package_data = { '': ['*.ps'] },
|
Loading…
Add table
Reference in a new issue