all: remove support for expired FreeBSD 13.3

Reviewed by:	bofh, brnrd, jbeich, nobutaka
Approved by:	portmgr (implicit)
Differential Revision: https://reviews.freebsd.org/D48247
This commit is contained in:
Rene Ladan 2024-12-29 18:37:17 +01:00
parent bd3f32dcf8
commit 8777dde246
12 changed files with 8 additions and 57 deletions

View file

@ -1164,7 +1164,7 @@ OSVERSION!= ${AWK} '/^\#define[[:blank:]]__FreeBSD_version/ {print $$3}' < ${SRC
. endif
_EXPORTED_VARS+= OSVERSION
. if ${OPSYS} == FreeBSD && (${OSVERSION} < 1303000 || (${OSVERSION} >= 1400000 && ${OSVERSION} < 1401000))
. if ${OPSYS} == FreeBSD && (${OSVERSION} < 1303400 || (${OSVERSION} >= 1400000 && ${OSVERSION} < 1401000))
_UNSUPPORTED_SYSTEM_MESSAGE= Ports Collection support for your ${OPSYS} version has ended, and no ports\
are guaranteed to build on this system. Please upgrade to a supported release.
. if defined(ALLOW_UNSUPPORTED_SYSTEM)

View file

@ -27,7 +27,7 @@ USES= metaport python
.include <bsd.port.options.mk>
.if ${OPSYS} != FreeBSD || ${OSVERSION} >= 1302509
.if ${OPSYS} != FreeBSD
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}MACS3>0:biology/py-macs3@${PY_FLAVOR}
.endif

View file

@ -18,7 +18,6 @@ BUILD_DEPENDS+= bjam:devel/boost-jam
# * OSVERSION is included in either of following ranges.
# 1. 1500000 <= OSVERSION < 1500017
# 2. 1400000 <= OSVERSION < 1400509 (no longer relevant)
# 3. 1300000 <= OSVERSION < 1303502 (no longer relevant)
# * Base system is built with WITH_LLVM_ASSERTIONS variable set.
# So if your base system fulfills them you need to use LLVM ports to
# build this port.

View file

@ -140,8 +140,7 @@ post-extract:
${CP} -R ${WRKDIR}/imhex-bastion-pats-${GL_TAG_IMHEX_BASTION_PATS}/* ${WRKDIR}/.build/_deps/imhex_patterns_src/patterns/bastion
${CP} -R ${WRKDIR}/imhex-ffx-pats-${GL_TAG_IMHEX_FFX_PATS}/* ${WRKDIR}/.build/_deps/imhex_patterns_src/patterns/ffx
# Before LLVM 18 import into the base system
.if ((${OSREL:R} == 15 && ${OSVERSION} < 1500018) \
|| (${OSREL:R} == 13 && ${OSVERSION} < 1303503))
.if ${OSREL:R} == 15 && ${OSVERSION} < 1500018
${CP} -R ${WRKSRC_jthread}/* ${WRKSRC}/lib/third_party/jthread
.endif

View file

@ -92,8 +92,7 @@ NLS_USES= gettext
.include <bsd.port.pre.mk>
# Before LLVM 18 import into the base system
.if ((${OSREL:R} == 15 && ${OSVERSION} < 1500018) \
|| (${OSREL:R} == 13 && ${OSVERSION} < 1303503))
.if ${OSREL:R} == 15 && ${OSVERSION} < 1500018
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-lib_external_libwolv_libs_io_include_wolv_io_file.hpp \
${PATCHDIR}/extra-patch-plugins_windows_include_views_view__tty__console.hpp \
${PATCHDIR}/extra-patch-lib_libimhex_include_hex_api_task.hpp \
@ -114,8 +113,7 @@ post-extract:
${CP} -R ${WRKSRC_yara}/* ${WRKSRC}/lib/external/yara/yara
${MKDIR} ${WRKDIR}/.build/_deps/imhex_patterns_src
${CP} -R ${WRKSRC_imhex_patterns}/* ${WRKDIR}/.build/_deps/imhex_patterns_src
.if ((${OSREL:R} == 15 && ${OSVERSION} < 1500018) \
|| (${OSREL:R} == 13 && ${OSVERSION} < 1303503))
.if ${OSREL:R} == 15 && ${OSVERSION} < 1500018
${CP} -R ${WRKSRC_jthread}/source/*.hpp ${WRKSRC}/lib/libimhex/include
${CP} -R ${WRKSRC_jthread}/source/*.hpp ${WRKSRC}/lib/external/libwolv/libs/io/include/wolv/io
.endif

View file

@ -20,7 +20,7 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1302505
.if ${OPSYS} == FreeBSD
CFLAGS+= -Wno-error=int-conversion
.endif

View file

@ -74,7 +74,7 @@ netlink_PKGNAMESUFFIX= 2-netlink
rtsock_PKGNAMESUFFIX= 2
.endif
.if ${OPSYS} == FreeBSD && ( ${OSVERSION} < 1303502 || ( ${OSVERSION} >= 1500000 && ${OSVERSION} < 1500017 ))
.if ${OPSYS} == FreeBSD && (${OSVERSION} >= 1500000 && ${OSVERSION} < 1500017)
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-netlink-route
.endif

View file

@ -412,10 +412,6 @@ UTMP_CONFIGURE_WITH= utmp
##############################################################################
.include <bsd.port.options.mk>
##############################################################################
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1300076
IGNORE=runs only on FreeBSD 13.1 and above due use of O_EMPTY_PATH
.endif
.if !${PORT_OPTIONS:MADS} && ${PORT_OPTIONS:MAD_DC}
IGNORE=To disable ADS option you also need to disable AD_DC option
.endif

View file

@ -74,7 +74,7 @@ GOST_DESC= GOST (Russian standard)
HASHES_DESC= Hash Function Support
I386_DESC= i386 (instead of i486+)
IDEA_DESC= International Data Encryption Algorithm
KTLS_DESC= Use in-kernel TLS (FreeBSD >13)
KTLS_DESC= Use in-kernel TLS
LEGACY_DESC= Older algorithms
MAN3_DESC= Install API manpages (section 3, 7)
MD2_DESC= MD2 (obsolete) (requires LEGACY)

View file

@ -1,19 +0,0 @@
Drop after FreeBSD 13.3 EOL around 2025-07-01
../src/debug/Log.cpp:13:26: error: no member named 'native_handle' in 'std::ofstream'
13 | auto handle = logOfs.native_handle();
| ~~~~~~ ^
--- src/debug/Log.cpp.orig 2024-08-18 21:21:59 UTC
+++ src/debug/Log.cpp
@@ -10,8 +10,10 @@ void Debug::init(const std::string& IS) {
void Debug::init(const std::string& IS) {
logFile = IS + (ISDEBUG ? "/hyprlandd.log" : "/hyprland.log");
logOfs.open(logFile, std::ios::out | std::ios::app);
+#if !defined(_LIBCPP_VERSION) || _LIBCPP_VERSION >= 180100
auto handle = logOfs.native_handle();
fcntl(handle, F_SETFD, FD_CLOEXEC);
+#endif
}
void Debug::close() {

View file

@ -176,24 +176,4 @@ pre-test:
${TOUCH} ${WRKDIR}/.meson_build_tests; \
fi
# XXX Drop after FreeBSD 13.3 EOL around 2025-07-01 (don't forget distinfo)
.if ${CXX} == c++ && exists(/usr/include/c++/v1/__chrono/concepts.h) && \
!exists(/usr/include/c++/v1/__chrono/tzdb.h) || make(makesum) || make(fetch)
USES+= cmake:indirect
CMAKE_ARGS= -B ${WRKDIR}/libcxx_build -S ${WRKSRC_libcxx}/libcxx
CMAKE_OFF= LIBCXX_INCLUDE_BENCHMARKS
CMAKE_INSTALL_PREFIX= ${WRKDIR}/libcxx_prefix
# XXX Move into separate port and standardize via USES
GH_TUPLE+= llvm:llvm-project:llvmorg-16.0.1:libcxx
CXXFLAGS+= -nostdinc++ -isystem${WRKDIR}/libcxx_prefix/include/c++/v1
# Don't link against new libc++ as it's not necessary
#LDFLAGS+= -nostdlib++ -L${WRKDIR}/libcxx_prefix/lib -l:libc++.a -lcxxrt
pre-configure: bundled-libcxx
bundled-libcxx:
@${SETENVI} ${WRK_ENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS}
@${DO_MAKE_BUILD:NDESTDIR*} install -C ${WRKDIR}/libcxx_build
.endif # exists(/usr/include/c++/v1/__chrono/concepts.h)
.include <bsd.port.mk>

View file

@ -1,7 +1,5 @@
TIMESTAMP = 1730730436
SHA256 (Alexays-Waybar-0.11.0_GH0.tar.gz) = 6a0e9f0f7f2eff503951958cbb16dc39041c0b67e86c35154e8507677c61be9d
SIZE (Alexays-Waybar-0.11.0_GH0.tar.gz) = 317607
SHA256 (llvm-llvm-project-llvmorg-16.0.1_GH0.tar.gz) = b5a9ff1793b1e2d388a3819bf35797002b1d2e40bb35a10c65605e0ea1435271
SIZE (llvm-llvm-project-llvmorg-16.0.1_GH0.tar.gz) = 179289803
SHA256 (0d02f6877d88551ea2be0cd151c1e6354e208b1c.patch) = 7ca2c4be684ad2d51f5c278400d37f7179c4f242d84268de1b74d443568a83d5
SIZE (0d02f6877d88551ea2be0cd151c1e6354e208b1c.patch) = 5550