mirror of
https://git.freebsd.org/ports.git
synced 2025-05-12 23:31:50 -04:00
net-p2p/mkbrr: New port: Commmand-line utility to create, modify and inspect torrent files
Supports features such as: * Creating torrent files * Inspecting torrent files * Modifying torrent metadata * Supports tracker-specific requirements automatically * Batch mode
This commit is contained in:
parent
e9a5a3550b
commit
86b27ebb8a
5 changed files with 56 additions and 0 deletions
|
@ -53,6 +53,7 @@
|
|||
SUBDIR += lxmf
|
||||
SUBDIR += microdc2
|
||||
SUBDIR += minder
|
||||
SUBDIR += mkbrr
|
||||
SUBDIR += mktorrent
|
||||
SUBDIR += mldonkey
|
||||
SUBDIR += mldonkey-core
|
||||
|
|
27
net-p2p/mkbrr/Makefile
Normal file
27
net-p2p/mkbrr/Makefile
Normal file
|
@ -0,0 +1,27 @@
|
|||
PORTNAME= mkbrr
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 1.3.0
|
||||
CATEGORIES= net-p2p
|
||||
|
||||
MAINTAINER= diizzy@FreeBSD.org
|
||||
COMMENT= Commmand-line utility to create, modify and inspect torrent files written in Go
|
||||
WWW= https://github.com/autobrr/mkbrr
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
USES= go:1.23,modules
|
||||
|
||||
CGO_ENABLED= 0
|
||||
GO_MODULE= github.com/autobrr/${PORTNAME}
|
||||
|
||||
PLIST_FILES= bin/mkbrr
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%DISTVERSION%%|${DISTVERSION}|g' \
|
||||
${PATCH_WRKSRC}/main.go
|
||||
@${REINPLACE_CMD} -e 's|%%BUILDTIME%%|${CONFIGURE_TARGET}|g' \
|
||||
${PATCH_WRKSRC}/main.go
|
||||
${RM} ${PATCH_WRKSRC}/cmd/update.go
|
||||
|
||||
.include <bsd.port.mk>
|
5
net-p2p/mkbrr/distinfo
Normal file
5
net-p2p/mkbrr/distinfo
Normal file
|
@ -0,0 +1,5 @@
|
|||
TIMESTAMP = 1741382943
|
||||
SHA256 (go/net-p2p_mkbrr/mkbrr-v1.3.0/v1.3.0.mod) = 7eb4252628e608712058fbed6f72cfa3a97fc6e8c5d7d3feb9efa8ec6d5d4676
|
||||
SIZE (go/net-p2p_mkbrr/mkbrr-v1.3.0/v1.3.0.mod) = 2106
|
||||
SHA256 (go/net-p2p_mkbrr/mkbrr-v1.3.0/v1.3.0.zip) = 426fd987d9f71b890d579d4d2a03b70d911b9e9a9e3ebc2824583a10012e13aa
|
||||
SIZE (go/net-p2p_mkbrr/mkbrr-v1.3.0/v1.3.0.zip) = 73885
|
13
net-p2p/mkbrr/files/patch-main.go
Normal file
13
net-p2p/mkbrr/files/patch-main.go
Normal file
|
@ -0,0 +1,13 @@
|
|||
--- main.go.orig 2025-03-07 21:35:10 UTC
|
||||
+++ main.go
|
||||
@@ -7,8 +7,8 @@ var (
|
||||
)
|
||||
|
||||
var (
|
||||
- version = "dev"
|
||||
- buildTime = "unknown"
|
||||
+ version = "%%DISTVERSION%%"
|
||||
+ buildTime = "%%BUILDTIME%%"
|
||||
)
|
||||
|
||||
func main() {
|
10
net-p2p/mkbrr/pkg-descr
Normal file
10
net-p2p/mkbrr/pkg-descr
Normal file
|
@ -0,0 +1,10 @@
|
|||
Commmand-line utility to create, modify and inspect torrent files written in Go
|
||||
|
||||
A simple yet powerful tool for:
|
||||
|
||||
* Creating torrent files
|
||||
* Inspecting torrent files
|
||||
* Modifying torrent metadata
|
||||
* Supports tracker-specific requirements automatically
|
||||
|
||||
|
Loading…
Add table
Reference in a new issue