mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
devel/glib20: Prevent the silent grabbing of libelf from ports
PR: 273479
This commit is contained in:
parent
f3348645e1
commit
8107e8e7cb
3 changed files with 28 additions and 1 deletions
|
@ -1,6 +1,6 @@
|
||||||
PORTNAME= glib
|
PORTNAME= glib
|
||||||
DISTVERSION= 2.84.1
|
DISTVERSION= 2.84.1
|
||||||
PORTREVISION= 1
|
PORTREVISION= 2
|
||||||
PORTEPOCH= 2
|
PORTEPOCH= 2
|
||||||
CATEGORIES= devel
|
CATEGORIES= devel
|
||||||
MASTER_SITES= GNOME
|
MASTER_SITES= GNOME
|
||||||
|
@ -42,6 +42,7 @@ MESON_ARGS= -Db_lundef=false \
|
||||||
-Ddefault_library=both \
|
-Ddefault_library=both \
|
||||||
-Dfile_monitor_backend='libinotify-kqueue' \
|
-Dfile_monitor_backend='libinotify-kqueue' \
|
||||||
-Dinstalled_tests=false \
|
-Dinstalled_tests=false \
|
||||||
|
-Dlibelf=disabled \
|
||||||
-Dlibmount=disabled \
|
-Dlibmount=disabled \
|
||||||
-Druntime_dir=/var/run \
|
-Druntime_dir=/var/run \
|
||||||
-Dselinux=disabled \
|
-Dselinux=disabled \
|
||||||
|
|
15
devel/glib20/files/patch-gio_gresource-tool.c
Normal file
15
devel/glib20/files/patch-gio_gresource-tool.c
Normal file
|
@ -0,0 +1,15 @@
|
||||||
|
--- gio/gresource-tool.c.orig 2025-04-03 14:38:51 UTC
|
||||||
|
+++ gio/gresource-tool.c
|
||||||
|
@@ -31,8 +31,10 @@
|
||||||
|
#include <locale.h>
|
||||||
|
|
||||||
|
#ifdef HAVE_LIBELF
|
||||||
|
-#include <libelf.h>
|
||||||
|
-#include <gelf.h>
|
||||||
|
+#include </usr/include/libelf.h>
|
||||||
|
+// fool libelf from ports to not include its libelf.h
|
||||||
|
+#define _LIBELF_H 1
|
||||||
|
+#include </usr/include/gelf.h>
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#ifdef HAVE_MMAP
|
11
devel/glib20/files/patch-gio_meson.build
Normal file
11
devel/glib20/files/patch-gio_meson.build
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- gio/meson.build.orig 2025-04-03 14:38:51 UTC
|
||||||
|
+++ gio/meson.build
|
||||||
|
@@ -971,7 +971,7 @@ else
|
||||||
|
# This fallback is necessary on *BSD. elfutils isn't the only libelf
|
||||||
|
# implementation, and *BSD usually includes their own libelf as a system
|
||||||
|
# library which doesn't have a corresponding .pc file.
|
||||||
|
- libelf = cc.find_library('elf', required : get_option ('libelf'))
|
||||||
|
+ libelf = declare_dependency(link_args: '/lib/libelf.so.2')
|
||||||
|
have_libelf = libelf.found()
|
||||||
|
have_libelf = have_libelf and cc.has_function('elf_begin', dependencies : libelf)
|
||||||
|
have_libelf = have_libelf and cc.has_function('elf_getshdrstrndx', dependencies : libelf)
|
Loading…
Add table
Reference in a new issue