mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
astro/py-ro: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
This commit is contained in:
parent
f1d329ab26
commit
8084815bd8
2 changed files with 15 additions and 2 deletions
|
@ -1,6 +1,6 @@
|
||||||
PORTNAME= ro
|
PORTNAME= ro
|
||||||
PORTVERSION= 3.6.9
|
PORTVERSION= 3.6.9
|
||||||
PORTREVISION= 5
|
PORTREVISION= 6
|
||||||
CATEGORIES= astro python
|
CATEGORIES= astro python
|
||||||
MASTER_SITES= PYPI
|
MASTER_SITES= PYPI
|
||||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||||
|
@ -14,10 +14,12 @@ WWW= https://staff.washington.edu/rowen/ROPackage/Overview.html \
|
||||||
LICENSE= MIT
|
LICENSE= MIT
|
||||||
LICENSE_FILE= ${WRKSRC}/docs/License.txt
|
LICENSE_FILE= ${WRKSRC}/docs/License.txt
|
||||||
|
|
||||||
|
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
|
||||||
|
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
|
||||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR}
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR}
|
||||||
|
|
||||||
USES= python
|
USES= python
|
||||||
USE_PYTHON= autoplist concurrent distutils
|
USE_PYTHON= autoplist concurrent pep517
|
||||||
|
|
||||||
NO_ARCH= yes
|
NO_ARCH= yes
|
||||||
|
|
||||||
|
|
11
astro/py-ro/files/patch-setup.py
Normal file
11
astro/py-ro/files/patch-setup.py
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- setup.py.orig 2015-11-02 21:50:21 UTC
|
||||||
|
+++ setup.py
|
||||||
|
@@ -45,7 +45,7 @@ setup(
|
||||||
|
print(("%s version %s" % (PkgName, Version.__version__)))
|
||||||
|
|
||||||
|
setup(
|
||||||
|
- name = PkgName,
|
||||||
|
+ name = PkgName.lower(),
|
||||||
|
version = Version.__version__,
|
||||||
|
description = "Collection of utilities including general algorithms, astronomical transformations and Tkinter widgets",
|
||||||
|
long_description = long_description,
|
Loading…
Add table
Reference in a new issue