mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
x11/mrxvt{-devel}: Merge into mrxvt
- mrxvt was using the older 4.2 version and mrxvt-devel had more recent version 0.5.4. Merge the devel version into the main port as in repology all other distributions are using 0.5.4
This commit is contained in:
parent
4979b17fff
commit
80085a6c6b
14 changed files with 121 additions and 265 deletions
1
MOVED
1
MOVED
|
@ -3042,3 +3042,4 @@ security/py-pyblake2||2024-03-03|Has expired: Reached it's End Of Life. Integrat
|
|||
net-im/gtkcord4|net-im/dissent|2024-03-03|Project renamed
|
||||
devel/anjuta|devel/gnome-builder|2024-03-12|Has expired: Unmaintained, upstream WWW owned by gambling site, use devel/gnome-builder
|
||||
deskutils/rubrica||2024-03-12|Has expired: Upstream WWW redirects to a different site not related to the application
|
||||
x11/mrxvt-devel|x11/mrxvt|2024-03-12|Merge most recent version into main port
|
||||
|
|
|
@ -271,7 +271,6 @@
|
|||
SUBDIR += mlterm
|
||||
SUBDIR += mons
|
||||
SUBDIR += mrxvt
|
||||
SUBDIR += mrxvt-devel
|
||||
SUBDIR += multi-aterm
|
||||
SUBDIR += mxascii
|
||||
SUBDIR += mxico
|
||||
|
|
|
@ -1,153 +0,0 @@
|
|||
PORTNAME= mrxvt-devel
|
||||
PORTVERSION= 0.5.4
|
||||
PORTREVISION= 13
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= SF/materm/mrxvt%20source/${PORTVERSION}
|
||||
DISTNAME= mrxvt-${PORTVERSION}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Development version of mrxvt
|
||||
WWW= https://materm.sourceforge.net/
|
||||
|
||||
LICENSE= GPLv2
|
||||
|
||||
CONFLICTS= mrxvt-0.4.*
|
||||
USES= shebangfix xorg
|
||||
USE_XORG= ice x11 sm xpm xrender
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
LIB_DEPENDS+= libfontconfig.so:x11-fonts/fontconfig
|
||||
|
||||
SHEBANG_FILES= ${WRKSRC}/share/scripts/mrxvtset.pl
|
||||
|
||||
SUB_FILES+= pkg-message
|
||||
|
||||
DESKTOP_ENTRIES= "mrxvt" "mrxvt terminal emulator" \
|
||||
"${PREFIX}/share/pixmaps/mrxvt.png" \
|
||||
"mrxvt" "Utility;TerminalEmulator;" \
|
||||
false
|
||||
|
||||
OPTIONS_DEFINE= XFT BACKGROUND JPEG PNG TRANSPARENCY SWAPSCREEN JAPANESE 24BITS \
|
||||
MENUBAR TEXTSHADOW FRILLS DOCS EXAMPLES
|
||||
OPTIONS_DEFAULT= BACKGROUND JPEG PNG TRANSPARENCY SWAPSCREEN 24BITS \
|
||||
MENUBAR XFT JAPANESE FRILLS TEXTSHADOW
|
||||
BACKGROUND_DESC= Background images
|
||||
TRANSPARENCY_DESC= Transparent background
|
||||
SWAPSCREEN_DESC= Swapscreen
|
||||
JAPANESE_DESC= Support for Japanese language
|
||||
24BITS_DESC= Prefer 24 bits color
|
||||
MENUBAR_DESC= Menubar
|
||||
TEXTSHADOW_DESC= Text shadow
|
||||
FRILLS_DESC= Internal borders and smart resizing
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
CONFIGURE_ARGS+= --enable-utempter
|
||||
CONFIGURE_ARGS+= --disable-lastlog
|
||||
CFLAGS+= -fcommon
|
||||
|
||||
.if ${PORT_OPTIONS:MJAPANESE}
|
||||
CONFIGURE_ARGS+= --enable-xim --enable-cjk --with-encoding=eucj
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MXFT}
|
||||
USE_XORG+= xft
|
||||
CONFIGURE_ARGS+= --enable-xft
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MXFT} && ${PORT_OPTIONS:MJAPANESE}
|
||||
USES+= iconv
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:M24BITS}
|
||||
CONFIGURE_ARGS+= --enable-24bits
|
||||
.endif
|
||||
|
||||
.if ! ${PORT_OPTIONS:MBACKGROUND}
|
||||
CONFIGURE_ARGS+= --disable-xpm
|
||||
.endif
|
||||
|
||||
.if ! ${PORT_OPTIONS:MJPEG} || ! ${PORT_OPTIONS:MBACKGROUND}
|
||||
CONFIGURE_ARGS+= --disable-jpeg
|
||||
.else
|
||||
USES+= jpeg
|
||||
.endif
|
||||
|
||||
.if ! ${PORT_OPTIONS:MPNG} || ! ${PORT_OPTIONS:MBACKGROUND}
|
||||
CONFIGURE_ARGS+= --disable-png
|
||||
.else
|
||||
LIB_DEPENDS+= libpng.so:graphics/png
|
||||
.endif
|
||||
|
||||
.if ! ${PORT_OPTIONS:MTRANSPARENCY}
|
||||
CONFIGURE_ARGS+= --disable-transparency
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MMENUBAR}
|
||||
CONFIGURE_ARGS+= --enable-menubar
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MTEXTSHADOW}
|
||||
CONFIGURE_ARGS+= --enable-text-shadow
|
||||
.endif
|
||||
|
||||
.if ! ${PORT_OPTIONS:MSWAPSCREEN}
|
||||
CONFIGURE_ARGS+= --disable-swapscreen
|
||||
.endif
|
||||
|
||||
.if ${PORT_OPTIONS:MFRILLS}
|
||||
CONFIGURE_ARGS+= --enable-frills
|
||||
.endif
|
||||
|
||||
## Rarely used options, not in the main menu
|
||||
# How many lines to save in the scroll buffer
|
||||
.if defined(SAVE_LINES)
|
||||
CONFIGURE_ARGS+= --with-save-lines=${SAVE_LINES:M[0-9]*}
|
||||
.endif
|
||||
|
||||
# Maximal number of terminals
|
||||
.if defined(MAX_TERMINALS)
|
||||
CONFIGURE_ARGS+= --with-max-term=${MAX_TERMINALS:M[0-9]*}
|
||||
.endif
|
||||
|
||||
# Maximal number of profiles
|
||||
.if defined(MAX_PROFILES)
|
||||
CONFIGURE_ARGS+= --with-max-profiles=${MAX_PROFILES:M[0-9]*}
|
||||
.endif
|
||||
|
||||
# Extra height of active tab as a percentage of the font height
|
||||
.if defined(EXTRA_ATAB_HEIGHT)
|
||||
CONFIGURE_ARGS+= --with-atab-extra=${EXTRA_ATAB_HEIGHT:M[0-9]*}
|
||||
.endif
|
||||
|
||||
# The radius of tab corners as a percentage of the font X offset
|
||||
.if defined(TAB_RADIUS)
|
||||
CONFIGURE_ARGS+= --with-tab-radius=${TAB_RADIUS:M[0-9]*}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if empty(ICONV_LIB)
|
||||
CONFIGURE_ARGS+=ac_cv_lib_iconv_iconv_open=no
|
||||
.else
|
||||
CONFIGURE_ARGS+=ac_cv_lib_iconv_iconv_open=yes
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/mrxvt ${STAGEDIR}${PREFIX}/bin
|
||||
@for pixmap in ${WRKSRC}/share/pixmaps/* ; \
|
||||
do ${INSTALL_DATA} $$pixmap ${STAGEDIR}${PREFIX}/share/pixmaps/ ; \
|
||||
done
|
||||
${MKDIR} ${STAGEDIR}${PREFIX}/etc/mrxvt
|
||||
${INSTALL_DATA} ${WRKSRC}/share/mrxvtrc ${STAGEDIR}${PREFIX}/etc/mrxvt/mrxvtrc.sample
|
||||
${INSTALL_DATA} ${WRKSRC}/share/default.menu ${STAGEDIR}${PREFIX}/etc/mrxvt/default.menu.sample
|
||||
${INSTALL_DATA} ${WRKSRC}/share/submenus.menu ${STAGEDIR}${PREFIX}/etc/mrxvt/submenus.menu.sample
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/mrxvt.1 ${STAGEDIR}${PREFIX}/share/man/man1
|
||||
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/scripts
|
||||
${INSTALL_DATA} ${WRKSRC}/share/scripts/mrxvtset.pl ${STAGEDIR}${EXAMPLESDIR}/scripts
|
||||
${INSTALL_DATA} ${WRKSRC}/share/scripts/settitle.c ${STAGEDIR}${EXAMPLESDIR}/scripts
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${CP} ${WRKSRC}/doc/*.bz2 ${STAGEDIR}${DOCSDIR}
|
||||
${BZIP2_CMD} -d ${STAGEDIR}${DOCSDIR}/*.bz2
|
||||
|
||||
.include <bsd.port.post.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (mrxvt-0.5.4.tar.gz) = f403ad5a908fcd38a55ed0a7e1b85584cb77be8781199653a39b8af1a9ad10d7
|
||||
SIZE (mrxvt-0.5.4.tar.gz) = 603978
|
|
@ -1,8 +0,0 @@
|
|||
Mrxvt (previously named as materm) is a lightweight and powerful
|
||||
multi-tabbed X terminal emulator based on the popular rxvt and
|
||||
aterm. It implements many useful features seen in some modern X
|
||||
terminal emulators, like gnome-terminal and konsole, but keep to
|
||||
be lightweight and independent from the GNOME and KDE desktop
|
||||
environment. The following are the major features of mrxvt (* are
|
||||
new features compared with rxvt, + are enhanced features compared
|
||||
with rxvt):
|
|
@ -1,21 +0,0 @@
|
|||
bin/mrxvt
|
||||
etc/mrxvt/default.menu.sample
|
||||
etc/mrxvt/mrxvtrc.sample
|
||||
etc/mrxvt/submenus.menu.sample
|
||||
share/man/man1/mrxvt.1.gz
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README.greek
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README.menu
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README.xvt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/behind_mrxvt.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/hack-mrxvt.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/mrxvt_seq.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rxvtRef.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/xterm-ctlseqs.txt
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/mrxvtset.pl
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/settitle.c
|
||||
share/pixmaps/mrxvt-csh.png
|
||||
share/pixmaps/mrxvt-csh.xpm
|
||||
share/pixmaps/mrxvt-root.png
|
||||
share/pixmaps/mrxvt-root.xpm
|
||||
share/pixmaps/mrxvt.png
|
||||
share/pixmaps/mrxvt.xpm
|
|
@ -1,44 +1,56 @@
|
|||
PORTNAME= mrxvt
|
||||
PORTVERSION= 0.4.2
|
||||
PORTREVISION= 12
|
||||
DISTVERSION= 0.5.4
|
||||
CATEGORIES= x11
|
||||
MASTER_SITES= SF/materm/${PORTNAME}%20source/${PORTVERSION}
|
||||
MASTER_SITES= SF/materm/mrxvt%20source/${PORTVERSION}
|
||||
|
||||
MAINTAINER= bofh@FreeBSD.org
|
||||
COMMENT= Tabbed version of rxvt
|
||||
WWW= https://materm.sourceforge.net/
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
LIB_DEPENDS= libpng.so:graphics/png
|
||||
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig
|
||||
|
||||
USES= cpe jpeg localbase tar:tgz xorg
|
||||
CPE_VENDOR= ${PORTNAME}_project
|
||||
USE_XORG= x11
|
||||
USES= shebangfix xorg
|
||||
USE_XORG= ice x11 sm xpm xrender
|
||||
|
||||
SHEBANG_FILES= ${WRKSRC}/share/scripts/mrxvtset.pl
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
|
||||
CONFIGURE_ARGS= --disable-lastlog --disable-wtmp
|
||||
CONFIGURE_ARGS+= --enable-utempter --disable-lastlog
|
||||
|
||||
CONFLICTS= mrxvt-0.5.*
|
||||
CFLAGS+= -fcommon
|
||||
|
||||
PORTDOCS= TIPS \
|
||||
README.greek \
|
||||
README.menu \
|
||||
README.xvt \
|
||||
xdefaults-sample.txt \
|
||||
xterm.seq \
|
||||
mrxvt.vbs \
|
||||
mrxvtset.pl
|
||||
DESKTOP_ENTRIES= "mrxvt" "mrxvt terminal emulator" \
|
||||
"${PREFIX}/share/pixmaps/mrxvt.png" \
|
||||
"mrxvt" "Utility;TerminalEmulator;" \
|
||||
false
|
||||
SUB_FILES+= pkg-message
|
||||
|
||||
OPTIONS_DEFINE= DOCS JAPANESE XFT
|
||||
OPTIONS_DEFINE= XFT BACKGROUND JPEG PNG TRANSPARENCY SWAPSCREEN JAPANESE 24BITS \
|
||||
MENUBAR TEXTSHADOW FRILLS DOCS EXAMPLES
|
||||
OPTIONS_DEFAULT= BACKGROUND JPEG PNG TRANSPARENCY SWAPSCREEN 24BITS \
|
||||
MENUBAR XFT JAPANESE FRILLS TEXTSHADOW
|
||||
|
||||
JAPANESE_DESC= Japanese Language support
|
||||
24BITS_DESC= Prefer 24 bits color
|
||||
BACKGROUND_DESC= Background images
|
||||
FRILLS_DESC= Internal borders and smart resizing
|
||||
JAPANESE_DESC= Support for Japanese language
|
||||
MENUBAR_DESC= Menubar
|
||||
SWAPSCREEN_DESC= Swapscreen
|
||||
TEXTSHADOW_DESC= Text shadow
|
||||
TRANSPARENCY_DESC= Transparent background
|
||||
|
||||
24BITS_CONFIGURE_ON= --enable-24bits
|
||||
BACKGROUND_CONFIGURE_OFF= --disable-xpm
|
||||
FRILLS_CONFIGURE_ON= --enable-frills
|
||||
JAPANESE_CONFIGURE_ON= --enable-xim --enable-cjk --with-encoding=eucj
|
||||
XFT_LIB_DEPENDS= libXft.so:x11-fonts/libXft
|
||||
XFT_CONFIGURE_ENABLE= xft
|
||||
MENUBAR_CONFIGURE_ON= --enable-menubar
|
||||
SWAPSCREEN_CONFIGURE_OFF= --disable-swapscreen
|
||||
TEXTSHADOW_CONFIGURE_ON= --enable-text-shadow
|
||||
TRANSPARENCY_CONFIGURE_OFF= --disable-transparency
|
||||
XFT_USE= XORG=xft
|
||||
XFT_CONFIGURE_ON= --enable-xft
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
|
@ -46,6 +58,44 @@ XFT_CONFIGURE_ENABLE= xft
|
|||
USES+= iconv
|
||||
.endif
|
||||
|
||||
.if ! ${PORT_OPTIONS:MJPEG} || ! ${PORT_OPTIONS:MBACKGROUND}
|
||||
CONFIGURE_ARGS+= --disable-jpeg
|
||||
.else
|
||||
USES+= jpeg
|
||||
.endif
|
||||
|
||||
.if ! ${PORT_OPTIONS:MPNG} || ! ${PORT_OPTIONS:MBACKGROUND}
|
||||
CONFIGURE_ARGS+= --disable-png
|
||||
.else
|
||||
LIB_DEPENDS+= libpng.so:graphics/png
|
||||
.endif
|
||||
|
||||
## Rarely used options, not in the main menu
|
||||
# How many lines to save in the scroll buffer
|
||||
.if defined(SAVE_LINES)
|
||||
CONFIGURE_ARGS+= --with-save-lines=${SAVE_LINES:M[0-9]*}
|
||||
.endif
|
||||
|
||||
# Maximal number of terminals
|
||||
.if defined(MAX_TERMINALS)
|
||||
CONFIGURE_ARGS+= --with-max-term=${MAX_TERMINALS:M[0-9]*}
|
||||
.endif
|
||||
|
||||
# Maximal number of profiles
|
||||
.if defined(MAX_PROFILES)
|
||||
CONFIGURE_ARGS+= --with-max-profiles=${MAX_PROFILES:M[0-9]*}
|
||||
.endif
|
||||
|
||||
# Extra height of active tab as a percentage of the font height
|
||||
.if defined(EXTRA_ATAB_HEIGHT)
|
||||
CONFIGURE_ARGS+= --with-atab-extra=${EXTRA_ATAB_HEIGHT:M[0-9]*}
|
||||
.endif
|
||||
|
||||
# The radius of tab corners as a percentage of the font X offset
|
||||
.if defined(TAB_RADIUS)
|
||||
CONFIGURE_ARGS+= --with-tab-radius=${TAB_RADIUS:M[0-9]*}
|
||||
.endif
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if empty(ICONV_LIB)
|
||||
|
@ -54,4 +104,21 @@ CONFIGURE_ARGS+=ac_cv_lib_iconv_iconv_open=no
|
|||
CONFIGURE_ARGS+=ac_cv_lib_iconv_iconv_open=yes
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/src/mrxvt ${STAGEDIR}${PREFIX}/bin
|
||||
@for pixmap in ${WRKSRC}/share/pixmaps/* ; \
|
||||
do ${INSTALL_DATA} $$pixmap ${STAGEDIR}${PREFIX}/share/pixmaps/ ; \
|
||||
done
|
||||
${MKDIR} ${STAGEDIR}${PREFIX}/etc/mrxvt
|
||||
${INSTALL_DATA} ${WRKSRC}/share/mrxvtrc ${STAGEDIR}${PREFIX}/etc/mrxvt/mrxvtrc.sample
|
||||
${INSTALL_DATA} ${WRKSRC}/share/default.menu ${STAGEDIR}${PREFIX}/etc/mrxvt/default.menu.sample
|
||||
${INSTALL_DATA} ${WRKSRC}/share/submenus.menu ${STAGEDIR}${PREFIX}/etc/mrxvt/submenus.menu.sample
|
||||
${INSTALL_MAN} ${WRKSRC}/doc/mrxvt.1 ${STAGEDIR}${PREFIX}/share/man/man1
|
||||
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/scripts
|
||||
${INSTALL_DATA} ${WRKSRC}/share/scripts/mrxvtset.pl ${STAGEDIR}${EXAMPLESDIR}/scripts
|
||||
${INSTALL_DATA} ${WRKSRC}/share/scripts/settitle.c ${STAGEDIR}${EXAMPLESDIR}/scripts
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${CP} ${WRKSRC}/doc/*.bz2 ${STAGEDIR}${DOCSDIR}
|
||||
${BZIP2_CMD} -d ${STAGEDIR}${DOCSDIR}/*.bz2
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,2 +1,5 @@
|
|||
SHA256 (mrxvt-0.4.2.tgz) = a6d348670641b043aa3cb7b55c2f3ebb4fbb521f8134b67e0821991b959f1830
|
||||
SIZE (mrxvt-0.4.2.tgz) = 508718
|
||||
TIMESTAMP = 1710358992
|
||||
SHA256 (mrxvt-0.5.4.tar.gz) = f403ad5a908fcd38a55ed0a7e1b85584cb77be8781199653a39b8af1a9ad10d7
|
||||
SIZE (mrxvt-0.5.4.tar.gz) = 603978
|
||||
SHA256 (mrxvt-0.5.4-001-fix-segfault-when-wd-empty.patch) = 1b4e5c18d5c2ed6c9e1f198a97e058016b8e6589e1690d494c01bc899c010f30
|
||||
SIZE (mrxvt-0.5.4-001-fix-segfault-when-wd-empty.patch) = 380
|
||||
|
|
|
@ -1,25 +0,0 @@
|
|||
--- src/logging.c.orig 2004-11-11 00:20:28 UTC
|
||||
+++ src/logging.c
|
||||
@@ -114,14 +114,22 @@ rxvt_makeutent(rxvt_t *r, int page, const char *pty, c
|
||||
if (!STRNCMP(pty, "/dev/", 5))
|
||||
pty += 5; /* skip /dev/ prefix */
|
||||
|
||||
+#ifdef PTYS_ARE_OPENPTY
|
||||
+ if (!STRNCMP(pty, "pts", 3) || !STRNCMP(pty, "tty", 3)) {
|
||||
+#else
|
||||
if (!STRNCMP(pty, "pty", 3) || !STRNCMP(pty, "tty", 3)) {
|
||||
+#endif
|
||||
STRNCPY(ut_id, (pty + 3), sizeof(ut_id));
|
||||
}
|
||||
#ifdef HAVE_UTMP_PID
|
||||
else if (sscanf(pty, "pts/%d", &i) == 1)
|
||||
sprintf(ut_id, "vt%02x", (i & 0xff)); /* sysv naming */
|
||||
#endif
|
||||
+#ifdef PTYS_ARE_OPENPTY
|
||||
+ else if (!STRNCMP(pty, "pts", 3) || !STRNCMP(pty, "tty", 3)) {
|
||||
+#else
|
||||
else if (STRNCMP(pty, "pty", 3) && STRNCMP(pty, "tty", 3)) {
|
||||
+#endif
|
||||
rxvt_print_error("can't parse tty name \"%s\"", pty);
|
||||
return;
|
||||
}
|
|
@ -1,11 +0,0 @@
|
|||
--- src/main.c.orig 2005-08-31 05:30:41 UTC
|
||||
+++ src/main.c
|
||||
@@ -1568,7 +1568,7 @@ rxvt_set_utf8_property (rxvt_t* r, Atom prop, Window w
|
||||
void
|
||||
rxvt_set_utf8_property (rxvt_t* r, Atom prop, Window win, const char* str)
|
||||
{
|
||||
-#ifdef HAVE_WCHAR_H
|
||||
+#ifdef HAVE_WCHAR_H && _FreeBSD_version >= 500000
|
||||
wchar_t* ws = rxvt_mbstowcs (str);
|
||||
char* s = rxvt_wcstoutf8 (ws);
|
||||
|
|
@ -1,18 +0,0 @@
|
|||
--- src/strings.c.orig 2005-03-21 00:42:08 UTC
|
||||
+++ src/strings.c
|
||||
@@ -44,6 +44,7 @@
|
||||
|
||||
#ifdef HAVE_WCHAR_H
|
||||
/* EXTPROTO */
|
||||
+#if _FreeBSD_version >= 500000
|
||||
char*
|
||||
rxvt_wcstombs (const wchar_t* str, int len)
|
||||
{
|
||||
@@ -70,6 +71,7 @@ rxvt_wcstombs (const wchar_t* str, int len)
|
||||
|
||||
return r;
|
||||
}
|
||||
+#endif
|
||||
|
||||
|
||||
/* EXTPROTO */
|
11
x11/mrxvt/files/patch-src_tabbar.c
Normal file
11
x11/mrxvt/files/patch-src_tabbar.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/tabbar.c.orig 2024-03-13 19:45:34 UTC
|
||||
+++ src/tabbar.c
|
||||
@@ -1314,7 +1314,7 @@ rxvt_append_page( rxvt_t* r, int profile,
|
||||
if( p.we_wordc > 1)
|
||||
rxvt_msg( DBG_ERROR, DBG_TABBAR,
|
||||
"Too many words when expanding %s\n", cwdOption );
|
||||
- else
|
||||
+ else if( NOT_NULL( *p.we_wordv ) )
|
||||
{
|
||||
filename = *p.we_wordv;
|
||||
|
|
@ -1,5 +1,18 @@
|
|||
@(,,4511) bin/mrxvt
|
||||
bin/mrxvt
|
||||
etc/mrxvt/default.menu.sample
|
||||
etc/mrxvt/mrxvtrc.sample
|
||||
etc/mrxvt/submenus.menu.sample
|
||||
share/man/man1/mrxvt.1.gz
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README.greek
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README.menu
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README.xvt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/behind_mrxvt.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/hack-mrxvt.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/mrxvt_seq.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/rxvtRef.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/xterm-ctlseqs.txt
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/mrxvtset.pl
|
||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scripts/settitle.c
|
||||
share/pixmaps/mrxvt-csh.png
|
||||
share/pixmaps/mrxvt-csh.xpm
|
||||
share/pixmaps/mrxvt-root.png
|
||||
|
|
Loading…
Add table
Reference in a new issue