mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
dns/{,py}ldns, dns/p5-DNS-Ldns: update 1.8.3 → 1.8.4
The most prominent fix is for the bug where ldns would, under certain conditions, use a commented out resolver in /etc/resolv.conf: https://github.com/NLnetLabs/ldns/issues/237 Changelog: https://github.com/NLnetLabs/ldns/blob/1.8.4/Changelog PR: 280404 278721 MFH: 2024Q3
This commit is contained in:
parent
6599adc28f
commit
7fe9f4303f
5 changed files with 11 additions and 77 deletions
|
@ -1,6 +1,5 @@
|
|||
PORTNAME= ldns
|
||||
DISTVERSION= 1.8.3
|
||||
PORTREVISION= 1
|
||||
DISTVERSION= 1.8.4
|
||||
CATEGORIES= dns
|
||||
MASTER_SITES= https://www.nlnetlabs.nl/downloads/ldns/ \
|
||||
LOCAL/ehaupt
|
||||
|
@ -18,7 +17,6 @@ USE_LDCONFIG= yes
|
|||
|
||||
CPE_VENDOR= nlnetlabs
|
||||
GNU_CONFIGURE= yes
|
||||
GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
|
||||
CONFIGURE_ARGS+= --disable-dane-ta-usage \
|
||||
--with-ssl=${OPENSSLBASE}
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
|
@ -142,8 +140,8 @@ post-install:
|
|||
|
||||
.if (defined(BUILD_PYLDNS))
|
||||
post-install:
|
||||
# file /usr/local/lib/python3.9/site-packages/_ldns.so.3.5.0
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/${PYTHON_VERSION}/site-packages/_ldns.so.3.5.0
|
||||
# file /usr/local/lib/python3.11/site-packages/_ldns.so.3.6.0
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/${PYTHON_VERSION}/site-packages/_ldns.so.3.6.0
|
||||
.endif # BUILD_PYLDNS
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1660561209
|
||||
SHA256 (ldns-1.8.3.tar.gz) = c3f72dd1036b2907e3a56e6acf9dfb2e551256b3c1bbd9787942deeeb70e7860
|
||||
SIZE (ldns-1.8.3.tar.gz) = 1299856
|
||||
TIMESTAMP = 1721549282
|
||||
SHA256 (ldns-1.8.4.tar.gz) = 838b907594baaff1cd767e95466a7745998ae64bc74be038dccc62e2de2e4247
|
||||
SIZE (ldns-1.8.4.tar.gz) = 1301058
|
||||
|
|
|
@ -1,64 +0,0 @@
|
|||
Obtained from: https://github.com/NLnetLabs/ldns/pull/231
|
||||
|
||||
--- contrib/python/ldns_rdf.i.orig 2022-08-15 10:38:22 UTC
|
||||
+++ contrib/python/ldns_rdf.i
|
||||
@@ -50,6 +50,7 @@
|
||||
SWIGTYPE_p_ldns_struct_rdf, SWIG_POINTER_OWN | 0));
|
||||
}
|
||||
|
||||
+#if SWIG_VERSION < 0x040200
|
||||
/*
|
||||
* Automatic conversion of const (ldns_rdf *) parameter from string.
|
||||
* Argument default value.
|
||||
@@ -95,6 +96,51 @@
|
||||
SWIG_Python_str_DelForPy3($1_str); /* Is a empty macro for Python < 3. */
|
||||
}
|
||||
}
|
||||
+
|
||||
+#else
|
||||
+/*
|
||||
+ * Automatic conversion of const (ldns_rdf *) parameter from string.
|
||||
+ * Argument default value.
|
||||
+ */
|
||||
+%typemap(arginit, noblock=1) const ldns_rdf *
|
||||
+{
|
||||
+ PyObject *$1_bytes = NULL;
|
||||
+}
|
||||
+
|
||||
+/*
|
||||
+ * Automatic conversion of const (ldns_rdf *) parameter from string.
|
||||
+ * Preparation of arguments.
|
||||
+ */
|
||||
+%typemap(in, noblock=1) const ldns_rdf * (void* argp, $1_ltype tmp = 0, int res)
|
||||
+{
|
||||
+ if (Python_str_Check($input)) {
|
||||
+ const char *$1_str = SWIG_PyUnicode_AsUTF8AndSize($input, NULL, &$1_bytes);
|
||||
+ if ($1_str == NULL) {
|
||||
+ %argument_fail(SWIG_TypeError, "char *", $symname, $argnum);
|
||||
+ }
|
||||
+ tmp = ldns_dname_new_frm_str($1_str);
|
||||
+ if (tmp == NULL) {
|
||||
+ %argument_fail(SWIG_TypeError, "char *", $symname, $argnum);
|
||||
+ }
|
||||
+ $1 = ($1_ltype) tmp;
|
||||
+ } else {
|
||||
+ res = SWIG_ConvertPtr($input, &argp, SWIGTYPE_p_ldns_struct_rdf, 0 | 0);
|
||||
+ if (!SWIG_IsOK(res)) {
|
||||
+ %argument_fail(res, "ldns_rdf const *", $symname, $argnum);
|
||||
+ }
|
||||
+ $1 = ($1_ltype) argp;
|
||||
+ }
|
||||
+}
|
||||
+
|
||||
+/*
|
||||
+ * Automatic conversion of const (ldns_rdf *) parameter from string.
|
||||
+ * Freeing of allocated memory (it's a no op unless compiling for some older versions of the Python stable ABI).
|
||||
+ */
|
||||
+%typemap(freearg, noblock=1) const ldns_rdf *
|
||||
+{
|
||||
+ Py_XDECREF($1_bytes);
|
||||
+}
|
||||
+#endif
|
||||
|
||||
%nodefaultctor ldns_struct_rdf; /* No default constructor. */
|
||||
%nodefaultdtor ldns_struct_rdf; /* No default destructor. */
|
|
@ -61,7 +61,7 @@ include/ldns/zone.h
|
|||
lib/libldns.a
|
||||
lib/libldns.so
|
||||
lib/libldns.so.3
|
||||
lib/libldns.so.3.5.0
|
||||
lib/libldns.so.3.6.0
|
||||
libdata/pkgconfig/libldns.pc
|
||||
%%DRILL%%share/man/man1/drill.1.gz
|
||||
%%EXAMPLES%%share/man/man1/ldns-chaos.1.gz
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
%%PYTHON_SITELIBDIR%%/_ldns.so.3.5.0
|
||||
%%PYTHON_SITELIBDIR%%/_ldns.so.3
|
||||
%%PYTHON_SITELIBDIR%%/ldns.py
|
||||
%%PYTHON_SITELIBDIR%%/_ldns.so
|
||||
%%PYTHON_SITELIBDIR%%/_ldns.a
|
||||
%%PYTHON_SITELIBDIR%%/_ldns.so
|
||||
%%PYTHON_SITELIBDIR%%/_ldns.so.3
|
||||
%%PYTHON_SITELIBDIR%%/_ldns.so.3.6.0
|
||||
%%PYTHON_SITELIBDIR%%/ldns.py
|
||||
@dir %%PYTHON_SITELIBDIR%%/ldns
|
||||
|
|
Loading…
Add table
Reference in a new issue