mirror of
https://git.freebsd.org/ports.git
synced 2025-05-12 15:21:51 -04:00
databases/py-tiledb: Update to 0.31.1
Changes: https://github.com/TileDB-Inc/TileDB-Py/releases
This commit is contained in:
parent
ba7f3a5446
commit
7d92511cb3
5 changed files with 12 additions and 53 deletions
|
@ -1,5 +1,5 @@
|
|||
PORTNAME= tiledb
|
||||
PORTVERSION= 0.30.2
|
||||
PORTVERSION= 0.31.1
|
||||
CATEGORIES= databases python
|
||||
MASTER_SITES= PYPI
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -14,15 +14,14 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
|
|||
|
||||
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.25,1:math/py-numpy@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}pybind11>=0:devel/py-pybind11@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}setuptools>=61:devel/py-setuptools@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}scikit-build-core>=0:devel/py-scikit-build-core@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}setuptools-scm>=1.5.4:devel/py-setuptools-scm@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}wheel>=0.30:devel/py-wheel@${PY_FLAVOR} \
|
||||
tiledb>=2.24.2:databases/tiledb
|
||||
tiledb>=2.25.0:databases/tiledb
|
||||
LIB_DEPENDS= libtiledb.so:databases/tiledb
|
||||
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.25,1:math/py-numpy@${PY_FLAVOR} \
|
||||
${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR}
|
||||
|
||||
USES= compiler:c++17-lang localbase python
|
||||
USES= cmake:indirect compiler:c++17-lang localbase python
|
||||
USE_PYTHON= autoplist concurrent cython pep517
|
||||
|
||||
MAKE_ENV= TILEDB_PATH=${LOCALBASE}
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1720447662
|
||||
SHA256 (tiledb-0.30.2.tar.gz) = 8a70e62b1cea6a1bba8afb1d36a635e9c5435db733944fb4e6d7493fa1d914a3
|
||||
SIZE (tiledb-0.30.2.tar.gz) = 345280
|
||||
TIMESTAMP = 1722711191
|
||||
SHA256 (tiledb-0.31.1.tar.gz) = 7b9ddd32c4c7437111764645d8a042d603102a813c8b89addaf9a15bd40dd939
|
||||
SIZE (tiledb-0.31.1.tar.gz) = 365917
|
||||
|
|
|
@ -1,18 +1,11 @@
|
|||
--- pyproject.toml.orig 2024-06-11 17:54:39 UTC
|
||||
--- pyproject.toml.orig 2022-11-09 12:37:21 UTC
|
||||
+++ pyproject.toml
|
||||
@@ -1,13 +1,13 @@ requires = [
|
||||
[build-system]
|
||||
requires = [
|
||||
- "setuptools>=64",
|
||||
+ "setuptools>=61",
|
||||
"wheel",
|
||||
"pybind11",
|
||||
"Cython",
|
||||
@@ -6,7 +6,7 @@ requires = [
|
||||
"numpy==1.17.* ; python_version == '3.8' and platform_machine not in 'arm64|aarch64'",
|
||||
"numpy==1.19.* ; python_version == '3.8' and platform_machine == 'aarch64'",
|
||||
"numpy==1.21.* ; python_version == '3.8' and platform_machine == 'arm64'",
|
||||
- "numpy>=2.0.0rc2 ; python_version >= '3.9'",
|
||||
+ "numpy>=1.25 ; python_version >= '3.9'",
|
||||
- "numpy>=2.0.0rc2 ; python_version >= '3.9'"
|
||||
+ "numpy>=1.25; python_version >= '3.9'"
|
||||
]
|
||||
build-backend = "setuptools.build_meta"
|
||||
build-backend = "scikit_build_core.build"
|
||||
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
--- requirements_dev.txt.orig 2024-06-11 17:54:39 UTC
|
||||
+++ requirements_dev.txt
|
||||
@@ -6,14 +6,10 @@ numpy>=1.25 ; python_version >= '3.9'
|
||||
# ------------------------------------------------
|
||||
# ** MUST sync with misc/requirements_wheel.txt **
|
||||
# ------------------------------------------------
|
||||
-build
|
||||
-cmake >= 3.23
|
||||
cython
|
||||
pybind11
|
||||
-setuptools >= 64
|
||||
+setuptools >= 61
|
||||
setuptools_scm >= 8
|
||||
wheel >= 0.30
|
||||
contextvars ;python_version<"3.7"
|
||||
dataclasses ;python_version<"3.7"
|
||||
-pytest
|
||||
--r misc/requirements_test.txt
|
|
@ -1,15 +0,0 @@
|
|||
--- setup.py.orig 2023-01-04 19:23:00 UTC
|
||||
+++ setup.py
|
||||
@@ -555,12 +555,6 @@ def setup_requires():
|
||||
req = parse_requirements("requirements_dev.txt")
|
||||
req = list(filter(lambda r: not r.startswith("-r"), req))
|
||||
|
||||
- req_cmake = list(filter(lambda r: "cmake" in r, req))[0]
|
||||
-
|
||||
- # Add cmake requirement if libtiledb is not found and cmake is not available.
|
||||
- if not libtiledb_exists(LIB_DIRS) and not cmake_available():
|
||||
- req.append(req_cmake)
|
||||
-
|
||||
return req
|
||||
|
||||
|
Loading…
Add table
Reference in a new issue