mirror of
https://git.freebsd.org/ports.git
synced 2025-05-25 07:26:29 -04:00
Bump port version to the 1.1.5, using sources that come together with
net/samba4-devel.
This commit is contained in:
parent
ff368cb1d9
commit
7cc2dd23f0
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=237650
6 changed files with 44 additions and 118 deletions
|
@ -1,26 +1,47 @@
|
|||
# ex:ts=8
|
||||
# Ports collection makefile for: tdb
|
||||
# Date created: Oct 12, 2002
|
||||
# Whom: ijliao
|
||||
# New ports collection makefile for: tdb
|
||||
# Date created: 1 May 2009
|
||||
# Whom: Koop Mast <kwm@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= tdb
|
||||
PORTVERSION= 1.0.6
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= ${PORTNAME}
|
||||
PORTNAME= tdb
|
||||
PORTVERSION= 1.1.5
|
||||
PORTREVISION= 0
|
||||
PORTEPOCH= 0
|
||||
CATEGORIES= databases
|
||||
PKGNAMESUFFIX=
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Trivial Database
|
||||
COMMENT= Trivial Database
|
||||
|
||||
USE_AUTOTOOLS= automake:14 autoconf:213 libtool:15
|
||||
USE_LDCONFIG= yes
|
||||
CONFLICTS=
|
||||
|
||||
MAN3= tdb.3 tdb_chainlock.3 tdb_close.3 tdb_delete.3 tdb_error.3 \
|
||||
tdb_exists.3 tdb_fetch.3 tdb_firstkey.3 tdb_open.3 tdb_store.3 \
|
||||
tdb_traverse.3
|
||||
SAMBA_PORT?= samba4-devel
|
||||
SAMBA_SUBPORT= yes
|
||||
|
||||
.include <bsd.port.mk>
|
||||
MASTERDIR= ${.CURDIR}/../../net/${SAMBA_PORT}
|
||||
PKGDIR= ${.CURDIR}
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/lib/tdb
|
||||
|
||||
USE_PYTHON= yes
|
||||
USE_GMAKE= yes
|
||||
USE_LDCONFIG= yes
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GNOME= pkgconfig
|
||||
USE_AUTOTOOLS= autoconf:262 autoheader:262
|
||||
|
||||
PLIST_FILES= bin/tdbbackup \
|
||||
bin/tdbdump \
|
||||
bin/tdbtool \
|
||||
include/tdb.h \
|
||||
lib/libtdb.a \
|
||||
lib/libtdb.so \
|
||||
lib/libtdb.so.1 \
|
||||
libdata/pkgconfig/tdb.pc \
|
||||
${PYTHONPREFIX_SITELIBDIR:S|${PREFIX}/||}/tdb.so
|
||||
|
||||
post-install:
|
||||
@${LN} -sf libtdb.so.1 ${PREFIX}/lib/libtdb.so
|
||||
|
||||
.include "${MASTERDIR}/Makefile"
|
||||
|
|
|
@ -1,3 +0,0 @@
|
|||
MD5 (tdb-1.0.6.tar.gz) = 6b643fdeb48304010dcd5f675e458b58
|
||||
SHA256 (tdb-1.0.6.tar.gz) = 235bd4f82321675779b0ed099753d0835b0f3e53bc45846f372fd51350252bb2
|
||||
SIZE (tdb-1.0.6.tar.gz) = 139948
|
|
@ -1,42 +0,0 @@
|
|||
--- configure.in.orig 2002-09-03 07:48:38.000000000 +1000
|
||||
+++ configure.in 2002-09-03 07:45:23.000000000 +1000
|
||||
@@ -18,13 +18,14 @@
|
||||
AC_CHECK_LIB(gdbm, gdbm_open,
|
||||
[have_gdbm=true],[have_gdbm=false])
|
||||
if test "x$have_gdbm" = "xfalse";then
|
||||
- AC_MSG_WARN(WARNING: tdbtest is disabled. It needs gdbm.)
|
||||
+ AC_MSG_WARN(WARNING: tdbspeed and tdbtest are disabled. They need gdbm.)
|
||||
fi
|
||||
AC_CHECK_LIB(dl, dlopen,[have_dllib=true],[have_dllib=false])
|
||||
if test "x$have_dllib" = "xfalse";then
|
||||
AC_MSG_WARN(WARNING: tdbtorture is disabled. It needs libdl.)
|
||||
fi
|
||||
|
||||
+AM_CONDITIONAL(BUILD_TDBSPEED,$have_gdbm)
|
||||
AM_CONDITIONAL(BUILD_TDBTEST,$have_gdbm)
|
||||
AM_CONDITIONAL(BUILD_TDBTORTURE,$have_dllib)
|
||||
|
||||
--- Makefile.am.orig 2002-09-03 07:48:50.000000000 +1000
|
||||
+++ Makefile.am 2002-09-03 07:42:58.000000000 +1000
|
||||
@@ -1,6 +1,12 @@
|
||||
CFLAGS = @CFLAGS@ @WARNS@
|
||||
LDADD=libtdb.la
|
||||
|
||||
+if BUILD_TDBSPEED
|
||||
+TDBSPEED = tdbspeed
|
||||
+else
|
||||
+TDBSPEED =
|
||||
+endif
|
||||
+
|
||||
if BUILD_TDBTEST
|
||||
TDBTEST = tdbtest
|
||||
else
|
||||
@@ -13,7 +19,7 @@
|
||||
TDBTORTURE =
|
||||
endif
|
||||
|
||||
-noinst_PROGRAMS=tdbspeed tdbiterate $(TDBTEST) $(TDBTORTURE)
|
||||
+noinst_PROGRAMS=tdbiterate $(TDBSPEED) $(TDBTEST) $(TDBTORTURE)
|
||||
bin_PROGRAMS=tdbtool tdbdump
|
||||
|
||||
lib_LTLIBRARIES=libtdb.la
|
|
@ -1,43 +0,0 @@
|
|||
--- tdbtool.c~ Tue Dec 11 04:45:47 2001
|
||||
+++ tdbtool.c Sun Aug 17 18:49:00 2003
|
||||
@@ -169,23 +169,23 @@
|
||||
|
||||
static void help(void)
|
||||
{
|
||||
- printf("
|
||||
-tdbtool:
|
||||
- create dbname : create a database
|
||||
- open dbname : open an existing database
|
||||
- erase : erase the database
|
||||
- dump dumpname : dump the database as strings
|
||||
- insert key data : insert a record
|
||||
- store key data : store a record (replace)
|
||||
- show key : show a record by key
|
||||
- delete key : delete a record by key
|
||||
- list : print the database hash table and freelist
|
||||
- free : print the database freelist
|
||||
- 1 | first : print the first record
|
||||
- n | next : print the next record
|
||||
- q | quit : terminate
|
||||
- \\n : repeat 'next' command
|
||||
-");
|
||||
+ puts("");
|
||||
+ puts("tdbtool: ");
|
||||
+ puts(" create dbname : create a database");
|
||||
+ puts(" open dbname : open an existing database");
|
||||
+ puts(" erase : erase the database");
|
||||
+ puts(" dump dumpname : dump the database as strings");
|
||||
+ puts(" insert key data : insert a record");
|
||||
+ puts(" store key data : store a record (replace)");
|
||||
+ puts(" show key : show a record by key");
|
||||
+ puts(" delete key : delete a record by key");
|
||||
+ puts(" list : print the database hash table and freelist");
|
||||
+ puts(" free : print the database freelist");
|
||||
+ puts(" 1 | first : print the first record");
|
||||
+ puts(" n | next : print the next record");
|
||||
+ puts(" q | quit : terminate");
|
||||
+ puts(" \\n : repeat 'next' command");
|
||||
+ puts("");
|
||||
}
|
||||
|
||||
static void terror(char *why)
|
|
@ -1,6 +1,6 @@
|
|||
TDB is a Trivial Database. In concept, it is very much like GDBM, and BSD's
|
||||
DB except that it allows multiple simultaneous writers and uses locking
|
||||
internally to keep writers from trampling on each other. TDB is also extremely
|
||||
small.
|
||||
TDB is a Trivial Database. In concept, it is very much like GDBM, and
|
||||
BSD's DB except that it allows multiple simultaneous writers and uses
|
||||
locking internally to keep writers from trampling on each other. TDB is
|
||||
also extremely small.
|
||||
|
||||
WWW: http://sourceforge.net/projects/tdb/
|
||||
WWW: http://tdb.samba.org/
|
||||
|
|
|
@ -1,7 +0,0 @@
|
|||
bin/tdbtool
|
||||
bin/tdbdump
|
||||
include/tdb.h
|
||||
lib/libtdb.a
|
||||
lib/libtdb.la
|
||||
lib/libtdb.so
|
||||
lib/libtdb.so.1
|
Loading…
Add table
Reference in a new issue