mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
mfmod_openmetrics: new port had been added (+)
Loadable module for mailfromd which adds OpenMetrics support to the mail filtering language (MFL). Requested by: maintainer
This commit is contained in:
parent
61f8384677
commit
7ad6ea4dd4
5 changed files with 62 additions and 0 deletions
|
@ -227,6 +227,7 @@
|
||||||
SUBDIR += mew
|
SUBDIR += mew
|
||||||
SUBDIR += mew-devel
|
SUBDIR += mew-devel
|
||||||
SUBDIR += mfmod_ldap
|
SUBDIR += mfmod_ldap
|
||||||
|
SUBDIR += mfmod_openmetrics
|
||||||
SUBDIR += mfmod_pcre
|
SUBDIR += mfmod_pcre
|
||||||
SUBDIR += milter-bogom
|
SUBDIR += milter-bogom
|
||||||
SUBDIR += milter-callback
|
SUBDIR += milter-callback
|
||||||
|
|
36
mail/mfmod_openmetrics/Makefile
Normal file
36
mail/mfmod_openmetrics/Makefile
Normal file
|
@ -0,0 +1,36 @@
|
||||||
|
PORTNAME= mfmod_openmetrics
|
||||||
|
PORTVERSION= 1.2
|
||||||
|
CATEGORIES= mail
|
||||||
|
MASTER_SITES= http://download.gnu.org.ua/pub/release/${PORTNAME}/ \
|
||||||
|
http://download.gnu.org.ua/pub/alpha/${PORTNAME}/
|
||||||
|
|
||||||
|
MAINTAINER= zeus@gnu.org.ua
|
||||||
|
COMMENT= OpenMetrics support loadable module for mailfromd
|
||||||
|
WWW= https://puszcza.gnu.org.ua/projects/mfmod_openmetrics/
|
||||||
|
|
||||||
|
LICENSE= GPLv3+
|
||||||
|
|
||||||
|
BUILD_DEPENDS= ${LOCALBASE}/include/mailfromd/mfmod.h:mail/mailfromd
|
||||||
|
LIB_DEPENDS= libgdbm.so:databases/gdbm \
|
||||||
|
libmicrohttpd.so:www/libmicrohttpd
|
||||||
|
|
||||||
|
USES= libtool localbase
|
||||||
|
GNU_CONFIGURE= yes
|
||||||
|
INSTALL_TARGET= install-strip
|
||||||
|
TEST_TARGET= check
|
||||||
|
|
||||||
|
INFO= ${PORTNAME}
|
||||||
|
PLIST_FILES= lib/mailfromd/mfmod_openmetrics.so \
|
||||||
|
share/mailfromd/openmetrics.mfl
|
||||||
|
PORTDOCS= NEWS README
|
||||||
|
|
||||||
|
OPTIONS_DEFINE= DOCS
|
||||||
|
|
||||||
|
post-patch:
|
||||||
|
@${REINPLACE_CMD} -e '/sed -n/s,p},p;},' ${WRKSRC}/configure
|
||||||
|
|
||||||
|
post-install-DOCS-on:
|
||||||
|
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||||
|
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
|
||||||
|
|
||||||
|
.include <bsd.port.mk>
|
3
mail/mfmod_openmetrics/distinfo
Normal file
3
mail/mfmod_openmetrics/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
||||||
|
TIMESTAMP = 1687803559
|
||||||
|
SHA256 (mfmod_openmetrics-1.2.tar.gz) = fb77badaf0a667577a170562706e14558e6bf4529955052d1fe837c7ca83c55f
|
||||||
|
SIZE (mfmod_openmetrics-1.2.tar.gz) = 508393
|
20
mail/mfmod_openmetrics/files/patch-mfmod__openmetrics.c
Normal file
20
mail/mfmod_openmetrics/files/patch-mfmod__openmetrics.c
Normal file
|
@ -0,0 +1,20 @@
|
||||||
|
--- mfmod_openmetrics.c.orig 2023-02-10 08:24:56 UTC
|
||||||
|
+++ mfmod_openmetrics.c
|
||||||
|
@@ -992,7 +992,7 @@ openmetrics_set(long count, MFMOD_PARAM *p, MFMOD_PARA
|
||||||
|
/*
|
||||||
|
* Server
|
||||||
|
*/
|
||||||
|
-static int
|
||||||
|
+static enum MHD_Result
|
||||||
|
reassemble_get_args(void *cls, enum MHD_ValueKind kind,
|
||||||
|
const char *key, const char *value)
|
||||||
|
{
|
||||||
|
@@ -1373,7 +1373,7 @@ http_response(struct MHD_Connection *conn,
|
||||||
|
return ret;
|
||||||
|
}
|
||||||
|
|
||||||
|
-static int
|
||||||
|
+static enum MHD_Result
|
||||||
|
openmetrics_httpd_handler(void *cls,
|
||||||
|
struct MHD_Connection *conn,
|
||||||
|
const char *url, const char *method,
|
2
mail/mfmod_openmetrics/pkg-descr
Normal file
2
mail/mfmod_openmetrics/pkg-descr
Normal file
|
@ -0,0 +1,2 @@
|
||||||
|
This package is a loadable module for mailfromd which adds OpenMetrics
|
||||||
|
support to the mail filtering language (MFL).
|
Loading…
Add table
Reference in a new issue