mirror of
https://git.freebsd.org/ports.git
synced 2025-05-12 23:31:50 -04:00
This is the new, shiny frontend for Cura. Check daid/LegacyCura for the
legacy Cura that everyone knows and loves/hates. We re-worked the whole GUI code at Ultimaker, because the old code started to become unmaintainable. WWW: https://github.com/Ultimaker/Cura/wiki
This commit is contained in:
parent
8d4d453671
commit
766e701f48
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=529142
7 changed files with 3112 additions and 0 deletions
|
@ -20,6 +20,7 @@
|
||||||
SUBDIR += cascade
|
SUBDIR += cascade
|
||||||
SUBDIR += cascade-compiler
|
SUBDIR += cascade-compiler
|
||||||
SUBDIR += chipvault
|
SUBDIR += chipvault
|
||||||
|
SUBDIR += cura
|
||||||
SUBDIR += cura-engine
|
SUBDIR += cura-engine
|
||||||
SUBDIR += digital
|
SUBDIR += digital
|
||||||
SUBDIR += dinotrace
|
SUBDIR += dinotrace
|
||||||
|
|
41
cad/cura/Makefile
Normal file
41
cad/cura/Makefile
Normal file
|
@ -0,0 +1,41 @@
|
||||||
|
# $FreeBSD$
|
||||||
|
|
||||||
|
PORTNAME= Cura
|
||||||
|
DISTVERSION= 15.06.03-82
|
||||||
|
DISTVERSIONSUFFIX= -g7c70ace
|
||||||
|
PORTEPOCH= 1
|
||||||
|
CATEGORIES= cad
|
||||||
|
DIST_SUBDIR= Ultimaker
|
||||||
|
|
||||||
|
MAINTAINER= db@db.net
|
||||||
|
COMMENT= Slicing application for 3D printers
|
||||||
|
|
||||||
|
LICENSE= AGPLv3
|
||||||
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||||
|
|
||||||
|
BUILD_DEPENDS= Uranium>0:cad/uranium
|
||||||
|
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}qt5-gui>0:x11-toolkits/py-qt5-gui@${PY_FLAVOR} \
|
||||||
|
${PYTHON_PKGNAMEPREFIX}qt5-widgets>0:x11-toolkits/py-qt5-widgets@${PY_FLAVOR} \
|
||||||
|
${PYTHON_PKGNAMEPREFIX}qt5-qml>0:lang/py-qt5-qml@${PY_FLAVOR} \
|
||||||
|
${PYTHON_PKGNAMEPREFIX}zeroconf>0:net/py-zeroconf@${PY_FLAVOR} \
|
||||||
|
${PYTHON_PKGNAMEPREFIX}Shapely>0:devel/py-shapely@${PY_FLAVOR} \
|
||||||
|
Uranium>0:cad/uranium \
|
||||||
|
libCharon>0:net/libcharon \
|
||||||
|
fdm_materials>0:cad/fdm_materials \
|
||||||
|
${PYTHON_PKGNAMEPREFIX}trimesh>0:devel/py-trimesh@${PY_FLAVOR}
|
||||||
|
LIB_DEPENDS= libArcus.so:net/libarcus \
|
||||||
|
libSavitar.so:devel/libsavitar
|
||||||
|
|
||||||
|
USES= cmake gettext shebangfix python:3.4+ desktop-file-utils shared-mime-info
|
||||||
|
CMAKE_ARGS+= -DURANIUM_SCRIPTS_DIR:STRING="${LOCALBASE}/share/uranium/scripts"
|
||||||
|
USE_GITHUB= yes
|
||||||
|
GH_ACCOUNT= Ultimaker
|
||||||
|
USE_GITHUB= yes
|
||||||
|
GH_TAGNAME= 7c70ace
|
||||||
|
NO_ARCH= yes
|
||||||
|
|
||||||
|
post-patch:
|
||||||
|
${REINPLACE_CMD} -e 's|%%PYTHON_CMD%%|${PYTHON_CMD}|' \
|
||||||
|
${WRKSRC}/cura_app.py
|
||||||
|
|
||||||
|
.include <bsd.port.mk>
|
3
cad/cura/distinfo
Normal file
3
cad/cura/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
||||||
|
TIMESTAMP = 1584382896
|
||||||
|
SHA256 (Ultimaker/Ultimaker-Cura-15.06.03-82-g7c70ace-7c70ace_GH0.tar.gz) = 74123ef60aad0a03c334726bd4f6161761324894156a354f2c3c3cb7a4a14d2d
|
||||||
|
SIZE (Ultimaker/Ultimaker-Cura-15.06.03-82-g7c70ace-7c70ace_GH0.tar.gz) = 34919081
|
24
cad/cura/files/patch-CMakeLists.txt
Normal file
24
cad/cura/files/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,24 @@
|
||||||
|
--- CMakeLists.txt.orig 2020-02-28 16:06:57 UTC
|
||||||
|
+++ CMakeLists.txt
|
||||||
|
@@ -6,8 +6,9 @@ include(GNUInstallDirs)
|
||||||
|
list(APPEND CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake)
|
||||||
|
|
||||||
|
set(URANIUM_DIR "${CMAKE_SOURCE_DIR}/../Uranium" CACHE PATH "The location of the Uranium repository")
|
||||||
|
-set(URANIUM_SCRIPTS_DIR "${URANIUM_DIR}/scripts" CACHE PATH "The location of the scripts directory of the Uranium repository")
|
||||||
|
-
|
||||||
|
+if(NOT DEFINED URANIUM_SCRIPTS_DIR)
|
||||||
|
+ set(URANIUM_SCRIPTS_DIR "${URANIUM_DIR}/scripts" CACHE PATH "The location of the scripts directory of the Uranium repository")
|
||||||
|
+endif()
|
||||||
|
# Tests
|
||||||
|
include(CuraTests)
|
||||||
|
|
||||||
|
@@ -67,6 +68,9 @@ install(DIRECTORY resources
|
||||||
|
|
||||||
|
include(CuraPluginInstall)
|
||||||
|
|
||||||
|
+if(CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
|
||||||
|
+ set(FREEBSD True)
|
||||||
|
+endif()
|
||||||
|
if(NOT APPLE AND NOT WIN32)
|
||||||
|
install(FILES cura_app.py
|
||||||
|
DESTINATION ${CMAKE_INSTALL_BINDIR}
|
8
cad/cura/files/patch-cura__app.py
Normal file
8
cad/cura/files/patch-cura__app.py
Normal file
|
@ -0,0 +1,8 @@
|
||||||
|
--- cura_app.py.orig 2020-02-28 16:06:57 UTC
|
||||||
|
+++ cura_app.py
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-#!/usr/bin/env python3
|
||||||
|
+#!/usr/bin/env %%PYTHON_CMD%%
|
||||||
|
|
||||||
|
# Copyright (c) 2019 Ultimaker B.V.
|
||||||
|
# Cura is released under the terms of the LGPLv3 or higher.
|
6
cad/cura/pkg-descr
Normal file
6
cad/cura/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
||||||
|
This is the new, shiny frontend for Cura. Check daid/LegacyCura for the
|
||||||
|
legacy Cura that everyone knows and loves/hates. We re-worked the
|
||||||
|
whole GUI code at Ultimaker, because the old code started to become
|
||||||
|
unmaintainable.
|
||||||
|
|
||||||
|
WWW: https://github.com/Ultimaker/Cura/wiki
|
3029
cad/cura/pkg-plist
Normal file
3029
cad/cura/pkg-plist
Normal file
File diff suppressed because it is too large
Load diff
Loading…
Add table
Reference in a new issue