mirror of
https://git.freebsd.org/ports.git
synced 2025-05-25 07:26:29 -04:00
Update to 1.31.18. PR: ports/41224 after very long maintainer timeout.
This commit is contained in:
parent
9a4ad553c6
commit
74f73a6c73
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=93207
7 changed files with 27 additions and 151 deletions
|
@ -6,15 +6,17 @@
|
|||
#
|
||||
|
||||
PORTNAME= yodl
|
||||
PORTVERSION= 1.22
|
||||
PORTVERSION= 1.31.18
|
||||
CATEGORIES= textproc
|
||||
MASTER_SITES= ftp://ftp.sco.com/skunkware/src/textproc/ \
|
||||
ftp://ftp.sunsite.org.uk/Mirrors/ftp.sco.com/skunkware/src/textproc/ \
|
||||
ftp://ftp.vse.cz/pub/.sd10c/SCO/ftp.sco.com/skunkware/src/textproc/ \
|
||||
ftp://ftp.netsw.org/netsw/Typesetting/ASCII/Generate/ \
|
||||
ftp://ftp.win.ne.jp/pub/misc/ \
|
||||
ftp://ftp.eos.hokudai.ac.jp/pub/misc/ \
|
||||
ftp://ftp.sunet.se/pub3/vendor/sco/skunkware/src/textproc/
|
||||
MASTER_SITES= ftp://ftp.lilypond.org/pub/yodl/development/ \
|
||||
http://www.foad.org/zsh/zsh/ \
|
||||
http://www.zsh.org/pub/GPL/ \
|
||||
http://mirrors.sunsite.dk/ \
|
||||
http://www.math.technion.ac.il/pub/zsh/GPL/ \
|
||||
http://litterbug.lut.ac.uk/zsh/ \
|
||||
http://ftp.rge.com/pub/shells/zsh/GPL/ \
|
||||
http://ftp.dmz.digex.net/pub/packages/ \
|
||||
http://linux.sarang.net/ftp/mirror/system/shell/zsh/GPL/
|
||||
|
||||
MAINTAINER= dburr@FreeBSD.org
|
||||
COMMENT= An easy to use but powerful document formatting/preparation language
|
||||
|
@ -24,21 +26,17 @@ BUILD_DEPENDS= latex:${PORTSDIR}/print/latex \
|
|||
RUN_DEPENDS= latex:${PORTSDIR}/print/latex \
|
||||
dvips:${PORTSDIR}/print/dvips
|
||||
|
||||
ALL_TARGET= progs manpages misc/striproff
|
||||
INSTALL_TARGET= installman installmanual
|
||||
GNU_CONFIGURE= yes
|
||||
USE_GMAKE= yes
|
||||
MAKEFILE= GNUmakefile
|
||||
|
||||
MAN1= yodl.1 \
|
||||
striproff.1 \
|
||||
yodlconverters.1
|
||||
MAN5= yodl.5
|
||||
MAN7= yodlmacros.7 \
|
||||
yodlmanpage.7
|
||||
|
||||
do-build:
|
||||
(cd ${WRKSRC} && ${SETENV} CFLAGS="${CFLAGS}" ${GMAKE} PREFIX=${PREFIX} progs)
|
||||
(cd ${WRKSRC}/misc && gcc ${CFLAGS} -s -o striproff striproff.c)
|
||||
|
||||
post-install:
|
||||
@${INSTALL_PROGRAM} ${WRKSRC}/misc/striproff ${PREFIX}/bin
|
||||
@${INSTALL_SCRIPT} ${WRKSRC}/scripts/out/striproff ${PREFIX}/bin
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1 +1 @@
|
|||
MD5 (yodl-1.22.tar.gz) = 04f46f2ae4d1823865ef14fec9998b84
|
||||
MD5 (yodl-1.31.18.tar.gz) = 247c5bf178baeb1f0b96511323f30a61
|
||||
|
|
|
@ -1,50 +0,0 @@
|
|||
--- Makefile Thu Apr 22 17:49:36 1999
|
||||
+++ Makefile.new Thu Jun 8 21:21:07 2000
|
||||
@@ -6,16 +6,17 @@
|
||||
|
||||
# A `lib' directory under which ...../yodl will be attached, as the
|
||||
# system-wide include directory for macros of the yodl program?
|
||||
-LIBDIR=/usr/local/lib
|
||||
+LOCALBASE?=/usr/local
|
||||
+LIBDIR=${LOCALBASE}/lib
|
||||
|
||||
# To what directory are the yodl program and all shell scripts installed?
|
||||
-BINDIR = /usr/local/bin
|
||||
+BINDIR = ${LOCALBASE}/bin
|
||||
|
||||
# Where do your man pages go? MANPREFIX is where the subdirs man1, man2 etc.
|
||||
# are located, CATPREFIX is where subdirs cat1, cat2 etc. are, that's
|
||||
# where formatted pages go.
|
||||
-MANPREFIX=/usr/local/man
|
||||
-CATPREFIX=/usr/local/man
|
||||
+MANPREFIX=${LOCALBASE}/man
|
||||
+CATPREFIX=${LOCALBASE}/man
|
||||
|
||||
# What's your LaTeX command? The shellscript "yodl2dvi" will run "yodl2tex" and
|
||||
# your LaTeX-er for you, creating the .dvi file. LaTeX is also used in
|
||||
@@ -37,13 +38,13 @@
|
||||
|
||||
# What's your pager, a-la "less"? Will be used in the "yodl2manless"
|
||||
# and "yodl2msless" scripts that show groff output in ASCII via a pager.
|
||||
-LESS = less
|
||||
+LESS = more
|
||||
|
||||
# The C compiler?
|
||||
-CC = cc
|
||||
+CC ?= cc
|
||||
|
||||
# Compiler flags?
|
||||
-CFLAGS = -c -O2 -Kalloca
|
||||
+CFLAGS += -c
|
||||
|
||||
# Installation program? If you don't have install, make sure that you state
|
||||
# something that also strips executables.
|
||||
@@ -81,7 +82,7 @@
|
||||
# shell will do too, but I suggest that you get bash if you don't have it
|
||||
# yet. I have it installed as /bin/sh, lucky me.
|
||||
# Define the path of your bash below:
|
||||
-BASH = /bin/bash
|
||||
+BASH = /bin/sh
|
||||
|
||||
# Some systems seem to lack the function strerror() (I've heard of SunOS 4.1.4
|
||||
# with GCC 2.6). If that's the case, uncomment the following:
|
|
@ -1,10 +0,0 @@
|
|||
--- src/yodlfixlabels/yodlfixlabels.h Wed Oct 16 03:38:41 1996
|
||||
+++ src/yodlfixlabels/yodlfixlabels.h.new Thu Jun 8 21:23:20 2000
|
||||
@@ -1,7 +1,6 @@
|
||||
|
||||
/* required standard includes */
|
||||
#include <ctype.h>
|
||||
-#include <malloc.h>
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
|
@ -1,47 +0,0 @@
|
|||
--- manpages/Makefile.in.orig Fri Jan 24 05:42:52 1997
|
||||
+++ manpages/Makefile.in Fri Mar 3 10:01:20 2000
|
||||
@@ -7,4 +7,2 @@
|
||||
|
||||
-SHELL=__BASH__
|
||||
-
|
||||
man1=$(MANPREFIX)/man1
|
||||
@@ -24,6 +22,6 @@
|
||||
yodl.man: yodl.yo ../Makefile
|
||||
- yodl2man $<
|
||||
+ yodl2man yodl.yo
|
||||
|
||||
$(man1)/yodl.1: yodl.man
|
||||
- cp $< $@
|
||||
+ cp yodl.man $@
|
||||
|
||||
@@ -34,6 +32,6 @@
|
||||
yodlconverters.man: yodlconverters.yo ../Makefile
|
||||
- yodl2man $<
|
||||
+ yodl2man yodlconverters.yo
|
||||
|
||||
$(man1)/yodlconverters.1: yodlconverters.man
|
||||
- cp $< $@
|
||||
+ cp yodlconverters.man $@
|
||||
|
||||
@@ -48,3 +46,3 @@
|
||||
$(man7)/yodlmacros.7: yodlmacros.man
|
||||
- cp $< $@
|
||||
+ cp yodlmacros.man $@
|
||||
|
||||
@@ -55,6 +53,6 @@
|
||||
yodlmanpage.man: yodlmanpage.yo ../Makefile
|
||||
- yodl2man $<
|
||||
+ yodl2man yodlmanpage.yo
|
||||
|
||||
$(man7)/yodlmanpage.7: yodlmanpage.man
|
||||
- cp $< $@
|
||||
+ cp yodlmanpage.man $@
|
||||
|
||||
@@ -65,6 +63,6 @@
|
||||
striproff.man: striproff.yo ../Makefile
|
||||
- yodl2man $<
|
||||
+ yodl2man striproff.yo
|
||||
|
||||
$(man1)/striproff.1: striproff.man
|
||||
- cp $< $@
|
||||
+ cp striproff.man $@
|
12
textproc/yodl/files/patch-src.lib.lib.h
Normal file
12
textproc/yodl/files/patch-src.lib.lib.h
Normal file
|
@ -0,0 +1,12 @@
|
|||
--- src/lib/lib.h.orig Wed Jul 31 23:08:06 2002
|
||||
+++ src/lib/lib.h Wed Jul 31 23:08:35 2002
|
||||
@@ -16,7 +16,7 @@
|
||||
|
||||
#if HAVE_MALLOC_H
|
||||
# include <malloc.h>
|
||||
-#elif defined STDC_HEADERS
|
||||
+#elif defined STDC_HEADERS && !defined __FreeBSD__
|
||||
extern void free PARAMS ((char *));
|
||||
extern char *malloc PARAMS ((int));
|
||||
extern char *realloc PARAMS ((char*, int));
|
||||
--- patch-src.lib.lib.h ends here ---
|
|
@ -11,30 +11,3 @@ bin/yodl2txt
|
|||
bin/yodl2man
|
||||
bin/yodl2ms
|
||||
bin/striproff
|
||||
lib/yodl/chartables/html.tables.yo
|
||||
lib/yodl/chartables/latex.tables.yo
|
||||
lib/yodl/chartables/man.tables.yo
|
||||
lib/yodl/chartables/sgml.tables.yo
|
||||
lib/yodl/chartables/txt.tables.yo
|
||||
lib/yodl/org/html.yo.in
|
||||
lib/yodl/org/output-commands.yo.in
|
||||
lib/yodl/org/shared.yo.in
|
||||
lib/yodl/yodl2html-post
|
||||
lib/yodl/yodlfixlabels
|
||||
lib/yodl/yodl2txt-post
|
||||
lib/yodl/yodl2man-post
|
||||
lib/yodl/yodl2ms-post
|
||||
lib/yodl/aux-macros.yo
|
||||
lib/yodl/disable-commands.yo
|
||||
lib/yodl/html.yo
|
||||
lib/yodl/man.yo
|
||||
lib/yodl/ms.yo
|
||||
lib/yodl/output-commands.yo
|
||||
lib/yodl/sgml.yo
|
||||
lib/yodl/shared.yo
|
||||
lib/yodl/tex.yo
|
||||
lib/yodl/txt.yo
|
||||
lib/yodl/xlatin1.tex
|
||||
@dirrm lib/yodl/chartables
|
||||
@dirrm lib/yodl/org
|
||||
@dirrm lib/yodl
|
||||
|
|
Loading…
Add table
Reference in a new issue