mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
sysutils/multitail: Update to 7.1.5
- Pass maintainership to submitter PR: 280755
This commit is contained in:
parent
a66393476c
commit
726bf485e7
6 changed files with 18 additions and 89 deletions
|
@ -1,32 +1,34 @@
|
||||||
PORTNAME= multitail
|
PORTNAME= multitail
|
||||||
PORTVERSION= 6.5.0
|
PORTVERSION= 7.1.5
|
||||||
PORTREVISION= 1
|
PORTREVISION= 1
|
||||||
CATEGORIES= sysutils
|
CATEGORIES= sysutils
|
||||||
MASTER_SITES= http://www.vanheusden.com/multitail/ \
|
MASTER_SITES= https://github.com/folkertvanheusden/multitail/archive/refs/tags/
|
||||||
http://fossies.org/unix/privat/
|
DISTNAME= ${PORTVERSION}
|
||||||
|
|
||||||
MAINTAINER= beat@FreeBSD.org
|
MAINTAINER= laszlo@karolyi.hu
|
||||||
COMMENT= Tail multiple files on console with ncurses
|
COMMENT= Tail multiple files on console with ncurses
|
||||||
WWW= https://www.vanheusden.com/multitail/
|
WWW= https://www.vanheusden.com/multitail/
|
||||||
|
|
||||||
LICENSE= GPLv2
|
LICENSE= MIT
|
||||||
LICENSE_FILE= ${WRKSRC}/license.txt
|
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||||
|
|
||||||
USES= alias gmake ncurses tar:tgz
|
LIB_DEPENDS= libgnuregex.so:devel/libgnuregex
|
||||||
|
|
||||||
|
USES= alias cmake ncurses pkgconfig
|
||||||
|
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
|
||||||
|
|
||||||
PLIST_FILES= bin/multitail etc/multitail.conf.sample \
|
PLIST_FILES= bin/multitail etc/multitail.conf.sample \
|
||||||
share/man/man1/multitail.1.gz
|
share/man/man1/multitail.1.gz
|
||||||
PORTDOCS= readme.txt license.txt
|
PORTDOCS= README.md LICENSE
|
||||||
MAKE_ARGS= NCURSES_IMPL="${NCURSES_IMPL}"
|
|
||||||
|
|
||||||
OPTIONS_DEFINE= DOCS
|
OPTIONS_DEFINE= DOCS
|
||||||
|
|
||||||
do-install:
|
do-install:
|
||||||
${INSTALL_PROGRAM} ${WRKSRC}/multitail ${STAGEDIR}${PREFIX}/bin/
|
${INSTALL_PROGRAM} ${WRKDIR}/.build/multitail ${STAGEDIR}${PREFIX}/bin/
|
||||||
${INSTALL_MAN} ${WRKSRC}/multitail.1 ${STAGEDIR}${PREFIX}/share/man/man1
|
${INSTALL_MAN} ${WRKSRC}/multitail.1 ${STAGEDIR}${PREFIX}/share/man/man1
|
||||||
${INSTALL_DATA} ${WRKSRC}/multitail.conf ${STAGEDIR}${PREFIX}/etc/multitail.conf.sample
|
${INSTALL_DATA} ${WRKSRC}/multitail.conf ${STAGEDIR}${PREFIX}/etc/multitail.conf.sample
|
||||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||||
${INSTALL_DATA} ${WRKSRC}/readme.txt ${STAGEDIR}${DOCSDIR}
|
${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
|
||||||
${INSTALL_DATA} ${WRKSRC}/license.txt ${STAGEDIR}${DOCSDIR}
|
${INSTALL_DATA} ${WRKSRC}/LICENSE ${STAGEDIR}${DOCSDIR}
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
TIMESTAMP = 1573322615
|
TIMESTAMP = 1723546600
|
||||||
SHA256 (multitail-6.5.0.tgz) = b29d5e77dfc663c7500f78da67de5d82d35d9417a4741a89a18ce9ee7bdba9ed
|
SHA256 (7.1.5.tar.gz) = b0c92bf5f504b39591bf3e2e30a1902925c11556e14b89a07cfa7533f9bd171b
|
||||||
SIZE (multitail-6.5.0.tgz) = 157578
|
SIZE (7.1.5.tar.gz) = 152590
|
||||||
|
|
|
@ -1,25 +0,0 @@
|
||||||
--- Makefile.orig 2019-11-07 12:56:23 UTC
|
|
||||||
+++ Makefile
|
|
||||||
@@ -19,18 +19,12 @@ CPPFLAGS+=-D$(PLATFORM) -DVERSION=\"$(VERSION)\" $(DEB
|
|
||||||
# build dependency files while compile (*.d)
|
|
||||||
CPPFLAGS+= -MMD -MP
|
|
||||||
|
|
||||||
-
|
|
||||||
-ifeq ($(PLATFORM),Darwin)
|
|
||||||
- LDFLAGS+=-lpanel $(NCURSES_LIB) -lutil -lm
|
|
||||||
+ifeq ($(NCURSES_IMPL),ncursesw)
|
|
||||||
+LDFLAGS+=-lpanelw -lncursesw -lutil -lm
|
|
||||||
else
|
|
||||||
-ifeq ($(UTF8_SUPPORT),yes)
|
|
||||||
- LDFLAGS+=-lpanelw -lncursesw -lutil -lm
|
|
||||||
- CPPFLAGS+=-DUTF8_SUPPORT
|
|
||||||
-else
|
|
||||||
- LDFLAGS+=-lpanel -lncurses -lutil -lm
|
|
||||||
+LDFLAGS+=-lpanel -lncurses -lutil -lm
|
|
||||||
endif
|
|
||||||
-endif
|
|
||||||
-
|
|
||||||
+CPPFLAGS+=-DUTF8_SUPPORT
|
|
||||||
|
|
||||||
OBJS:=utils.o mt.o error.o my_pty.o term.o scrollback.o help.o mem.o cv.o selbox.o stripstring.o color.o misc.o ui.o exec.o diff.o config.o cmdline.o globals.o history.o clipboard.o
|
|
||||||
DEPENDS:= $(OBJS:%.o=%.d)
|
|
|
@ -1,15 +0,0 @@
|
||||||
--- mt.c.orig 2014-02-16 09:06:54.000000000 -0500
|
|
||||||
+++ mt.c 2014-02-24 14:35:45.000000000 -0500
|
|
||||||
@@ -23,8 +23,12 @@
|
|
||||||
#include <sys/ioctl.h>
|
|
||||||
#include <sys/stat.h>
|
|
||||||
#ifndef AIX
|
|
||||||
+#if defined(__FreeBSD__)
|
|
||||||
+#include <termios.h>
|
|
||||||
+#else
|
|
||||||
#include <sys/termios.h> /* needed on Solaris 8 */
|
|
||||||
#endif
|
|
||||||
+#endif
|
|
||||||
#include <sys/time.h>
|
|
||||||
#include <sys/wait.h>
|
|
||||||
#include <unistd.h>
|
|
|
@ -1,18 +0,0 @@
|
||||||
--- mt.h.orig 2019-11-09 18:07:35 UTC
|
|
||||||
+++ mt.h
|
|
||||||
@@ -60,8 +60,13 @@ typedef enum { SCHEME_TYPE_EDIT = 0, SCHEME_TYPE_FILTE
|
|
||||||
#endif
|
|
||||||
|
|
||||||
#if defined(UTF8_SUPPORT) && !defined(__APPLE__)
|
|
||||||
- #include <ncursesw/panel.h>
|
|
||||||
- #include <ncursesw/ncurses.h>
|
|
||||||
+ #if defined(__FreeBSD__)
|
|
||||||
+ #include <panel.h>
|
|
||||||
+ #include <curses.h>
|
|
||||||
+ #else
|
|
||||||
+ #include <ncursesw/panel.h>
|
|
||||||
+ #include <ncursesw/ncurses.h>
|
|
||||||
+ #endif
|
|
||||||
#else
|
|
||||||
#if defined(__APPLE__)
|
|
||||||
#include <ncurses.h>
|
|
|
@ -1,15 +0,0 @@
|
||||||
--- term.c.orig 2014-02-24 14:33:39.000000000 -0500
|
|
||||||
+++ term.c 2014-02-24 14:35:02.000000000 -0500
|
|
||||||
@@ -16,8 +16,12 @@
|
|
||||||
#include <stropts.h>
|
|
||||||
#endif
|
|
||||||
#ifndef AIX
|
|
||||||
+#if defined(__FreeBSD__)
|
|
||||||
+#include <termios.h>
|
|
||||||
+#else
|
|
||||||
#include <sys/termios.h> /* needed on Solaris 8 */
|
|
||||||
#endif
|
|
||||||
+#endif
|
|
||||||
#include <sys/socket.h>
|
|
||||||
#include <netinet/in.h>
|
|
||||||
|
|
Loading…
Add table
Reference in a new issue