mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
emulators/yuzu: unbreak after a4245a4c6c
src/input_common/drivers/udp_client.cpp:116:18: error: no type named 'io_service' in namespace 'boost::asio' 116 | boost::asio::io_service io_service; | ~~~~~~~~~~~~~^ Reported by: pkg-fallout
This commit is contained in:
parent
ca70418ac1
commit
721fead075
3 changed files with 30 additions and 14 deletions
|
@ -1,6 +1,6 @@
|
|||
PORTNAME= yuzu
|
||||
PORTVERSION= s20240301
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= emulators wayland
|
||||
.if make(makesum)
|
||||
MASTER_SITES= https://api.yuzu-emu.org/gamedb/?dummy=/:gamedb
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
https://github.com/boostorg/asio/issues/437
|
||||
https://github.com/boostorg/asio/commit/6ca7c4726e05
|
||||
|
||||
--- CMakeLists.txt.orig 2024-03-01 07:57:00 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -275,6 +275,7 @@ add_definitions(-DBOOST_ASIO_DISABLE_CONCEPTS)
|
||||
|
||||
# boost asio's concept usage doesn't play nicely with some compilers yet.
|
||||
add_definitions(-DBOOST_ASIO_DISABLE_CONCEPTS)
|
||||
+add_definitions(-Dasync_operation=typename) # XXX Remove after Boost 1.87 upgrade
|
||||
if (MSVC)
|
||||
add_compile_options($<$<COMPILE_LANGUAGE:CXX>:/std:c++20>)
|
||||
|
29
emulators/yuzu/files/patch-boost-1.87
Normal file
29
emulators/yuzu/files/patch-boost-1.87
Normal file
|
@ -0,0 +1,29 @@
|
|||
src/input_common/drivers/udp_client.cpp:116:18: error: no type named 'io_service' in namespace 'boost::asio'
|
||||
116 | boost::asio::io_service io_service;
|
||||
| ~~~~~~~~~~~~~^
|
||||
src/tests/input_common/calibration_configuration_job.cpp:85:18: error: no type named 'io_service' in namespace 'boost::asio'
|
||||
85 | boost::asio::io_service io_service;
|
||||
| ~~~~~~~~~~~~~^
|
||||
|
||||
--- src/input_common/drivers/udp_client.cpp.orig 2024-03-01 07:57:00 UTC
|
||||
+++ src/input_common/drivers/udp_client.cpp
|
||||
@@ -113,7 +113,7 @@ class Socket { (private)
|
||||
}
|
||||
|
||||
SocketCallback callback;
|
||||
- boost::asio::io_service io_service;
|
||||
+ boost::asio::io_context io_service;
|
||||
boost::asio::basic_waitable_timer<clock> timer;
|
||||
udp::socket socket;
|
||||
|
||||
--- src/tests/input_common/calibration_configuration_job.cpp.orig 2024-03-01 07:57:00 UTC
|
||||
+++ src/tests/input_common/calibration_configuration_job.cpp
|
||||
@@ -82,7 +82,7 @@ class FakeCemuhookServer { (private)
|
||||
}
|
||||
|
||||
private:
|
||||
- boost::asio::io_service io_service;
|
||||
+ boost::asio::io_context io_service;
|
||||
boost::asio::ip::udp::socket socket;
|
||||
std::array<u8, InputCommon::CemuhookUDP::MAX_PACKET_SIZE> send_buffer;
|
||||
std::array<u8, InputCommon::CemuhookUDP::MAX_PACKET_SIZE> receive_buffer;
|
Loading…
Add table
Reference in a new issue