math/pdal: Update to 2.8.4

This commit is contained in:
Loïc Bartoletti 2025-04-07 18:10:29 +02:00
parent 2fcd3ef3a7
commit 71def28c85
16 changed files with 23 additions and 98 deletions

View file

@ -1,5 +1,6 @@
PORTNAME= grass
DISTVERSION= 8.4.1
PORTREVISION= 1
CATEGORIES= databases geography
MASTER_SITES= https://grass.osgeo.org/%SUBDIR%/ \
http://grass.cict.fr/%SUBDIR%/ \

View file

@ -1,5 +1,6 @@
PORTNAME= qgis
DISTVERSION= 3.40.5
PORTREVISION= 1
CATEGORIES= graphics geography
MASTER_SITES= https://qgis.org/downloads/
PKGNAMESUFFIX= -ltr

View file

@ -1,6 +1,6 @@
PORTNAME= qgis
DISTVERSION= 3.42.1
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= graphics geography
MASTER_SITES= https://qgis.org/downloads/

View file

@ -1,7 +1,7 @@
PORTNAME= mdal
DISTVERSIONPREFIX= release-
DISTVERSION= 1.2.0
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= math geography
MAINTAINER= wen@FreeBSD.org

View file

@ -1,6 +1,5 @@
PORTNAME= pdal
DISTVERSION= 2.7.2
PORTREVISION= 6
DISTVERSION= 2.8.4
CATEGORIES= math databases graphics
MASTER_SITES= https://github.com/PDAL/PDAL/releases/download/${DISTVERSION}/
DISTNAME= ${PORTNAME}-${DISTVERSION}-src

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1724912712
SHA256 (pdal-2.7.2-src.tar.bz2) = f6ae0f3dc012b19c70dde2361799ecac0cdcbeb9cad5cfd96313c9fdc8608f32
SIZE (pdal-2.7.2-src.tar.bz2) = 87431434
TIMESTAMP = 1743790534
SHA256 (pdal-2.8.4-src.tar.bz2) = c27dc79af0b26f9cb3209b694703e9d576f1b0c8c05b36206fd5e310494e75b5
SIZE (pdal-2.8.4-src.tar.bz2) = 86725389

View file

@ -1,11 +0,0 @@
--- CMakeLists.txt.orig 2024-08-29 07:07:08 UTC
+++ CMakeLists.txt
@@ -356,7 +356,7 @@ install(DIRECTORY ${PDAL_FILTERS_DIR}/
# PATTERN "private" EXCLUDE
)
-install(FILES ${DIMENSION_OUTFILE} ${pdal_features_hpp}/
+install(FILES ${DIMENSION_OUTFILE} ${pdal_features_hpp}
DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}/pdal"
PERMISSIONS
GROUP_EXECUTE WORLD_EXECUTE OWNER_EXECUTE

View file

@ -1,11 +0,0 @@
--- apps/CMakeLists.txt.orig 2024-01-31 13:44:27 UTC
+++ apps/CMakeLists.txt
@@ -62,7 +62,7 @@ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/pdal.pc
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/pdal.pc.in
${CMAKE_CURRENT_BINARY_DIR}/pdal.pc @ONLY)
install(FILES ${CMAKE_CURRENT_BINARY_DIR}/pdal.pc
- DESTINATION "${PDAL_LIB_INSTALL_DIR}/pkgconfig/"
+ DESTINATION "${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig/"
PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ)
configure_file("${CMAKE_CURRENT_SOURCE_DIR}/pdal-config.in"

View file

@ -1,10 +0,0 @@
--- vendor/kazhdan/MyTime.h.orig 2018-04-06 19:43:22 UTC
+++ vendor/kazhdan/MyTime.h
@@ -30,7 +30,6 @@ DAMAGE.
#define MY_TIME_INCLUDED
#include <string.h>
-#include <sys/timeb.h>
#ifndef WIN32
#include <sys/time.h>
#endif // WIN32

View file

@ -1,20 +0,0 @@
--- vendor/kazhdan/Ply.h.orig 2024-06-29 01:37:43 UTC
+++ vendor/kazhdan/Ply.h
@@ -317,7 +317,7 @@ class PlyOrientedVertex (public)
PlyOrientedVertex( void ) { ; }
PlyOrientedVertex( Point3D< Real > p , Point3D< Real > n ) : point(p) , normal(n) { ; }
PlyOrientedVertex operator + ( PlyOrientedVertex p ) const { return PlyOrientedVertex( point+p.point , normal+p.normal ); }
- PlyOrientedVertex operator - ( PlyOrientedVertex p ) const { return PlyOrientedVertex( point-p.value , normal-p.normal ); }
+ PlyOrientedVertex operator - ( PlyOrientedVertex p ) const { return PlyOrientedVertex( point-p.point , normal-p.normal ); }
template< class _Real > PlyOrientedVertex operator * ( _Real s ) const { return PlyOrientedVertex( point*s , normal*s ); }
template< class _Real > PlyOrientedVertex operator / ( _Real s ) const { return PlyOrientedVertex( point/s , normal/s ); }
PlyOrientedVertex& operator += ( PlyOrientedVertex p ) { point += p.point , normal += p.normal ; return *this; }
@@ -363,7 +363,7 @@ class PlyColorVertex (public)
}
_PlyColorVertex operator + ( _PlyColorVertex p ) const { return _PlyColorVertex( point+p.point , color+p.color ); }
- _PlyColorVertex operator - ( _PlyColorVertex p ) const { return _PlyColorVertex( point-p.value , color-p.color ); }
+ _PlyColorVertex operator - ( _PlyColorVertex p ) const { return _PlyColorVertex( point-p.point , color-p.color ); }
template< class _Real > _PlyColorVertex operator * ( _Real s ) const { return _PlyColorVertex( point*s , color*s ); }
template< class _Real > _PlyColorVertex operator / ( _Real s ) const { return _PlyColorVertex( point/s , color/s ); }
_PlyColorVertex& operator += ( _PlyColorVertex p ) { point += p.point , color += p.color ; return *this; }

View file

@ -1,11 +0,0 @@
--- vendor/kazhdan/SparseMatrix.h.orig 2024-06-29 01:37:43 UTC
+++ vendor/kazhdan/SparseMatrix.h
@@ -67,8 +67,6 @@ template<class T> class SparseMatrix (public)
SparseMatrix( const SparseMatrix& M );
~SparseMatrix();
- void SetZero();
-
SparseMatrix<T>& operator = (const SparseMatrix<T>& M);
SparseMatrix<T> operator * (const T& V) const;

View file

@ -1,16 +0,0 @@
--- vendor/kazhdan/SparseMatrix.inl.orig 2024-06-29 01:37:43 UTC
+++ vendor/kazhdan/SparseMatrix.inl
@@ -188,13 +188,6 @@ void SparseMatrix< T >::SetRowSize( int row , int coun
}
}
-
-template<class T>
-void SparseMatrix<T>::SetZero()
-{
- Resize(this->m_N, this->m_M);
-}
-
template<class T>
SparseMatrix<T> SparseMatrix<T>::operator * (const T& V) const
{

View file

@ -72,6 +72,7 @@ include/pdal/filters/ELMFilter.hpp
include/pdal/filters/EigenvaluesFilter.hpp
include/pdal/filters/EstimateRankFilter.hpp
include/pdal/filters/ExpressionFilter.hpp
include/pdal/filters/ExpressionStatsFilter.hpp
include/pdal/filters/FaceRasterFilter.hpp
include/pdal/filters/FarthestPointSamplingFilter.hpp
include/pdal/filters/FerryFilter.hpp
@ -91,6 +92,7 @@ include/pdal/filters/IQRFilter.hpp
include/pdal/filters/InfoFilter.hpp
include/pdal/filters/IterativeClosestPoint.hpp
include/pdal/filters/LOFFilter.hpp
include/pdal/filters/LabelDuplicatesFilter.hpp
include/pdal/filters/LiTreeFilter.hpp
include/pdal/filters/LloydKMeansFilter.hpp
include/pdal/filters/LocateFilter.hpp
@ -327,20 +329,20 @@ lib/cmake/PDAL/PDALTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/PDAL/PDALTargets.cmake
lib/cmake/PDAL/pluginmacros.cmake
lib/libpdal_plugin_kernel_fauxplugin.so
lib/libpdal_plugin_kernel_fauxplugin.so.17
lib/libpdal_plugin_kernel_fauxplugin.so.17.1.0
lib/libpdal_plugin_kernel_fauxplugin.so.18
lib/libpdal_plugin_kernel_fauxplugin.so.18.1.0
%%ICEBRIDGE%%lib/libpdal_plugin_reader_icebridge.so
%%ICEBRIDGE%%lib/libpdal_plugin_reader_icebridge.so.17
%%ICEBRIDGE%%lib/libpdal_plugin_reader_icebridge.so.17.1.0
%%ICEBRIDGE%%lib/libpdal_plugin_reader_icebridge.so.18
%%ICEBRIDGE%%lib/libpdal_plugin_reader_icebridge.so.18.1.0
%%PGPOINTCLOUD%%lib/libpdal_plugin_reader_pgpointcloud.so
%%PGPOINTCLOUD%%lib/libpdal_plugin_reader_pgpointcloud.so.17
%%PGPOINTCLOUD%%lib/libpdal_plugin_reader_pgpointcloud.so.17.1.0
%%PGPOINTCLOUD%%lib/libpdal_plugin_reader_pgpointcloud.so.18
%%PGPOINTCLOUD%%lib/libpdal_plugin_reader_pgpointcloud.so.18.1.0
%%PGPOINTCLOUD%%lib/libpdal_plugin_writer_pgpointcloud.so
%%PGPOINTCLOUD%%lib/libpdal_plugin_writer_pgpointcloud.so.17
%%PGPOINTCLOUD%%lib/libpdal_plugin_writer_pgpointcloud.so.17.1.0
%%PGPOINTCLOUD%%lib/libpdal_plugin_writer_pgpointcloud.so.18
%%PGPOINTCLOUD%%lib/libpdal_plugin_writer_pgpointcloud.so.18.1.0
lib/libpdalcpp.so
lib/libpdalcpp.so.17
lib/libpdalcpp.so.17.1.0
lib/libpdalcpp.so.18
lib/libpdalcpp.so.18.1.0
libdata/pkgconfig/pdal.pc
%%BASH%%share/bash-completion/completions/pdal
@dir include/pdal/filters/private/csf

View file

@ -1,5 +1,6 @@
PORTNAME= pdal
DISTVERSION= 3.4.5
PORTREVISION= 1
CATEGORIES= math python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}

View file

@ -1,6 +1,6 @@
PORTNAME= saga
PORTVERSION= 9.8.0
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= math
MASTER_SITES= SF/saga-gis/SAGA%20-%20${PORTVERSION:C/\.[[:digit:]]\.[[:digit:]]*$//}/SAGA%20-%20${PORTVERSION}

View file

@ -1,6 +1,6 @@
PORTNAME= paraview
DISTVERSION= ${PARAVIEW_VER}.1
PORTREVISION= 18
PORTREVISION= 19
CATEGORIES= science graphics
MASTER_SITES= http://www.paraview.org/files/v${PARAVIEW_VER}/
DISTNAME= ParaView-v${PORTVERSION}