- Remove the port math/bamg, as it is no longer supported upstream.

This commit is contained in:
Stephen Montgomery-Smith 2016-08-14 18:36:34 +00:00
parent ed34698f12
commit 6f74706f80
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=420195
11 changed files with 1 additions and 159 deletions

1
LEGAL
View file

@ -39,7 +39,6 @@ apache2/mod_h264_streaming-* www/mod_h264_streaming No commercial use
armyops*-linux.run games/linux-americasarmy Redistribution is limited
astah-community-*.zip devel/astah-community License restrictions -- See http://astah.net/faq/community/enduser-license-agreement
atari800/* emulators/atari800 xf25 contains copyright ROMs and cannot be distributed
bamg* math/bamg Contact author personally regarding commercial use
baudline_* audio/baudline No redistribution allowed
BCWipe-* security/bcwipe Non-commercial distribution and use only
bdc* security/bdc License does not allow redistribution

1
MOVED
View file

@ -8616,3 +8616,4 @@ multimedia/linux-xmovie||2016-08-08|Has expired: Not maintained upstream, contai
multimedia/linux-realplayer||2016-08-09|Has expired: Not maintained upstream, contains security issues
cad/NASTRAN|cad/NASTRAN-95|2016-08-12|Rename to match PORTNAME and upstream name
ports-mgmt/xps||2016-08-11|Has expired: Does not support pkg(8)
math/bamg||2016-08-14|No longer maintained upstream as is now part of freefem++

View file

@ -90,7 +90,6 @@
SUBDIR += aspcud
SUBDIR += asymptote
SUBDIR += atlas
SUBDIR += bamg
SUBDIR += bargraph
SUBDIR += biggles
SUBDIR += blacs

View file

@ -1,62 +0,0 @@
# Created by: thierry@pompo.net
# $FreeBSD$
PORTNAME= bamg
PORTVERSION= 1.01
PORTREVISION= 1
CATEGORIES= math science
MASTER_SITES= http://www.ann.jussieu.fr/hecht/ftp/bamg/
DISTFILES= ${PORTNAME}-v${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= stephen@FreeBSD.org
COMMENT= Bidimensional Anisotropic Mesh Generator
RESTRICTED= Contact author personally regarding commercial use
BROKEN= Master site no longer exists
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_XORG= x11
USES= gmake shebangfix
SHEBANG_FILES= examples/quadloop/dotest.pl
MAKE_JOBS_UNSAFE= yes
ALL_TARGET= world
INSTALL_TARGET= install-world
BINS= bamg bamg-g cvmsh2 drawbdmesh
EXDIRS= NACA012 quadloop square test
OPTIONS_DEFINE= DOCS EXAMPLES
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MDOCS}
DISTFILES+= ${PORTNAME}.pdf
EXTRACT_ONLY= ${PORTNAME}-v${PORTVERSION}${EXTRACT_SUFX}
.endif
.pre-configure:
HOSTTYPE= ${UNAME} -s
MAKE_ENV= HOSTTYPE=${${HOSTTYPE}}
post-patch:
@${MV} ${WRKSRC}/FLAG.linux ${WRKSRC}/FLAG.${${HOSTTYPE}}
@${MV} ${WRKSRC}/FLAG.linux.orig ${WRKSRC}/FLAG.linux
post-install:
.for bin in ${BINS}
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${bin}
.endfor
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@${INSTALL_DATA} ${DISTDIR}/${PORTNAME}.pdf ${STAGEDIR}${DOCSDIR}
.endif
.for exdir in ${EXDIRS}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/${exdir}
@${INSTALL_DATA} ${WRKSRC}/examples/${exdir}/* ${STAGEDIR}${EXAMPLESDIR}/${exdir}
.endfor
@${FIND} ${STAGEDIR}${EXAMPLESDIR} \( -name "*.pl" -or -name "*.sh" \) -exec ${CHMOD} a+x {} \;
.include <bsd.port.post.mk>

View file

@ -1,4 +0,0 @@
SHA256 (bamg-v1.01.tar.gz) = d40c80606917a87fd90d15b6755e79812e1780130f56b16f5a69327209b05ff2
SIZE (bamg-v1.01.tar.gz) = 178947
SHA256 (bamg.pdf) = 85280b1dd7a92bda344cb9c55a2321996b5c7fc16429a28812638459f3b7af31
SIZE (bamg.pdf) = 2203754

View file

@ -1,23 +0,0 @@
--- FLAG.linux.orig Fri May 29 18:33:51 1998
+++ FLAG.linux Fri Dec 19 11:24:28 2003
@@ -1,12 +1,11 @@
-CXX=g++
longlong = -DLONGLONG
-O = -O $(longlong)
-G = -g $(longlong)
-CXXFLAGS= $(O)
-CXXGRAPHIC = -I/usr/include/X11R6 -DDRAWING -DDEBUG
+O = $(longlong)
+G =
+CXXFLAGS+= $(O)
+CXXGRAPHIC = $(CXXFLAGS) -I$(LOCALBASE)/include -DDRAWING -DDEBUG
CXXLINKFLAG =
-X11LIB = -L/usr/lib/X11R6 -L/usr/X11R6/lib -lX11
-X11INCLUDE= -I/usr/include/X11R6
+X11LIB = -L$(LOCALBASE)/lib -lX11
+X11INCLUDE= -I$(LOCALBASE)/include
STDLIB =
-F77FLAGS =
-F77 = f77
+F77FLAGS = $(FFLAGS)
+F77 = $(F77)

View file

@ -1,11 +0,0 @@
--- Makefile.orig Thu Apr 5 10:15:28 2001
+++ Makefile Wed Dec 17 23:56:36 2003
@@ -5,7 +5,7 @@
all: bamg cvmsh2 $(FLAGFILE)
-INSTALLDIR=/usr/local/bin
+INSTALLDIR=$(DESTDIR)$(PREFIX)/bin
FLAGFILE=FLAG.$(HOSTTYPE)
include $(FLAGFILE)

View file

@ -1,10 +0,0 @@
--- Mesh2.h-orig 2011-07-19 12:39:01.000000000 -0500
+++ Mesh2.h 2011-07-19 12:39:23.000000000 -0500
@@ -19,6 +19,7 @@
#include <math.h>
#include <limits.h>
#include <time.h>
+#include <cassert>
#if (defined(unix) || defined(__unix)) && !defined(__AIX)
#define SYSTIMES
#include <sys/times.h>

View file

@ -1,14 +0,0 @@
--- Xrgraph.cpp-orig 2011-07-19 12:50:19.000000000 -0500
+++ Xrgraph.cpp 2011-07-19 12:50:40.000000000 -0500
@@ -18,8 +18,9 @@
#include <stdlib.h>
#include <stdio.h>
#include <unistd.h>
-#include <iostream.h>
-#include <assert.h>
+#include <iostream>
+#include <cassert>
+using namespace std;
#define MAXSHORT 0xFFFF

View file

@ -1,5 +0,0 @@
bamg is a Bidimensional Anisotropic Mesh Generator.
Suggested add-on: the port math/freefem++.
WWW: http://www.ann.jussieu.fr/hecht/ftp/bamg/

View file

@ -1,28 +0,0 @@
bin/bamg
bin/bamg-g
bin/cvmsh2
bin/drawbdmesh
%%PORTDOCS%%%%DOCSDIR%%/bamg.pdf
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/NACA012/ad.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/NACA012/adap.sh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/NACA012/adap.sh-g
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/NACA012/data
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/NACA012/data-orign
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/NACA012/naca.awk
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/NACA012/plot.fv
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/NACA012/plot.fv-1
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/quadloop/dotest.pl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/square/circle_g.mesh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/square/doadapt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/square/dotest
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/square/l_g.mesh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/square/octogone_g.mesh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/square/square_g.mesh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/square/square_raf_ani_g.mtr
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/square/square_raf_g.mesh
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/square/square_raf_g.mtr
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test/dotest-o.pl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test/dotest.pl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test/dotest1.pl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test/dotest2.pl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test/dotest3.pl