mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
lang/halide: update 17.0.1 → 18.0.0
This commit is contained in:
parent
93d3cc5c89
commit
6f10bf5387
4 changed files with 14 additions and 23 deletions
|
@ -1,6 +1,6 @@
|
||||||
PORTNAME= halide
|
PORTNAME= halide
|
||||||
DISTVERSIONPREFIX= v
|
DISTVERSIONPREFIX= v
|
||||||
DISTVERSION= 17.0.1
|
DISTVERSION= 18.0.0
|
||||||
PORTEPOCH= 1
|
PORTEPOCH= 1
|
||||||
CATEGORIES= lang
|
CATEGORIES= lang
|
||||||
|
|
||||||
|
@ -50,5 +50,6 @@ post-install:
|
||||||
${RM} -r ${STAGEDIR}${PREFIX}/share
|
${RM} -r ${STAGEDIR}${PREFIX}/share
|
||||||
|
|
||||||
# tests fail to compile, see https://github.com/halide/Halide/issues/8236
|
# tests fail to compile, see https://github.com/halide/Halide/issues/8236
|
||||||
|
# Vulkan support isn't enabled for some reason: Configure finds Vulkan but target.has_gpu_feature() returns false, see https://github.com/halide/Halide/issues/8375
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
TIMESTAMP = 1716857358
|
TIMESTAMP = 1723059408
|
||||||
SHA256 (halide-Halide-v17.0.1_GH0.tar.gz) = beb18331d9e4b6f69943bcc75fb9d923a250ae689f09f6940a01636243289727
|
SHA256 (halide-Halide-v18.0.0_GH0.tar.gz) = 1176b42a3e2374ab38555d9316c78e39b157044b5a8e765c748bf3afd2edb351
|
||||||
SIZE (halide-Halide-v17.0.1_GH0.tar.gz) = 33075499
|
SIZE (halide-Halide-v18.0.0_GH0.tar.gz) = 33052677
|
||||||
|
|
|
@ -1,16 +1,16 @@
|
||||||
--- src/LLVM_Runtime_Linker.cpp.orig 2024-02-20 17:13:06 UTC
|
--- src/LLVM_Runtime_Linker.cpp.orig 2024-07-17 16:16:39 UTC
|
||||||
+++ src/LLVM_Runtime_Linker.cpp
|
+++ src/LLVM_Runtime_Linker.cpp
|
||||||
@@ -432,6 +432,9 @@ llvm::Triple get_triple_for_target(const Target &targe
|
@@ -481,6 +481,9 @@ llvm::Triple get_triple_for_target(const Target &targe
|
||||||
if (target.os == Target::Linux) {
|
if (target.os == Target::Linux) {
|
||||||
triple.setOS(llvm::Triple::Linux);
|
triple.setOS(llvm::Triple::Linux);
|
||||||
triple.setEnvironment(llvm::Triple::GNU);
|
triple.setEnvironment(llvm::Triple::GNU);
|
||||||
+ } else if (target.os == Target::Linux || target.os == Target::FreeBSD) {
|
+ } else if (target.os == Target::FreeBSD) {
|
||||||
+ triple.setOS(llvm::Triple::FreeBSD);
|
+ triple.setOS(llvm::Triple::FreeBSD);
|
||||||
+ triple.setEnvironment(llvm::Triple::GNU);
|
+ triple.setEnvironment(llvm::Triple::GNU);
|
||||||
} else if (target.os == Target::OSX) {
|
} else if (target.os == Target::OSX) {
|
||||||
triple.setVendor(llvm::Triple::Apple);
|
triple.setVendor(llvm::Triple::Apple);
|
||||||
triple.setOS(llvm::Triple::MacOSX);
|
triple.setOS(llvm::Triple::MacOSX);
|
||||||
@@ -478,6 +481,9 @@ llvm::Triple get_triple_for_target(const Target &targe
|
@@ -527,6 +530,9 @@ llvm::Triple get_triple_for_target(const Target &targe
|
||||||
} else if (target.os == Target::Linux) {
|
} else if (target.os == Target::Linux) {
|
||||||
triple.setOS(llvm::Triple::Linux);
|
triple.setOS(llvm::Triple::Linux);
|
||||||
triple.setEnvironment(llvm::Triple::GNUEABIHF);
|
triple.setEnvironment(llvm::Triple::GNUEABIHF);
|
||||||
|
@ -20,7 +20,7 @@
|
||||||
} else if (target.os == Target::Windows) {
|
} else if (target.os == Target::Windows) {
|
||||||
user_assert(target.bits == 64) << "Windows ARM targets must be 64-bit.\n";
|
user_assert(target.bits == 64) << "Windows ARM targets must be 64-bit.\n";
|
||||||
triple.setVendor(llvm::Triple::PC);
|
triple.setVendor(llvm::Triple::PC);
|
||||||
@@ -539,6 +545,8 @@ llvm::Triple get_triple_for_target(const Target &targe
|
@@ -588,6 +594,8 @@ llvm::Triple get_triple_for_target(const Target &targe
|
||||||
|
|
||||||
if (target.os == Target::Linux) {
|
if (target.os == Target::Linux) {
|
||||||
triple.setOS(llvm::Triple::Linux);
|
triple.setOS(llvm::Triple::Linux);
|
||||||
|
@ -29,7 +29,7 @@
|
||||||
} else if (target.os == Target::Android) {
|
} else if (target.os == Target::Android) {
|
||||||
triple.setOS(llvm::Triple::Linux);
|
triple.setOS(llvm::Triple::Linux);
|
||||||
triple.setEnvironment(llvm::Triple::Android);
|
triple.setEnvironment(llvm::Triple::Android);
|
||||||
@@ -855,7 +863,7 @@ std::unique_ptr<llvm::Module> get_initial_module_for_t
|
@@ -923,7 +931,7 @@ std::unique_ptr<llvm::Module> get_initial_module_for_t
|
||||||
if (module_type != ModuleGPU) {
|
if (module_type != ModuleGPU) {
|
||||||
if (module_type != ModuleJITInlined && module_type != ModuleAOTNoRuntime) {
|
if (module_type != ModuleJITInlined && module_type != ModuleAOTNoRuntime) {
|
||||||
// OS-dependent modules
|
// OS-dependent modules
|
||||||
|
@ -38,7 +38,7 @@
|
||||||
add_allocator();
|
add_allocator();
|
||||||
modules.push_back(get_initmod_posix_allocator(c, bits_64, debug));
|
modules.push_back(get_initmod_posix_allocator(c, bits_64, debug));
|
||||||
modules.push_back(get_initmod_posix_error_handler(c, bits_64, debug));
|
modules.push_back(get_initmod_posix_error_handler(c, bits_64, debug));
|
||||||
@@ -1045,7 +1053,7 @@ std::unique_ptr<llvm::Module> get_initial_module_for_t
|
@@ -1113,7 +1121,7 @@ std::unique_ptr<llvm::Module> get_initial_module_for_t
|
||||||
}
|
}
|
||||||
|
|
||||||
// Prefer using fopen_lfs on Linux systems, which calls fopen64() to ensure LFS support.
|
// Prefer using fopen_lfs on Linux systems, which calls fopen64() to ensure LFS support.
|
||||||
|
@ -47,12 +47,3 @@
|
||||||
modules.push_back(get_initmod_fopen_lfs(c, bits_64, debug));
|
modules.push_back(get_initmod_fopen_lfs(c, bits_64, debug));
|
||||||
} else {
|
} else {
|
||||||
modules.push_back(get_initmod_fopen(c, bits_64, debug));
|
modules.push_back(get_initmod_fopen(c, bits_64, debug));
|
||||||
@@ -1209,7 +1217,7 @@ std::unique_ptr<llvm::Module> get_initial_module_for_t
|
|
||||||
if (t.os == Target::Android) {
|
|
||||||
// Only platform that supports OpenGL Compute for now.
|
|
||||||
modules.push_back(get_initmod_opengl_egl_context(c, bits_64, debug));
|
|
||||||
- } else if (t.os == Target::Linux) {
|
|
||||||
+ } else if (t.os == Target::Linux || t.os == Target::FreeBSD) {
|
|
||||||
if (t.has_feature(Target::EGL)) {
|
|
||||||
modules.push_back(get_initmod_opengl_egl_context(c, bits_64, debug));
|
|
||||||
} else {
|
|
||||||
|
|
|
@ -15,7 +15,6 @@ include/HalideRuntimeHexagonDma.h
|
||||||
include/HalideRuntimeHexagonHost.h
|
include/HalideRuntimeHexagonHost.h
|
||||||
include/HalideRuntimeMetal.h
|
include/HalideRuntimeMetal.h
|
||||||
include/HalideRuntimeOpenCL.h
|
include/HalideRuntimeOpenCL.h
|
||||||
include/HalideRuntimeOpenGLCompute.h
|
|
||||||
include/HalideRuntimeQurt.h
|
include/HalideRuntimeQurt.h
|
||||||
include/HalideRuntimeVulkan.h
|
include/HalideRuntimeVulkan.h
|
||||||
include/HalideRuntimeWebGPU.h
|
include/HalideRuntimeWebGPU.h
|
||||||
|
@ -33,8 +32,8 @@ lib/cmake/HalideHelpers/HalideHelpersConfigVersion.cmake
|
||||||
lib/cmake/HalideHelpers/HalideTargetHelpers.cmake
|
lib/cmake/HalideHelpers/HalideTargetHelpers.cmake
|
||||||
lib/cmake/HalideHelpers/TargetExportScript.cmake
|
lib/cmake/HalideHelpers/TargetExportScript.cmake
|
||||||
lib/libHalide.so
|
lib/libHalide.so
|
||||||
lib/libHalide.so.17
|
lib/libHalide.so.18
|
||||||
lib/libHalide.so.17.0.1
|
lib/libHalide.so.18.0.0
|
||||||
lib/libautoschedule_adams2019.so
|
lib/libautoschedule_adams2019.so
|
||||||
lib/libautoschedule_anderson2021.so
|
lib/libautoschedule_anderson2021.so
|
||||||
lib/libautoschedule_li2018.so
|
lib/libautoschedule_li2018.so
|
||||||
|
|
Loading…
Add table
Reference in a new issue