textproc/py-youseedee: Add py-youseedee 0.3.0

youseedee provides an interface to the UCD. This module allows you to query the
Unicode Character Database. The main function to be imported is ucd_data.
This commit is contained in:
Po-Chuan Hsieh 2022-12-30 16:36:18 +08:00
parent f5b4e30c5e
commit 6cf0c4cce7
No known key found for this signature in database
GPG key ID: 9A4BD10F002DD04B
5 changed files with 40 additions and 0 deletions

View file

@ -1586,6 +1586,7 @@
SUBDIR += py-xmldiff
SUBDIR += py-xmlschema
SUBDIR += py-yapf
SUBDIR += py-youseedee
SUBDIR += py-zope.i18nmessageid
SUBDIR += py-zope.structuredtext
SUBDIR += py-zope.tal

View file

@ -0,0 +1,23 @@
PORTNAME= youseedee
PORTVERSION= 0.3.0
CATEGORIES= textproc python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Interface to the Unicode Character Database
WWW= https://github.com/simoncozens/youseedee
LICENSE= MIT
RUN_DEPENDS= UCD>=0:textproc/UCD
USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
post-patch:
@${REINPLACE_CMD} -e 's|%%UCDDIR%%|${LOCALBASE}/share/unicode/ucd|' ${WRKSRC}/lib/youseedee/__init__.py
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
TIMESTAMP = 1669057517
SHA256 (youseedee-0.3.0.tar.gz) = 596c1112230bdd154b6d6c962872933e16748ae8efd7cb2389b922cc9aabcab0
SIZE (youseedee-0.3.0.tar.gz) = 9832

View file

@ -0,0 +1,11 @@
--- lib/youseedee/__init__.py.orig 2020-10-06 16:13:22 UTC
+++ lib/youseedee/__init__.py
@@ -9,7 +9,7 @@ import csv
UCD_URL = "https://unicode.org/Public/UCD/latest/ucd/UCD.zip"
def ucd_dir():
- ucddir = os.path.expanduser("~/.youseedee")
+ ucddir = "%%UCDDIR%%"
if not os.path.isdir(ucddir):
os.mkdir(ucddir)
return ucddir

View file

@ -0,0 +1,2 @@
youseedee provides an interface to the UCD. This module allows you to query the
Unicode Character Database. The main function to be imported is ucd_data.