mirror of
https://git.freebsd.org/ports.git
synced 2025-05-12 15:21:51 -04:00
sysutils/conky{-awesome}: update to 1.21.0
ChangeLog: https://github.com/brndnmtthws/conky/releases/tag/v1.21.0 Features * Update DPI when changed in resource manager * CLI: -V now displays a short version string * Make version string semver compliant, add git sha * Add BUILD_COLOUR_NAME_MAP build flag * Docker: updated base image to Ubuntu 24.04 LTS * Docker: improve tagging, distinguish main and latest * Introduce geometry primitives Bug fixes * Fix bad query_x11_windows early returns * Re-enable RSS in AppImage, also enable in Nix flake * Disable -Wregister on gperf output * Simplify binary include handling (and fix build) * Require gperf at build-time * Docker: Add gperf, enable Lua Cairo Xlib bindings * Fix conky-cairo_imlib2_helper dependency conditions * Use private mapping from provided shm_pool buffer * Remove dpi scaling of maximum width * Use _NET_VIRTUAL_ROOTS for querying virtual roots * Use MODULE library type for Lua libs * Fix AppImage version naming * Ensure we use correct LLVM in nix dev shell * Fix alignment documentation & enable HTML in docs Miscellaneous * Bump version * Explicitly note updated time is UTC * Link to latest commit in web footer * Update nix flake w/ LLVM 18 * shared_ptr::unique() deprecated, use use_count() * Bump minor version * Fix this env var handling (derp) * Try to fix this quote handling again * Move docker build to separate script for less jank * Docker build separate script
This commit is contained in:
parent
0e5375dba6
commit
6c950196d9
6 changed files with 47 additions and 31 deletions
|
@ -1,5 +1,5 @@
|
|||
PORTNAME= conky
|
||||
PORTVERSION= 1.20.2
|
||||
PORTVERSION= 1.21.0
|
||||
DISTVERSIONPREFIX= v
|
||||
CATEGORIES= sysutils
|
||||
|
||||
|
@ -28,7 +28,8 @@ CMAKE_ARGS= -DAPP_SED=${LOCALBASE}/bin/gsed \
|
|||
CONFLICTS?= conky-awesome
|
||||
|
||||
SLAVEDIRS= sysutils/conky-awesome
|
||||
PLIST_FILES= bin/conky
|
||||
PLIST_FILES= bin/conky \
|
||||
lib/libVc.a
|
||||
PORTDOCS= config_settings.yaml lua.yaml variables.yaml
|
||||
PORTEXAMPLES= conky.conf conky_no_x11.conf convert.lua
|
||||
|
||||
|
@ -163,4 +164,8 @@ post-install-DOCS-on:
|
|||
${INSTALL_MAN} ${WRKSRC}/doc/${FILE} ${STAGEDIR}${DOCSDIR}
|
||||
.endfor
|
||||
|
||||
post-install:
|
||||
${RM} -rf ${STAGEDIR}${PREFIX}/include
|
||||
${RM} -rf ${STAGEDIR}${PREFIX}/lib/cmake
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1714027251
|
||||
SHA256 (brndnmtthws-conky-v1.20.2_GH0.tar.gz) = 16f2e17d35252c1c3b97363016ede5cd68be719c32a51961420fcd46859bf503
|
||||
SIZE (brndnmtthws-conky-v1.20.2_GH0.tar.gz) = 1837320
|
||||
TIMESTAMP = 1715452113
|
||||
SHA256 (brndnmtthws-conky-v1.21.0_GH0.tar.gz) = fff08ee35c15caf85ca62119c2694b9392f770eb4a8f1b5e07738d96edd0e5ac
|
||||
SIZE (brndnmtthws-conky-v1.21.0_GH0.tar.gz) = 2146867
|
||||
|
|
|
@ -1,26 +0,0 @@
|
|||
--- src/display-x11.cc.orig 2024-04-24 13:56:28 UTC
|
||||
+++ src/display-x11.cc
|
||||
@@ -683,7 +683,9 @@ bool handle_event<x_event_handler::BORDER_CROSSING>(
|
||||
conky::display_output_x11 *surface, Display *display, XEvent &ev,
|
||||
bool *consumed, void **cookie) {
|
||||
if (ev.type != EnterNotify && ev.type != LeaveNotify) return false;
|
||||
+#ifdef BUILD_XINPUT
|
||||
if (window.xi_opcode != 0) return true; // handled by mouse_input already
|
||||
+#endif
|
||||
|
||||
bool not_over_conky = ev.xcrossing.x_root <= window.x ||
|
||||
ev.xcrossing.y_root <= window.y ||
|
||||
@@ -692,11 +694,13 @@ bool handle_event<x_event_handler::BORDER_CROSSING>(
|
||||
|
||||
if ((not_over_conky && ev.xcrossing.type == LeaveNotify) ||
|
||||
(!not_over_conky && ev.xcrossing.type == EnterNotify)) {
|
||||
+#ifdef BUILD_MOUSE_EVENTS
|
||||
llua_mouse_hook(mouse_crossing_event(
|
||||
ev.xcrossing.type == EnterNotify ? mouse_event_t::AREA_ENTER
|
||||
: mouse_event_t::AREA_LEAVE,
|
||||
ev.xcrossing.x, ev.xcrossing.y, ev.xcrossing.x_root,
|
||||
ev.xcrossing.y_root));
|
||||
+#endif
|
||||
}
|
||||
return true;
|
||||
}
|
10
sysutils/conky/files/patch-src_llua.h
Normal file
10
sysutils/conky/files/patch-src_llua.h
Normal file
|
@ -0,0 +1,10 @@
|
|||
--- src/llua.h.orig 2024-05-07 20:02:47 UTC
|
||||
+++ src/llua.h
|
||||
@@ -31,6 +31,7 @@ extern "C" {
|
||||
}
|
||||
|
||||
#include <config.h>
|
||||
+#include "geometry.h"
|
||||
|
||||
#ifdef BUILD_MOUSE_EVENTS
|
||||
#include "mouse-events.h"
|
11
sysutils/conky/files/patch-src_x11-settings.cc
Normal file
11
sysutils/conky/files/patch-src_x11-settings.cc
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- src/x11-settings.cc.orig 2024-05-07 20:02:47 UTC
|
||||
+++ src/x11-settings.cc
|
||||
@@ -77,7 +77,7 @@ bool use_xpmdb_setting::set_up(lua::state &l) {
|
||||
if (!out_to_x.get(l)) return false;
|
||||
|
||||
window.back_buffer =
|
||||
- XCreatePixmap(display, window.window, window.width + 1, window.height + 1,
|
||||
+ XCreatePixmap(display, window.window, window.geometry.get_width() + 1, window.geometry.get_height() + 1,
|
||||
DefaultDepth(display, screen));
|
||||
if (window.back_buffer != None) {
|
||||
window.drawable = window.back_buffer;
|
16
sysutils/conky/files/patch-src_x11.cc
Normal file
16
sysutils/conky/files/patch-src_x11.cc
Normal file
|
@ -0,0 +1,16 @@
|
|||
--- src/x11.cc.orig 2024-05-14 16:06:21 UTC
|
||||
+++ src/x11.cc
|
||||
@@ -1215,10 +1215,10 @@ void xpmdb_swap_buffers(void) {
|
||||
void xpmdb_swap_buffers(void) {
|
||||
if (use_xpmdb.get(*state)) {
|
||||
XCopyArea(display, window.back_buffer, window.window, window.gc, 0, 0,
|
||||
- window.width, window.height, 0, 0);
|
||||
+ window.geometry.get_width(), window.geometry.get_height(), 0, 0);
|
||||
XSetForeground(display, window.gc, 0);
|
||||
- XFillRectangle(display, window.drawable, window.gc, 0, 0, window.width,
|
||||
- window.height);
|
||||
+ XFillRectangle(display, window.drawable, window.gc, 0, 0, window.geometry.get_width(),
|
||||
+ window.geometry.get_height());
|
||||
XFlush(display);
|
||||
}
|
||||
}
|
Loading…
Add table
Reference in a new issue