mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
net/waypipe: downgrade to 0.9.2 due to broken runtime (unless --no-gpu)
Need help with https://gitlab.freedesktop.org/mstoeckl/waypipe/-/issues/128
This reverts commit 8b2034a505
.
This commit is contained in:
parent
8b2034a505
commit
6abf712284
5 changed files with 32 additions and 163 deletions
|
@ -1,31 +1,33 @@
|
|||
PORTNAME= waypipe
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 0.10.3
|
||||
DISTVERSION= 0.9.2
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= net wayland
|
||||
|
||||
PATCH_SITES= ${GL_SITE}/${GL_ACCOUNT}/${GL_PROJECT}/-/commit/
|
||||
PATCHFILES+= eccbb5cbf1e3.patch:-p1 # https://gitlab.freedesktop.org/mstoeckl/waypipe/-/issues/110
|
||||
PATCHFILES+= 4216e58e3c0f.patch:-p1 # https://gitlab.freedesktop.org/mstoeckl/waypipe/-/issues/116
|
||||
PATCHFILES+= 853cfbb482be.patch:-p1 # https://gitlab.freedesktop.org/mstoeckl/waypipe/-/issues/115
|
||||
|
||||
MAINTAINER= jbeich@FreeBSD.org
|
||||
COMMENT= Network transparency with Wayland
|
||||
WWW= https://gitlab.freedesktop.org/mstoeckl/waypipe
|
||||
|
||||
LICENSE= GPLv3+
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE.GPLv3
|
||||
LICENSE= MIT
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
USES= cargo meson pkgconfig
|
||||
LIB_DEPENDS= libwayland-client.so:graphics/wayland
|
||||
|
||||
USES= compiler:c11 localbase:ldflags meson pkgconfig
|
||||
USE_GITLAB= yes
|
||||
GL_SITE= https://gitlab.freedesktop.org
|
||||
GL_ACCOUNT= mstoeckl
|
||||
MAKE_ENV= ${CARGO_ENV}
|
||||
CARGO_BUILD= no
|
||||
CARGO_INSTALL= no
|
||||
CARGO_TEST= no
|
||||
PLIST_FILES= bin/${PORTNAME}
|
||||
|
||||
OPTIONS_DEFINE= FFMPEG LZ4 MANPAGES VULKAN ZSTD
|
||||
OPTIONS_DEFAULT=FFMPEG LZ4 MANPAGES VULKAN ZSTD
|
||||
OPTIONS_DEFINE= FFMPEG LZ4 MANPAGES OPENGL VAAPI ZSTD
|
||||
OPTIONS_DEFAULT=FFMPEG LZ4 MANPAGES OPENGL VAAPI ZSTD
|
||||
|
||||
FFMPEG_BUILD_DEPENDS= vulkan-headers>0:graphics/vulkan-headers \
|
||||
glslc:graphics/shaderc \
|
||||
ffmpeg>0:multimedia/ffmpeg
|
||||
FFMPEG_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg
|
||||
FFMPEG_MESON_ENABLED= with_video
|
||||
|
||||
LZ4_LIB_DEPENDS= liblz4.so:archivers/liblz4
|
||||
|
@ -35,10 +37,14 @@ MANPAGES_BUILD_DEPENDS= scdoc:textproc/scdoc
|
|||
MANPAGES_MESON_ENABLED= man-pages
|
||||
MANPAGES_PLIST_FILES= share/man/man1/${PORTNAME}.1.gz
|
||||
|
||||
VULKAN_BUILD_DEPENDS= bindgen:devel/rust-bindgen-cli \
|
||||
vulkan-loader>0:graphics/vulkan-loader \
|
||||
${GL_DEFAULT}>0:graphics/${GL_DEFAULT}
|
||||
VULKAN_MESON_ENABLED= with_dmabuf with_gbm
|
||||
OPENGL_USES= gl
|
||||
OPENGL_USE= GL=gbm
|
||||
OPENGL_LIB_DEPENDS= libdrm.so:graphics/libdrm
|
||||
OPENGL_MESON_ENABLED= with_dmabuf
|
||||
|
||||
VAAPI_LIB_DEPENDS= libva.so:multimedia/libva
|
||||
VAAPI_MESON_ENABLED= with_vaapi
|
||||
VAAPI_IMPLIES= FFMPEG
|
||||
|
||||
ZSTD_LIB_DEPENDS= libzstd.so:archivers/zstd
|
||||
ZSTD_MESON_ENABLED= with_zstd
|
||||
|
@ -48,10 +54,5 @@ post-patch:
|
|||
@${REINPLACE_CMD} -i .nogit -e 's/git.found()/false/' \
|
||||
-e '/project_version/s/@0@/${DISTVERSIONFULL}/' \
|
||||
${WRKSRC}/meson.build
|
||||
# Make each cargo subcommand very verbose
|
||||
@${REINPLACE_CMD} -e "/cargo test/,/^[[:space:]]*)/s/-v/&', '&/" \
|
||||
${WRKSRC}/meson.build
|
||||
@${REINPLACE_CMD} -e '/cargo/s/-v/& &/' \
|
||||
${WRKSRC}/compile_wrapper.sh
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,35 +0,0 @@
|
|||
CARGO_CRATES= anstream-0.6.18 \
|
||||
anstyle-1.0.10 \
|
||||
anstyle-parse-0.2.6 \
|
||||
anstyle-query-1.1.2 \
|
||||
anstyle-wincon-3.0.6 \
|
||||
ash-0.38.0+1.3.281 \
|
||||
autocfg-1.4.0 \
|
||||
bitflags-2.6.0 \
|
||||
cfg-if-1.0.0 \
|
||||
cfg_aliases-0.2.1 \
|
||||
clap-4.5.21 \
|
||||
clap_builder-4.5.21 \
|
||||
clap_lex-0.7.3 \
|
||||
colorchoice-1.0.3 \
|
||||
getrandom-0.2.15 \
|
||||
is_terminal_polyfill-1.70.1 \
|
||||
libc-0.2.164 \
|
||||
libloading-0.8.5 \
|
||||
log-0.4.22 \
|
||||
memoffset-0.9.1 \
|
||||
nix-0.29.0 \
|
||||
pkg-config-0.3.31 \
|
||||
strsim-0.11.1 \
|
||||
utf8parse-0.2.2 \
|
||||
wasi-0.11.0+wasi-snapshot-preview1 \
|
||||
windows-sys-0.59.0 \
|
||||
windows-targets-0.52.6 \
|
||||
windows_aarch64_gnullvm-0.52.6 \
|
||||
windows_aarch64_msvc-0.52.6 \
|
||||
windows_i686_gnu-0.52.6 \
|
||||
windows_i686_gnullvm-0.52.6 \
|
||||
windows_i686_msvc-0.52.6 \
|
||||
windows_x86_64_gnu-0.52.6 \
|
||||
windows_x86_64_gnullvm-0.52.6 \
|
||||
windows_x86_64_msvc-0.52.6
|
|
@ -1,73 +1,9 @@
|
|||
TIMESTAMP = 1740684112
|
||||
SHA256 (rust/crates/anstream-0.6.18.crate) = 8acc5369981196006228e28809f761875c0327210a891e941f4c683b3a99529b
|
||||
SIZE (rust/crates/anstream-0.6.18.crate) = 29681
|
||||
SHA256 (rust/crates/anstyle-1.0.10.crate) = 55cc3b69f167a1ef2e161439aa98aed94e6028e5f9a59be9a6ffb47aef1651f9
|
||||
SIZE (rust/crates/anstyle-1.0.10.crate) = 15725
|
||||
SHA256 (rust/crates/anstyle-parse-0.2.6.crate) = 3b2d16507662817a6a20a9ea92df6652ee4f94f914589377d69f3b21bc5798a9
|
||||
SIZE (rust/crates/anstyle-parse-0.2.6.crate) = 22343
|
||||
SHA256 (rust/crates/anstyle-query-1.1.2.crate) = 79947af37f4177cfead1110013d678905c37501914fba0efea834c3fe9a8d60c
|
||||
SIZE (rust/crates/anstyle-query-1.1.2.crate) = 9969
|
||||
SHA256 (rust/crates/anstyle-wincon-3.0.6.crate) = 2109dbce0e72be3ec00bed26e6a7479ca384ad226efdd66db8fa2e3a38c83125
|
||||
SIZE (rust/crates/anstyle-wincon-3.0.6.crate) = 12271
|
||||
SHA256 (rust/crates/ash-0.38.0+1.3.281.crate) = 0bb44936d800fea8f016d7f2311c6a4f97aebd5dc86f09906139ec848cf3a46f
|
||||
SIZE (rust/crates/ash-0.38.0+1.3.281.crate) = 457775
|
||||
SHA256 (rust/crates/autocfg-1.4.0.crate) = ace50bade8e6234aa140d9a2f552bbee1db4d353f69b8217bc503490fc1a9f26
|
||||
SIZE (rust/crates/autocfg-1.4.0.crate) = 17712
|
||||
SHA256 (rust/crates/bitflags-2.6.0.crate) = b048fb63fd8b5923fc5aa7b340d8e156aec7ec02f0c78fa8a6ddc2613f6f71de
|
||||
SIZE (rust/crates/bitflags-2.6.0.crate) = 45357
|
||||
SHA256 (rust/crates/cfg-if-1.0.0.crate) = baf1de4339761588bc0619e3cbc0120ee582ebb74b53b4efbf79117bd2da40fd
|
||||
SIZE (rust/crates/cfg-if-1.0.0.crate) = 7934
|
||||
SHA256 (rust/crates/cfg_aliases-0.2.1.crate) = 613afe47fcd5fac7ccf1db93babcb082c5994d996f20b8b159f2ad1658eb5724
|
||||
SIZE (rust/crates/cfg_aliases-0.2.1.crate) = 6355
|
||||
SHA256 (rust/crates/clap-4.5.21.crate) = fb3b4b9e5a7c7514dfa52869339ee98b3156b0bfb4e8a77c4ff4babb64b1604f
|
||||
SIZE (rust/crates/clap-4.5.21.crate) = 56470
|
||||
SHA256 (rust/crates/clap_builder-4.5.21.crate) = b17a95aa67cc7b5ebd32aa5370189aa0d79069ef1c64ce893bd30fb24bff20ec
|
||||
SIZE (rust/crates/clap_builder-4.5.21.crate) = 164115
|
||||
SHA256 (rust/crates/clap_lex-0.7.3.crate) = afb84c814227b90d6895e01398aee0d8033c00e7466aca416fb6a8e0eb19d8a7
|
||||
SIZE (rust/crates/clap_lex-0.7.3.crate) = 12841
|
||||
SHA256 (rust/crates/colorchoice-1.0.3.crate) = 5b63caa9aa9397e2d9480a9b13673856c78d8ac123288526c37d7839f2a86990
|
||||
SIZE (rust/crates/colorchoice-1.0.3.crate) = 7923
|
||||
SHA256 (rust/crates/getrandom-0.2.15.crate) = c4567c8db10ae91089c99af84c68c38da3ec2f087c3f82960bcdbf3656b6f4d7
|
||||
SIZE (rust/crates/getrandom-0.2.15.crate) = 37163
|
||||
SHA256 (rust/crates/is_terminal_polyfill-1.70.1.crate) = 7943c866cc5cd64cbc25b2e01621d07fa8eb2a1a23160ee81ce38704e97b8ecf
|
||||
SIZE (rust/crates/is_terminal_polyfill-1.70.1.crate) = 7492
|
||||
SHA256 (rust/crates/libc-0.2.164.crate) = 433bfe06b8c75da9b2e3fbea6e5329ff87748f0b144ef75306e674c3f6f7c13f
|
||||
SIZE (rust/crates/libc-0.2.164.crate) = 769055
|
||||
SHA256 (rust/crates/libloading-0.8.5.crate) = 4979f22fdb869068da03c9f7528f8297c6fd2606bc3a4affe42e6a823fdb8da4
|
||||
SIZE (rust/crates/libloading-0.8.5.crate) = 28902
|
||||
SHA256 (rust/crates/log-0.4.22.crate) = a7a70ba024b9dc04c27ea2f0c0548feb474ec5c54bba33a7f72f873a39d07b24
|
||||
SIZE (rust/crates/log-0.4.22.crate) = 44027
|
||||
SHA256 (rust/crates/memoffset-0.9.1.crate) = 488016bfae457b036d996092f6cb448677611ce4449e970ceaf42695203f218a
|
||||
SIZE (rust/crates/memoffset-0.9.1.crate) = 9032
|
||||
SHA256 (rust/crates/nix-0.29.0.crate) = 71e2746dc3a24dd78b3cfcb7be93368c6de9963d30f43a6a73998a9cf4b17b46
|
||||
SIZE (rust/crates/nix-0.29.0.crate) = 318248
|
||||
SHA256 (rust/crates/pkg-config-0.3.31.crate) = 953ec861398dccce10c670dfeaf3ec4911ca479e9c02154b3a215178c5f566f2
|
||||
SIZE (rust/crates/pkg-config-0.3.31.crate) = 20880
|
||||
SHA256 (rust/crates/strsim-0.11.1.crate) = 7da8b5736845d9f2fcb837ea5d9e2628564b3b043a70948a3f0b778838c5fb4f
|
||||
SIZE (rust/crates/strsim-0.11.1.crate) = 14266
|
||||
SHA256 (rust/crates/utf8parse-0.2.2.crate) = 06abde3611657adf66d383f00b093d7faecc7fa57071cce2578660c9f1010821
|
||||
SIZE (rust/crates/utf8parse-0.2.2.crate) = 13499
|
||||
SHA256 (rust/crates/wasi-0.11.0+wasi-snapshot-preview1.crate) = 9c8d87e72b64a3b4db28d11ce29237c246188f4f51057d65a7eab63b7987e423
|
||||
SIZE (rust/crates/wasi-0.11.0+wasi-snapshot-preview1.crate) = 28131
|
||||
SHA256 (rust/crates/windows-sys-0.59.0.crate) = 1e38bc4d79ed67fd075bcc251a1c39b32a1776bbe92e5bef1f0bf1f8c531853b
|
||||
SIZE (rust/crates/windows-sys-0.59.0.crate) = 2387323
|
||||
SHA256 (rust/crates/windows-targets-0.52.6.crate) = 9b724f72796e036ab90c1021d4780d4d3d648aca59e491e6b98e725b84e99973
|
||||
SIZE (rust/crates/windows-targets-0.52.6.crate) = 6403
|
||||
SHA256 (rust/crates/windows_aarch64_gnullvm-0.52.6.crate) = 32a4622180e7a0ec044bb555404c800bc9fd9ec262ec147edd5989ccd0c02cd3
|
||||
SIZE (rust/crates/windows_aarch64_gnullvm-0.52.6.crate) = 435718
|
||||
SHA256 (rust/crates/windows_aarch64_msvc-0.52.6.crate) = 09ec2a7bb152e2252b53fa7803150007879548bc709c039df7627cabbd05d469
|
||||
SIZE (rust/crates/windows_aarch64_msvc-0.52.6.crate) = 832615
|
||||
SHA256 (rust/crates/windows_i686_gnu-0.52.6.crate) = 8e9b5ad5ab802e97eb8e295ac6720e509ee4c243f69d781394014ebfe8bbfa0b
|
||||
SIZE (rust/crates/windows_i686_gnu-0.52.6.crate) = 880402
|
||||
SHA256 (rust/crates/windows_i686_gnullvm-0.52.6.crate) = 0eee52d38c090b3caa76c563b86c3a4bd71ef1a819287c19d586d7334ae8ed66
|
||||
SIZE (rust/crates/windows_i686_gnullvm-0.52.6.crate) = 475940
|
||||
SHA256 (rust/crates/windows_i686_msvc-0.52.6.crate) = 240948bc05c5e7c6dabba28bf89d89ffce3e303022809e73deaefe4f6ec56c66
|
||||
SIZE (rust/crates/windows_i686_msvc-0.52.6.crate) = 901163
|
||||
SHA256 (rust/crates/windows_x86_64_gnu-0.52.6.crate) = 147a5c80aabfbf0c7d901cb5895d1de30ef2907eb21fbbab29ca94c5b08b1a78
|
||||
SIZE (rust/crates/windows_x86_64_gnu-0.52.6.crate) = 836363
|
||||
SHA256 (rust/crates/windows_x86_64_gnullvm-0.52.6.crate) = 24d5b23dc417412679681396f2b49f3de8c1473deb516bd34410872eff51ed0d
|
||||
SIZE (rust/crates/windows_x86_64_gnullvm-0.52.6.crate) = 435707
|
||||
SHA256 (rust/crates/windows_x86_64_msvc-0.52.6.crate) = 589f6da84c646204747d1270a2a5661ea66ed1cced2631d546fdfb155959f9ec
|
||||
SIZE (rust/crates/windows_x86_64_msvc-0.52.6.crate) = 832564
|
||||
SHA256 (waypipe-v0.10.3.tar.bz2) = 0810b6f315937f9aaf1807f38ccccbb3932e0a2fed11de16da6615c5ba1a12a3
|
||||
SIZE (waypipe-v0.10.3.tar.bz2) = 433874
|
||||
TIMESTAMP = 1731968960
|
||||
SHA256 (waypipe-v0.9.2.tar.bz2) = ef0783ba95abb950cb0e876e1d186de77905759ed7406ec23973f46cab96b5ee
|
||||
SIZE (waypipe-v0.9.2.tar.bz2) = 196024
|
||||
SHA256 (eccbb5cbf1e3.patch) = e9f2cb8f771deda59be2041c625bb8da4af068cefbfb40fa880480e5d4e87e67
|
||||
SIZE (eccbb5cbf1e3.patch) = 543
|
||||
SHA256 (4216e58e3c0f.patch) = 25de12dad5de8f7e409751653adeb07380e248dfc7e08c625fef64cbb610ee06
|
||||
SIZE (4216e58e3c0f.patch) = 828
|
||||
SHA256 (853cfbb482be.patch) = 2ae021c59e45ca8f9883538432f0de9750c7d307e64234fe57b9f7cd4789056c
|
||||
SIZE (853cfbb482be.patch) = 786
|
||||
|
|
|
@ -1,20 +0,0 @@
|
|||
https://gitlab.freedesktop.org/mstoeckl/waypipe/-/issues/129
|
||||
|
||||
--- meson.build.orig 2025-02-27 19:21:52 UTC
|
||||
+++ meson.build
|
||||
@@ -103,6 +103,6 @@ if get_option('build_rs')
|
||||
)
|
||||
libavutil = dependency(
|
||||
'libavutil',
|
||||
- version: '>=59.39.100',
|
||||
+ version: '>=58.29.100',
|
||||
required: get_option('with_video'),
|
||||
)
|
||||
@@ -109,6 +109,6 @@
|
||||
libavcodec = dependency(
|
||||
'libavcodec',
|
||||
- version: '>=61.19.100',
|
||||
+ version: '>=60.19.100',
|
||||
required: get_option('with_video'),
|
||||
)
|
||||
if bindgen.found() and libavcodec.found() and libavutil.found() and glslc.found()
|
|
@ -1,13 +0,0 @@
|
|||
https://gitlab.freedesktop.org/mstoeckl/waypipe/-/issues/128
|
||||
|
||||
--- src/dmabuf.rs.orig 2025-02-27 19:21:52 UTC
|
||||
+++ src/dmabuf.rs
|
||||
@@ -2806,7 +2806,7 @@ pub fn get_dev_for_drm_node_path(path: &PathBuf) -> Re
|
||||
|
||||
pub fn get_dev_for_drm_node_path(path: &PathBuf) -> Result<u64, String> {
|
||||
let r = nix::sys::stat::stat(path).map_err(|_| "Failed to get device for drm node path")?;
|
||||
- Ok(r.st_rdev)
|
||||
+ Ok(r.st_rdev.into())
|
||||
}
|
||||
|
||||
impl VulkanDevice {
|
Loading…
Add table
Reference in a new issue