mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
science/libkml: Simplify expat fix
This commit is contained in:
parent
31661a3f15
commit
6ab2eadcf0
2 changed files with 1 additions and 12 deletions
|
@ -16,6 +16,7 @@ LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
|
|||
|
||||
USES= cmake compiler:c++11-lang minizip pathfix
|
||||
|
||||
CMAKE_ARGS= -DEXPAT_LIBRARY=${LOCALBASE}/lib/libexpat.so
|
||||
CMAKE_OFF= BUILD_TESTING WITH_JAVA WITH_PYTHON WITH_SWIG
|
||||
CMAKE_ON= BUILD_SHARED_LIBS
|
||||
LDFLAGS+= -lz
|
||||
|
|
|
@ -1,12 +0,0 @@
|
|||
Fix linking with CMake >= 3.27 due to changes [1] in the FindEXPAT module.
|
||||
|
||||
[1] https://github.com/Kitware/CMake/commit/13079f382b480c8fe6a68d98afc2cec716a75e59
|
||||
|
||||
--- src/kml/base/CMakeLists.txt.orig 2017-01-15 08:52:06 UTC
|
||||
+++ src/kml/base/CMakeLists.txt
|
||||
@@ -49,4 +49,4 @@ build_target(
|
||||
SRCS ${SRCS}
|
||||
INCS ${INCS}
|
||||
DEPENDS ${KMLBASE_DEPENDS}
|
||||
- LINKS ${ZLIB_LIBRARY} ${MINIZIP_LIBRARIES} ${URIPARSER_LIBRARY} ${EXPAT_LIBRARY} )
|
||||
+ LINKS ${ZLIB_LIBRARY} ${MINIZIP_LIBRARIES} ${URIPARSER_LIBRARY} EXPAT::EXPAT )
|
Loading…
Add table
Reference in a new issue