mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
graphics/py-mayavi: update 4.8.1 → 4.8.2
This commit is contained in:
parent
5ade161210
commit
69eaa3254a
4 changed files with 6 additions and 49 deletions
|
@ -1,6 +1,5 @@
|
|||
PORTNAME= mayavi
|
||||
DISTVERSION= 4.8.1
|
||||
PORTREVISION= 7
|
||||
DISTVERSION= 4.8.2
|
||||
CATEGORIES= graphics science python
|
||||
MASTER_SITES= PYPI
|
||||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
|
||||
|
@ -38,7 +37,8 @@ USE_PYTHON= distutils autoplist
|
|||
USE_WX= 3.2
|
||||
WX_COMPS= python:run
|
||||
|
||||
SHEBANG_FILES= mayavi/tests/csv_files/csv_2_py
|
||||
SHEBANG_FILES= mayavi/scripts/mayavi2 \
|
||||
mayavi/tests/csv_files/csv_2_py
|
||||
|
||||
POST_PLIST= fix-plist
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1666417495
|
||||
SHA256 (mayavi-4.8.1.tar.gz) = 9f427ef2ca6c91ae78d92d3689ba6beca24c8460e2706d8a1c9b84289ad3fd9e
|
||||
SIZE (mayavi-4.8.1.tar.gz) = 20607299
|
||||
TIMESTAMP = 1717834084
|
||||
SHA256 (mayavi-4.8.2.tar.gz) = b10fe9145f21c48e4902f0e746b3603b3cb694d11456515a46820f21a0a74229
|
||||
SIZE (mayavi-4.8.2.tar.gz) = 7100132
|
||||
|
|
|
@ -1,32 +0,0 @@
|
|||
- The first patch is to fix build by accepting tvtk_classes.zip,
|
||||
- otherwise the build SEGVs on some platforms.
|
||||
- Rebuilding tvtk_classes.zip seems to cause SEGVs.
|
||||
|
||||
- Misc other patches.
|
||||
|
||||
--- setup.py.orig 2022-10-17 14:42:18 UTC
|
||||
+++ setup.py
|
||||
@@ -260,7 +260,7 @@ def _tvtk_built_recently(zipfile, delay):
|
||||
def build_tvtk_classes_zip():
|
||||
MY_DIR = os.path.dirname(__file__)
|
||||
zipfile = os.path.join(MY_DIR, 'tvtk', 'tvtk_classes.zip')
|
||||
- if _tvtk_built_recently(zipfile, delay=120):
|
||||
+ if True or _tvtk_built_recently(zipfile, delay=120):
|
||||
print("Already built tvtk_classes.zip")
|
||||
return
|
||||
else:
|
||||
@@ -378,12 +378,12 @@ def configuration(parent_package=None, top_path=None):
|
||||
config.add_data_dir('mayavi/core/lut')
|
||||
config.add_data_dir('mayavi/tests/data')
|
||||
config.add_data_dir('mayavi/tests/csv_files')
|
||||
- config.add_data_dir('mayavi/tools/static')
|
||||
+ config.add_data_dir('mayavi/tools/static/x3d')
|
||||
|
||||
# Image files.
|
||||
for pkgdir in ('mayavi', 'tvtk'):
|
||||
for root, dirs, files in os.walk(pkgdir):
|
||||
- if split(root)[-1] == 'images':
|
||||
+ if split(root)[-1] == 'images' and files:
|
||||
config.add_data_dir(root)
|
||||
|
||||
# *.ini files.
|
|
@ -1,11 +0,0 @@
|
|||
--- tvtk/setup.py.orig 2016-08-01 19:02:36 UTC
|
||||
+++ tvtk/setup.py
|
||||
@@ -20,7 +20,7 @@ def configuration(parent_package=None, t
|
||||
config.add_subpackage('custom')
|
||||
config.add_subpackage('pipeline')
|
||||
config.add_data_dir('pipeline/images')
|
||||
- config.add_data_dir('pyface/images')
|
||||
+# config.add_data_dir('pyface/images')
|
||||
config.add_data_dir('tools/images')
|
||||
|
||||
config.add_subpackage('plugins')
|
Loading…
Add table
Reference in a new issue