. Fix the location of the

FILES_c += initIDs.c

  line so it comes after FILE_c is explicitly set in the BSD specific
  block.  This fixes missing symbols in libawt.

Submitted by:	Kurt Miller (kurt@intricatesoftware.com)
Obtained from:	http://hg.openjdk.java.net/bsd-port/bsd-port/jdk/rev/ef510cd4aec5
This commit is contained in:
Greg Lewis 2013-03-27 03:11:33 +00:00
parent e2f338bdce
commit 69c1296d68
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=315346

View file

@ -0,0 +1,20 @@
--- jdk/make/sun/awt/Makefile.orig 2013-03-26 18:41:21.000000000 -0700
+++ jdk/make/sun/awt/Makefile 2013-03-26 18:41:38.000000000 -0700
@@ -123,8 +123,6 @@
OTHER_LDLIBS = $(JVMLIB) $(LIBM) $(LIBDL)
endif
-FILES_c += initIDs.c
-
ifeq ($(PLATFORM), bsd)
FILES_c = $(FILES_2D_c)
FILES_c += awt_LoadLibrary.c
@@ -139,6 +137,8 @@
OTHER_LDLIBS = $(JVMLIB) $(LIBM)
endif
+FILES_c += initIDs.c
+
# ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ SOLARIS/LINUX
endif # PLATFORM