www/c-icap-modules: update to 0.5.7

Changelog: https://sourceforge.net/p/c-icap/mailman/message/58723534/
This commit is contained in:
Rodrigo Osorio 2024-07-10 17:59:58 +02:00
parent f5bd252c20
commit 68f3fe36d4
3 changed files with 43 additions and 6 deletions

View file

@ -1,6 +1,5 @@
PORTNAME= c-icap PORTNAME= c-icap
PORTVERSION= 0.5.6 PORTVERSION= 0.5.7
PORTREVISION= 1
CATEGORIES= www security CATEGORIES= www security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}/0.5.x/ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}/0.5.x/
PKGNAMESUFFIX= -modules PKGNAMESUFFIX= -modules
@ -16,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libclamav.so:security/clamav \ LIB_DEPENDS= libclamav.so:security/clamav \
libicapapi.so:www/c-icap libicapapi.so:www/c-icap
USES= libtool USES= libtool autoreconf
GNU_CONFIGURE= yes GNU_CONFIGURE= yes
GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
CONFIGURE_ARGS= --enable-static \ CONFIGURE_ARGS= --enable-static \

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1699301325 TIMESTAMP = 1720345204
SHA256 (c_icap_modules-0.5.6.tar.gz) = 4d35205a5fdb1cbd9b0a088e66b62ddcbafa251904b92e8ae9f78a534b37d055 SHA256 (c_icap_modules-0.5.7.tar.gz) = 80bc0af10be171c0c73cd5886533a397c4d55211756fb6279f245ee7e5dd3814
SIZE (c_icap_modules-0.5.6.tar.gz) = 454248 SIZE (c_icap_modules-0.5.7.tar.gz) = 456000

View file

@ -0,0 +1,38 @@
--- configure.ac.orig 2024-07-10 10:13:59.977549000 +0000
+++ configure.ac 2024-07-10 10:15:44.659810000 +0000
@@ -165,7 +165,7 @@
AC_COMPILE_IFELSE([AC_LANG_SOURCE(
[
#include <clamav.h>
- int main(int argc, char *argv[])
+ int main(int argc, char **argv)
{
struct cl_engine node; node.refcount=1;
}
@@ -181,7 +181,7 @@
AC_COMPILE_IFELSE([AC_LANG_SOURCE(
[
#include <clamav.h>
- int main(int argc, cgar *argv[])
+ int main(int argc, char **argv)
{
struct cl_limits limits;
limits.maxratio=200;
@@ -201,7 +201,7 @@
AC_COMPILE_IFELSE([AC_LANG_SOURCE(
[
#include <clamav.h>
- int main(int argc, char *argv[])
+ int main(int argc, char **argv)
{
struct cl_limits limits;
}
@@ -221,7 +221,7 @@
AC_COMPILE_IFELSE([AC_LANG_SOURCE(
[
#include <clamav.h>
- int main(int argc, char *argv[])
+ int main(int argc, char **argv)
{
struct cl_scan_options CLAMSCAN_OPTIONS = { 0, 0, 0, 0, 0 };
}