graphics/glvis: update 4.2 → 4.3.2

This commit is contained in:
Yuri Victorovich 2025-01-18 01:50:09 -08:00
parent 85e3e569f7
commit 679e7913af
4 changed files with 25 additions and 33 deletions

View file

@ -1,6 +1,5 @@
PORTNAME= glvis
DISTVERSION= 4.2
PORTREVISION= 4
DISTVERSION= 4.3.2
CATEGORIES= graphics
MASTER_SITES= https://glvis.github.io/releases/
PKGNAMESUFFIX= -mesh-visualizer # other software also has the name glvis
@ -8,7 +7,8 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Lightweight tool for accurate & flexible finite element visualization
WWW= https://glvis.org/
WWW= https://glvis.org \
https://github.com/glvis/glvis
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
@ -27,8 +27,10 @@ USES= cmake:testing gl python:test sdl tar:tgz
USE_GL= gl glew
USE_SDL= sdl2
# the mpi dependency is inherited from math/mfem and not set here for simplicity
USE_GITHUB= nodefault
GH_TUPLE= GLVis:data:1fc2954:data/tests/data
GH_TUPLE= GLVis:data:b8092cc:data/tests/data
CMAKE_TESTING_ON= ENABLE_TESTS # 5 tests fail, likely because test baseline is for ubuntu
CMAKE_ARGS= -DGLVIS_BASELINE_SYS=ubuntu-20.04 # baseline for tests

View file

@ -1,5 +1,5 @@
TIMESTAMP = 1661361561
SHA256 (glvis-4.2.tgz) = 314fb04040cd0a8128d6dac62ba67d7067c2c097364e5747182ee8371049b42a
SIZE (glvis-4.2.tgz) = 2477717
SHA256 (GLVis-data-1fc2954_GH0.tar.gz) = 130f75ada7c1b4abebb85f0a60a387456fa532f194f4d196b9ea58d1dfc1189d
SIZE (GLVis-data-1fc2954_GH0.tar.gz) = 15711923
TIMESTAMP = 1737152720
SHA256 (glvis-4.3.2.tgz) = d24f0b444a3dcdb99eada90852308b657e5a0bb8c6225545ca5628445aa47ad1
SIZE (glvis-4.3.2.tgz) = 2488479
SHA256 (GLVis-data-b8092cc_GH0.tar.gz) = 3ee95b3bf99513aee468b50786ca32ae6ffff33abdd55a72e64bb086a30f199f
SIZE (GLVis-data-b8092cc_GH0.tar.gz) = 21043606

View file

@ -1,6 +1,6 @@
--- CMakeLists.txt.orig 2022-05-24 00:33:38 UTC
--- CMakeLists.txt.orig 2024-09-27 21:31:27 UTC
+++ CMakeLists.txt
@@ -22,7 +22,7 @@ if ("${CMAKE_SOURCE_DIR}" STREQUAL "${CMAKE_BINARY_DIR
@@ -22,7 +22,7 @@ endif ("${CMAKE_SOURCE_DIR}" STREQUAL "${CMAKE_BINARY_
message(FATAL_ERROR "In-source builds are prohibited.")
endif ("${CMAKE_SOURCE_DIR}" STREQUAL "${CMAKE_BINARY_DIR}")
@ -9,16 +9,19 @@
# Import MFEM. The following variables can be used to help CMake find MFEM:
# * MFEM_DIR - absolute path to the MFEM build or install prefix.
@@ -333,10 +333,12 @@ if(NOT EMSCRIPTEN)
install(TARGETS app
RUNTIME DESTINATION .
BUNDLE DESTINATION .)
@@ -342,6 +342,7 @@ if(NOT EMSCRIPTEN)
install(TARGETS app
RUNTIME DESTINATION .
BUNDLE DESTINATION .)
+ if (FALSE)
install(CODE [[
include (BundleUtilities)
fixup_bundle("${CMAKE_INSTALL_PREFIX}/GLVis.app" "" "")
]] COMPONENT RUNTIME)
install(CODE [[
include (BundleUtilities)
fixup_bundle("${CMAKE_INSTALL_PREFIX}/GLVis.app" "" "")
@@ -354,6 +355,7 @@ if(NOT EMSCRIPTEN)
endforeach()
execute_process(COMMAND codesign --force --sign - ${CMAKE_INSTALL_PREFIX}/GLVis.app)
]] COMPONENT RUNTIME)
+ endif()
endif(APPLE)
endif(NOT EMSCRIPTEN)

View file

@ -1,13 +0,0 @@
--- lib/aux_vis.cpp.orig 2022-09-11 23:06:14 UTC
+++ lib/aux_vis.cpp
@@ -822,8 +822,8 @@ const char *glvis_screenshot_ext = ".bmp";
#if SDL_BYTEORDER == SDL_BIG_ENDIAN
Uint32 rmask = 0xff000000;
Uint32 gmask = 0x00ff0000;
-Uint32 bmask = 0x0000ff00:
- Uint32 amask = 0x000000ff;
+Uint32 bmask = 0x0000ff00;
+Uint32 amask = 0x000000ff;
#else // little endian, like x86
Uint32 rmask = 0x000000ff;
Uint32 gmask = 0x0000ff00;