lang/pharo: Update to 10.2.0

PR:		278583
This commit is contained in:
Zoltán Király 2024-04-25 22:12:12 +03:00 committed by Li-Wen Hsu
parent 1293b5f0c5
commit 6315307ba0
No known key found for this signature in database
GPG key ID: 7377A4A02A2954DD
4 changed files with 29 additions and 9 deletions

View file

@ -1,14 +1,13 @@
PORTNAME= pharo
DISTVERSION= 10.0.9
DISTVERSIONSUFFIX= de76067
PORTREVISION= 3
DISTVERSION= 10.2.0
DISTVERSIONSUFFIX= f4c5e2a
CATEGORIES= lang
MASTER_SITES= http://files.pharo.org/vm/pharo-spur64-headless/Linux-x86_64/source/
DISTNAME= PharoVM-${DISTVERSION}-${DISTVERSIONSUFFIX}-Linux-x86_64-c-src
MAINTAINER= ports@FreeBSD.org
COMMENT= Smalltalk-inspired language and environment
WWW= http://www.pharo.org/
WWW= https://www.pharo.org/
LICENSE= MIT

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1700701195
SHA256 (PharoVM-10.0.9-de76067-Linux-x86_64-c-src.tar.gz) = e797b3b00be38fbd158ffba732d175307fe9928421529e1f5b96a9e553f018bf
SIZE (PharoVM-10.0.9-de76067-Linux-x86_64-c-src.tar.gz) = 3875300
TIMESTAMP = 1714060881
SHA256 (PharoVM-10.2.0-f4c5e2a-Linux-x86_64-c-src.tar.gz) = c82e7950984c65cce3f1ea92ae9e8ac2b39ebfa9d71915c00470a09778ee264b
SIZE (PharoVM-10.2.0-f4c5e2a-Linux-x86_64-c-src.tar.gz) = 3911477

View file

@ -0,0 +1,13 @@
--- CMakeLists.txt.orig 2024-04-25 18:54:30 UTC
+++ CMakeLists.txt
@@ -570,10 +570,6 @@ add_third_party_dependencies_per_platform()
# Handling Third party dependencies
add_third_party_dependencies_per_platform()
-if (UNIX)
- addIndependentLibraryWithRPATH(tty ${CMAKE_CURRENT_SOURCE_DIR}/tty/tty.c)
-endif()
-
# Signing Setup
include(cmake/sign.cmake)

View file

@ -1,6 +1,14 @@
--- packaging/linux/bin/launch.sh.in.orig 2023-11-23 00:48:34 UTC
--- packaging/linux/bin/launch.sh.in.orig 2024-04-15 08:04:05 UTC
+++ packaging/linux/bin/launch.sh.in
@@ -27,13 +27,13 @@ fi
@@ -17,6 +17,7 @@ esac
/*) PLUGINS="$BIN";;
*) PLUGINS="`pwd`/$BIN"
esac
+PLUGINS=${PLUGINS%libexec*}lib${PLUGINS#*/libexec}
if [ $(uname -s) = "OpenBSD" ]; then
LD_LIBRARY_PATH="$PLUGINS:${LD_LIBRARY_PATH}" exec $GDB "$BIN/@VM_EXECUTABLE_NAME@" "$@"
@@ -27,13 +28,13 @@ fi
# and so it should take precedence over /lib libc. This is done by setting
# LD_LIBRARY_PATH appropriately, based on ldd's idea of the libc use by the VM.
#Try extracting Libc