mirror of
https://git.freebsd.org/ports.git
synced 2025-05-25 15:36:35 -04:00
Digitalcoin is an open source digital currency, originally based on Bitcoin,
but now heavily modified and improved. Digitalcoin works over a distributed peer-to-peer network to offer irreversible, low-cost, anonymous and decentralized monetary transactions. WWW: http://digitalcoin.co/ PR: ports/184369 Submitted by: myst3r10n <myst3r10n@rocketmail.com>
This commit is contained in:
parent
3dfe432a23
commit
622250ba46
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=340216
7 changed files with 104 additions and 0 deletions
|
@ -21,6 +21,7 @@
|
||||||
SUBDIR += ctorrent
|
SUBDIR += ctorrent
|
||||||
SUBDIR += dclib
|
SUBDIR += dclib
|
||||||
SUBDIR += deluge
|
SUBDIR += deluge
|
||||||
|
SUBDIR += digitalcoin
|
||||||
SUBDIR += dogecoin
|
SUBDIR += dogecoin
|
||||||
SUBDIR += ed2k
|
SUBDIR += ed2k
|
||||||
SUBDIR += edonkey-tool-hash
|
SUBDIR += edonkey-tool-hash
|
||||||
|
|
51
net-p2p/digitalcoin/Makefile
Normal file
51
net-p2p/digitalcoin/Makefile
Normal file
|
@ -0,0 +1,51 @@
|
||||||
|
# Created by: myst3r10n <myst3r10n@rocketmail.com>
|
||||||
|
# $FreeBSD$
|
||||||
|
|
||||||
|
PORTNAME= digitalcoin
|
||||||
|
PORTVERSION= 1.0.0.0b
|
||||||
|
CATEGORIES= net-p2p
|
||||||
|
|
||||||
|
MAINTAINER= myst3r10n@rocketmail.com
|
||||||
|
COMMENT= Alternative Bitcoin peer-to-peer currency client
|
||||||
|
|
||||||
|
LIB_DEPENDS= libboost_date_time.so:${PORTSDIR}/devel/boost-libs \
|
||||||
|
libminiupnpc.so:${PORTSDIR}/net/miniupnpc
|
||||||
|
|
||||||
|
WRKSRC= ${WRKDIR}/${GH_ACCOUNT}-${PORTNAME}-${GH_COMMIT}
|
||||||
|
|
||||||
|
USE_GITHUB= yes
|
||||||
|
GH_ACCOUNT= baritus
|
||||||
|
GH_PROJECT= ${PORTNAME}
|
||||||
|
GH_COMMIT= 96b098a
|
||||||
|
GH_TAGNAME= ${GH_COMMIT}
|
||||||
|
|
||||||
|
USES= gmake
|
||||||
|
USE_OPENSSL= yes
|
||||||
|
USE_BDB= yes
|
||||||
|
WANT_BDB_VER= 48
|
||||||
|
USE_QT4= corelib gui qmake_build linguist uic moc rcc
|
||||||
|
|
||||||
|
PLIST_FILES= bin/${BINARY} share/applications/digitalcoin-qt.desktop share/pixmaps/digitalcoin.png
|
||||||
|
|
||||||
|
BINARY= digitalcoin-qt
|
||||||
|
|
||||||
|
.include <bsd.port.pre.mk>
|
||||||
|
|
||||||
|
do-configure:
|
||||||
|
cd ${WRKSRC} && ${SETENV} ${QMAKE_ENV} \
|
||||||
|
${QMAKE} ${QMAKE_ARGS} USE_UPNP=${QMAKE_USE_UPNP} USE_QRCODE=${QMAKE_USE_QRCODE} \
|
||||||
|
QMAKE_LRELEASE=lrelease-qt4 PREFIX=${PREFIX} INCLUDEPATH=${BDB_INCLUDE_DIR} \
|
||||||
|
QMAKE_LIBDIR+=${BDB_LIB_DIR} ${PORTNAME}-qt.pro
|
||||||
|
|
||||||
|
do-install:
|
||||||
|
@${MKDIR} ${PREFIX}/bin
|
||||||
|
${INSTALL_PROGRAM} ${WRKSRC}/${BINARY} ${STAGEDIR}${PREFIX}/bin/
|
||||||
|
${REINPLACE_CMD} -e 's,=/usr,=${PREFIX},' \
|
||||||
|
-e 's,bitcoin,digitalcoin,g' \
|
||||||
|
-e 's,Bitcoin,Digitalcoin,g' \
|
||||||
|
-e 's,xpm,png,g' \
|
||||||
|
-e 's,80,,g' ${WRKSRC}/contrib/debian/bitcoin-qt.desktop
|
||||||
|
${INSTALL} ${WRKSRC}/contrib/debian/bitcoin-qt.desktop ${STAGEDIR}${PREFIX}/share/applications/digitalcoin-qt.desktop
|
||||||
|
${INSTALL} ${WRKSRC}/src/qt/res/icons/bitcoin.png ${STAGEDIR}${PREFIX}/share/pixmaps/digitalcoin.png
|
||||||
|
|
||||||
|
.include <bsd.port.post.mk>
|
2
net-p2p/digitalcoin/distinfo
Normal file
2
net-p2p/digitalcoin/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
||||||
|
SHA256 (digitalcoin-1.0.0.0b.tar.gz) = 5ef55e55eb0fc6ec6b86aa559a93cca9e23f1f0cba10b6635527d58373679f14
|
||||||
|
SIZE (digitalcoin-1.0.0.0b.tar.gz) = 1873811
|
11
net-p2p/digitalcoin/files/patch-src__net.cpp
Normal file
11
net-p2p/digitalcoin/files/patch-src__net.cpp
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- src/net.cpp.orig 2014-01-18 04:31:19.000000000 +0000
|
||||||
|
+++ src/net.cpp 2014-01-18 04:32:57.000000000 +0000
|
||||||
|
@@ -58,7 +58,7 @@
|
||||||
|
static bool vfLimited[NET_MAX] = {};
|
||||||
|
static CNode* pnodeLocalHost = NULL;
|
||||||
|
uint64 nLocalHostNonce = 0;
|
||||||
|
-array<int, THREAD_MAX> vnThreadsRunning;
|
||||||
|
+boost::array<int, THREAD_MAX> vnThreadsRunning;
|
||||||
|
static std::vector<SOCKET> vhListenSocket;
|
||||||
|
CAddrMan addrman;
|
||||||
|
|
11
net-p2p/digitalcoin/files/patch-src__qt__qtipcserver.cpp
Normal file
11
net-p2p/digitalcoin/files/patch-src__qt__qtipcserver.cpp
Normal file
|
@ -0,0 +1,11 @@
|
||||||
|
--- src/qt/qtipcserver.cpp.orig 2014-01-18 05:21:31.335425774 +0000
|
||||||
|
+++ src/qt/qtipcserver.cpp 2014-01-18 05:22:33.976421840 +0000
|
||||||
|
@@ -21,7 +21,7 @@
|
||||||
|
|
||||||
|
static void ipcThread2(void* pArg);
|
||||||
|
|
||||||
|
-#ifdef MAC_OSX
|
||||||
|
+#if defined(MAC_OSX) || defined(__FreeBSD__)
|
||||||
|
// URI handling not implemented on OSX yet
|
||||||
|
|
||||||
|
void ipcInit() { }
|
22
net-p2p/digitalcoin/files/patch-src__serialize.h
Normal file
22
net-p2p/digitalcoin/files/patch-src__serialize.h
Normal file
|
@ -0,0 +1,22 @@
|
||||||
|
--- ./src/serialize.h.orig 2013-09-24 01:50:35.661706153 +0000
|
||||||
|
+++ ./src/serialize.h 2013-09-24 01:50:52.913703572 +0000
|
||||||
|
@@ -895,19 +895,6 @@
|
||||||
|
iterator insert(iterator it, const char& x=char()) { return vch.insert(it, x); }
|
||||||
|
void insert(iterator it, size_type n, const char& x) { vch.insert(it, n, x); }
|
||||||
|
|
||||||
|
- void insert(iterator it, const_iterator first, const_iterator last)
|
||||||
|
- {
|
||||||
|
- assert(last - first >= 0);
|
||||||
|
- if (it == vch.begin() + nReadPos && (unsigned int)(last - first) <= nReadPos)
|
||||||
|
- {
|
||||||
|
- // special case for inserting at the front when there's room
|
||||||
|
- nReadPos -= (last - first);
|
||||||
|
- memcpy(&vch[nReadPos], &first[0], last - first);
|
||||||
|
- }
|
||||||
|
- else
|
||||||
|
- vch.insert(it, first, last);
|
||||||
|
- }
|
||||||
|
-
|
||||||
|
void insert(iterator it, std::vector<char>::const_iterator first, std::vector<char>::const_iterator last)
|
||||||
|
{
|
||||||
|
assert(last - first >= 0);
|
6
net-p2p/digitalcoin/pkg-descr
Normal file
6
net-p2p/digitalcoin/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
||||||
|
Digitalcoin is an open source digital currency, originally based on Bitcoin,
|
||||||
|
but now heavily modified and improved. Digitalcoin works over a distributed
|
||||||
|
peer-to-peer network to offer irreversible, low-cost, anonymous and
|
||||||
|
decentralized monetary transactions.
|
||||||
|
|
||||||
|
WWW: http://digitalcoin.co/
|
Loading…
Add table
Reference in a new issue