uGet is a very powerful download manager application, with large inventory

of features but is still very light-weight and low on resources.

General features:
- Downloads queue
- Resume downloads
- Advanced download categories
- Clipboard monitor
- Batch downloads
- Multi-protocol
- Scheduler

WWW: http://ugetdm.com/
This commit is contained in:
Olivier Duchateau 2014-07-12 11:25:04 +00:00
parent 83fd1f7a1e
commit 60a0ef534b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=361611
10 changed files with 259 additions and 0 deletions

View file

@ -1206,6 +1206,7 @@
SUBDIR += udptunnel
SUBDIR += udpxy
SUBDIR += udt
SUBDIR += uget
SUBDIR += ulxmlrpcpp
SUBDIR += unfs3
SUBDIR += unison

92
net/uget/Makefile Normal file
View file

@ -0,0 +1,92 @@
# Created by: Olivier Duchateau
# $FreeBSD$
PORTNAME= uget
PORTVERSION= 1.10.4
CATEGORIES= net
MASTER_SITES= SF
MASTER_SITE_SUBDIR= urlget/${PORTNAME}%20%28stable%29/${PORTVERSION}
MAINTAINER= olivierd@FreeBSD.org
COMMENT= Download manager application
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libnotify.so:${PORTSDIR}/devel/libnotify
USES= gmake pkgconfig
GNU_CONFIGURE= yes
USE_GNOME= glib20 gtk30 intltool intlhack
INSTALLS_ICONS= yes
OPTIONS_DEFINE= GNUTLS NLS
OPTIONS_RADIO= GSTREAMER
OPTIONS_RADIO_GSTREAMER= GST01 GST10
OPTIONS_GROUP= PLUGINS
OPTIONS_GROUP_PLUGINS= PLUG_ARIA PLUG_CURL
OPTIONS_DEFAULT= GNUTLS GST10 NLS PLUG_CURL
# GNUTLS option is currently broken, fixed in 'master' branch
OPTIONS_EXCLUDE= GNUTLS
GST010_DESC= GStreamer 0.10
GST10_DESC= GStreamer 1.0
PLUG_ARIA_DESC= Aria2 plugin
PLUG_CURL_DESC= cURL plugin
CONFIGURE_ARGS=--enable-appindicator=no \
--disable-pwmd \
--enable-hidden
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGNUTLS}
LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls \
libgcrypt.so:${PORTSDIR}/security/libgcrypt
CONFIGURE_ARGS+=--enable-gnutls
.else
CONFIGURE_ARGS+=--disable-gnutls
.endif
.if ${PORT_OPTIONS:MNLS}
USES+= gettext
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
.if ${PORT_OPTIONS:MGST10}
USE_GSTREAMER1= yes
CONFIGURE_ARGS+=--enable-gstreamer
.endif
.if ${PORT_OPTIONS:MGST01}
USE_GSTREAMER= yes
CONFIGURE_ARGS+=--enable-gstreamer
.endif
.if ! ${PORT_OPTIONS:MGST10} && ! ${PORT_OPTIONS:MGST01}
CONFIGURE_ARGS+=--disable-gstreamer
.endif
.if ${PORT_OPTIONS:MPLUG_ARIA}
BUILD_DEPENDS= aria2c:${PORTSDIR}/www/aria2
CONFIGURE_ARGS+=--enable-plugin-aria2
.else
CONFIGURE_ARGS+=--disable-plugin-aria2
.endif
.if ${PORT_OPTIONS:MPLUG_CURL}
BUILD_DEPENDS= curl-config:${PORTSDIR}/ftp/curl
CONFIGURE_ARGS+=--enable-plugin-curl
.else
CONFIGURE_ARGS+=--disable-plugin-curl
.endif
post-install:
cd ${WRKSRC}/uget-cmd && \
${INSTALL_PROGRAM} uget-cmd ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>

2
net/uget/distinfo Normal file
View file

@ -0,0 +1,2 @@
SHA256 (uget-1.10.4.tar.gz) = a25c5cc9af4e87a2c22206f376ffce70697ef743a902ecf028b50a586180a622
SIZE (uget-1.10.4.tar.gz) = 576147

View file

@ -0,0 +1,11 @@
--- ./configure.orig 2014-01-01 09:25:49.000000000 +0000
+++ ./configure 2014-07-12 10:05:16.000000000 +0000
@@ -5753,7 +5753,7 @@
fi
fi
- USE_NLS=yes
+ #USE_NLS=yes
gt_cv_have_gettext=no

View file

@ -0,0 +1,31 @@
--- ./po/Makefile.in.in.orig 2012-04-02 08:48:47.000000000 +0000
+++ ./po/Makefile.in.in 2014-07-12 11:21:45.000000000 +0000
@@ -34,7 +34,7 @@
datarootdir = @datarootdir@
libdir = @libdir@
DATADIRNAME = @DATADIRNAME@
-itlocaledir = $(prefix)/$(DATADIRNAME)/locale
+localedir = @localedir@
subdir = po
install_sh = @install_sh@
# Automake >= 1.8 provides @mkdir_p@.
@@ -108,7 +108,7 @@
install-data-yes: all
linguas="$(USE_LINGUAS)"; \
for lang in $$linguas; do \
- dir=$(DESTDIR)$(itlocaledir)/$$lang/LC_MESSAGES; \
+ dir=$(DESTDIR)$(localedir)/$$lang/LC_MESSAGES; \
$(mkdir_p) $$dir; \
if test -r $$lang.gmo; then \
$(INSTALL_DATA) $$lang.gmo $$dir/$(GETTEXT_PACKAGE).mo; \
@@ -142,8 +142,8 @@
uninstall:
linguas="$(USE_LINGUAS)"; \
for lang in $$linguas; do \
- rm -f $(DESTDIR)$(itlocaledir)/$$lang/LC_MESSAGES/$(GETTEXT_PACKAGE).mo; \
- rm -f $(DESTDIR)$(itlocaledir)/$$lang/LC_MESSAGES/$(GETTEXT_PACKAGE).mo.m; \
+ rm -f $(DESTDIR)$(localedir)/$$lang/LC_MESSAGES/$(GETTEXT_PACKAGE).mo; \
+ rm -f $(DESTDIR)$(localedir)/$$lang/LC_MESSAGES/$(GETTEXT_PACKAGE).mo.m; \
done
check: all $(GETTEXT_PACKAGE).pot

View file

@ -0,0 +1,26 @@
--- ./uget-gtk/UgApp-gtk-callback.c.orig 2014-07-12 12:08:24.000000000 +0000
+++ ./uget-gtk/UgApp-gtk-callback.c 2014-07-12 12:08:40.000000000 +0000
@@ -1334,10 +1334,12 @@
ug_launch_uri ("http://ugetdm.com/reportbug");
}
+/*
void on_check_updates (GtkWidget* widget, UgAppGtk* app)
{
ug_launch_uri ("http://ugetdm.com/versioncheck?v=" PACKAGE_VERSION);
}
+*/
void on_about (GtkWidget* widget, UgAppGtk* app)
{
@@ -2008,8 +2010,10 @@
G_CALLBACK (on_support_forum), app);
g_signal_connect (menubar->help.submit_feedback, "activate",
G_CALLBACK (on_submit_feedback), app);
+ /*
g_signal_connect (menubar->help.check_updates, "activate",
G_CALLBACK (on_check_updates), app);
+ */
g_signal_connect (menubar->help.report_bug, "activate",
G_CALLBACK (on_report_bug), app);
g_signal_connect (menubar->help.about_uget, "activate",

View file

@ -0,0 +1,17 @@
--- ./uget-gtk/UgApp-gtk-gui.c.orig 2014-07-12 12:11:05.000000000 +0000
+++ ./uget-gtk/UgApp-gtk-gui.c 2014-07-12 12:12:47.000000000 +0000
@@ -860,12 +860,14 @@
gtk_menu_shell_append ((GtkMenuShell*)menu, menu_item);
menubar->help.report_bug = menu_item;
+ /*
// Check for Updates
menu_item = gtk_image_menu_item_new_with_mnemonic(_("Check for Updates"));
// image = gtk_image_new_from_stock (GTK_STOCK_DND_MULTIPLE, GTK_ICON_SIZE_MENU);
// gtk_image_menu_item_set_image ((GtkImageMenuItem*)menu_item, image);
gtk_menu_shell_append ((GtkMenuShell*)menu, menu_item);
menubar->help.check_updates = menu_item;
+ */
// About Uget
menu_item = gtk_image_menu_item_new_from_stock (GTK_STOCK_ABOUT, NULL);

View file

@ -0,0 +1,11 @@
--- ./uget-gtk/UgSetting.c.orig 2014-01-01 09:39:00.000000000 +0000
+++ ./uget-gtk/UgSetting.c 2014-07-12 11:51:49.000000000 +0000
@@ -457,7 +457,7 @@
setting->window.statusbar = TRUE;
setting->window.category = TRUE;
setting->window.summary = TRUE;
- setting->window.banner = TRUE;
+ setting->window.banner = FALSE;
setting->window.x = 0;
setting->window.y = 0;
setting->window.width = 0;

13
net/uget/pkg-descr Normal file
View file

@ -0,0 +1,13 @@
uGet is a very powerful download manager application, with large inventory
of features but is still very light-weight and low on resources.
General features:
- Downloads queue
- Resume downloads
- Advanced download categories
- Clipboard monitor
- Batch downloads
- Multi-protocol
- Scheduler
WWW: http://ugetdm.com/

55
net/uget/pkg-plist Normal file
View file

@ -0,0 +1,55 @@
bin/uget-cmd
bin/uget-gtk
share/applications/uget-gtk.desktop
share/icons/hicolor/128x128/apps/uget-icon.png
share/icons/hicolor/16x16/apps/uget-icon.png
share/icons/hicolor/16x16/apps/uget-tray-default.png
share/icons/hicolor/16x16/apps/uget-tray-downloading.png
share/icons/hicolor/16x16/apps/uget-tray-error.png
share/icons/hicolor/22x22/apps/uget-icon.png
share/icons/hicolor/22x22/apps/uget-tray-default.png
share/icons/hicolor/22x22/apps/uget-tray-downloading.png
share/icons/hicolor/22x22/apps/uget-tray-error.png
share/icons/hicolor/24x24/apps/uget-icon.png
share/icons/hicolor/24x24/apps/uget-tray-default.png
share/icons/hicolor/24x24/apps/uget-tray-downloading.png
share/icons/hicolor/24x24/apps/uget-tray-error.png
share/icons/hicolor/32x32/apps/uget-icon.png
share/icons/hicolor/32x32/apps/uget-tray-default.png
share/icons/hicolor/32x32/apps/uget-tray-downloading.png
share/icons/hicolor/32x32/apps/uget-tray-error.png
share/icons/hicolor/48x48/apps/uget-icon.png
share/icons/hicolor/48x48/apps/uget-tray-default.png
share/icons/hicolor/48x48/apps/uget-tray-downloading.png
share/icons/hicolor/48x48/apps/uget-tray-error.png
share/icons/hicolor/64x64/apps/uget-icon.png
share/icons/hicolor/96x96/apps/uget-icon.png
share/icons/hicolor/scalable/apps/uget-icon.svg
%%NLS%%share/locale/ar/LC_MESSAGES/uget.mo
%%NLS%%share/locale/be/LC_MESSAGES/uget.mo
%%NLS%%share/locale/bn_BD/LC_MESSAGES/uget.mo
%%NLS%%share/locale/cs/LC_MESSAGES/uget.mo
%%NLS%%share/locale/da/LC_MESSAGES/uget.mo
%%NLS%%share/locale/de/LC_MESSAGES/uget.mo
%%NLS%%share/locale/es/LC_MESSAGES/uget.mo
%%NLS%%share/locale/fr/LC_MESSAGES/uget.mo
%%NLS%%share/locale/hu/LC_MESSAGES/uget.mo
%%NLS%%share/locale/id/LC_MESSAGES/uget.mo
%%NLS%%share/locale/it/LC_MESSAGES/uget.mo
%%NLS%%share/locale/ka_GE/LC_MESSAGES/uget.mo
%%NLS%%share/locale/pl/LC_MESSAGES/uget.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/uget.mo
%%NLS%%share/locale/ru/LC_MESSAGES/uget.mo
%%NLS%%share/locale/tr/LC_MESSAGES/uget.mo
%%NLS%%share/locale/uk/LC_MESSAGES/uget.mo
%%NLS%%share/locale/vi/LC_MESSAGES/uget.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/uget.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/uget.mo
share/pixmaps/uget/logo.png
share/sounds/uget/notification.wav
%%NLS%%@dirrmtry share/locale/bn_BD/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/bn_BD
%%NLS%%@dirrmtry share/locale/ka_GE/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/ka_GE
@dirrm share/pixmaps/uget
@dirrm share/sounds/uget