mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
math/sleef: upgrade to 3.8
Releases notes at https://github.com/shibatch/sleef/releases
This commit is contained in:
parent
44df4075d3
commit
6093f5d5f6
6 changed files with 15 additions and 68 deletions
|
@ -1,6 +1,5 @@
|
|||
PORTNAME= sleef
|
||||
DISTVERSION= 3.5.1-62
|
||||
DISTVERSIONSUFFIX= -g85440a5
|
||||
DISTVERSION= 3.8
|
||||
CATEGORIES= math
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
|
@ -10,14 +9,19 @@ WWW= https://sleef.org
|
|||
LICENSE= BSL
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
|
||||
|
||||
USES= cmake:testing compiler:c11 pathfix
|
||||
LIB_DEPENDS= libgmp.so:math/gmp \
|
||||
libmpfr.so:math/mpfr \
|
||||
libfftw3.so:math/fftw3
|
||||
|
||||
USES= cmake:testing compiler:c11 pathfix ssl
|
||||
CMAKE_ARGS= -DSLEEF_BUILD_SHARED_LIBS:BOOL=ON
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= shibatch
|
||||
|
||||
CMAKE_OFF= BUILD_TESTS
|
||||
CMAKE_TESTING_ON= BUILD_TESTS
|
||||
CMAKE_OFF= SLEEF_BUILD_TESTS
|
||||
CMAKE_TESTING_ON= SLEEF_BUILD_TESTS
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1664661522
|
||||
SHA256 (shibatch-sleef-3.5.1-62-g85440a5_GH0.tar.gz) = 6544ea223bdf6f5d7bfc58afb55942066125f5325b535dd0cb136248ece53c43
|
||||
SIZE (shibatch-sleef-3.5.1-62-g85440a5_GH0.tar.gz) = 1659120
|
||||
TIMESTAMP = 1739116908
|
||||
SHA256 (shibatch-sleef-3.8_GH0.tar.gz) = a12ccd50f57083c530e1c76f10d52865defbd19fc9e2c85b483493065709874a
|
||||
SIZE (shibatch-sleef-3.8_GH0.tar.gz) = 1863935
|
||||
|
|
|
@ -1,35 +0,0 @@
|
|||
--- src/libm-tester/testerutil.c.orig 2021-04-05 11:53:56 UTC
|
||||
+++ src/libm-tester/testerutil.c
|
||||
@@ -289,32 +289,6 @@ double countULP2sp(float d, mpfr_t c0) {
|
||||
|
||||
//
|
||||
|
||||
-void mpfr_sinpi(mpfr_t ret, mpfr_t arg, mpfr_rnd_t rnd) {
|
||||
- mpfr_t frpi, frd;
|
||||
- mpfr_inits(frpi, frd, NULL);
|
||||
-
|
||||
- mpfr_const_pi(frpi, GMP_RNDN);
|
||||
- mpfr_set_d(frd, 1.0, GMP_RNDN);
|
||||
- mpfr_mul(frpi, frpi, frd, GMP_RNDN);
|
||||
- mpfr_mul(frd, frpi, arg, GMP_RNDN);
|
||||
- mpfr_sin(ret, frd, GMP_RNDN);
|
||||
-
|
||||
- mpfr_clears(frpi, frd, NULL);
|
||||
-}
|
||||
-
|
||||
-void mpfr_cospi(mpfr_t ret, mpfr_t arg, mpfr_rnd_t rnd) {
|
||||
- mpfr_t frpi, frd;
|
||||
- mpfr_inits(frpi, frd, NULL);
|
||||
-
|
||||
- mpfr_const_pi(frpi, GMP_RNDN);
|
||||
- mpfr_set_d(frd, 1.0, GMP_RNDN);
|
||||
- mpfr_mul(frpi, frpi, frd, GMP_RNDN);
|
||||
- mpfr_mul(frd, frpi, arg, GMP_RNDN);
|
||||
- mpfr_cos(ret, frd, GMP_RNDN);
|
||||
-
|
||||
- mpfr_clears(frpi, frd, NULL);
|
||||
-}
|
||||
-
|
||||
void mpfr_lgamma_nosign(mpfr_t ret, mpfr_t arg, mpfr_rnd_t rnd) {
|
||||
int s;
|
||||
mpfr_lgamma(ret, &s, arg, rnd);
|
|
@ -1,10 +0,0 @@
|
|||
--- src/libm-tester/testerutil.h.orig 2021-04-05 11:53:56 UTC
|
||||
+++ src/libm-tester/testerutil.h
|
||||
@@ -90,7 +90,5 @@ int cmpDenormsp(float x, mpfr_t fry);
|
||||
double countULPsp(float d, mpfr_t c);
|
||||
double countULP2sp(float d, mpfr_t c);
|
||||
|
||||
-void mpfr_sinpi(mpfr_t ret, mpfr_t arg, mpfr_rnd_t rnd);
|
||||
-void mpfr_cospi(mpfr_t ret, mpfr_t arg, mpfr_rnd_t rnd);
|
||||
void mpfr_lgamma_nosign(mpfr_t ret, mpfr_t arg, mpfr_rnd_t rnd);
|
||||
#endif
|
|
@ -1,13 +0,0 @@
|
|||
--- src/libm/tryvsx3.c.orig 2023-05-12 23:04:06 UTC
|
||||
+++ src/libm/tryvsx3.c
|
||||
@@ -1,8 +1,8 @@
|
||||
#include <altivec.h>
|
||||
|
||||
__vector double sleef_cpuidtmp0;
|
||||
-__vector unsigned long long sleef_cpuidtmp1, sleef_cpuidtmp2;
|
||||
+__vector unsigned long long sleef_cpuidtmp1, sleef_cpuidtmp3;
|
||||
|
||||
void sleef_tryVSX3() {
|
||||
- sleef_cpuidtmp0 = vec_insert_exp(sleef_cpuidtmp1, sleef_cpuidtmp2);
|
||||
+ sleef_cpuidtmp0 = vec_insert_exp(sleef_cpuidtmp1, sleef_cpuidtmp3);
|
||||
}
|
|
@ -5,7 +5,8 @@ lib/cmake/sleef/sleefTargets-%%CMAKE_BUILD_TYPE%%.cmake
|
|||
lib/cmake/sleef/sleefTargets.cmake
|
||||
lib/libsleef.so
|
||||
lib/libsleef.so.3
|
||||
lib/libsleef.so.3.6.0
|
||||
lib/libsleef.so.3.8.0
|
||||
libdata/pkgconfig/sleef.pc
|
||||
%%GNUABI%%lib/libsleefgnuabi.so
|
||||
%%GNUABI%%lib/libsleefgnuabi.so.3
|
||||
%%GNUABI%%lib/libsleefgnuabi.so.3.6
|
||||
%%GNUABI%%lib/libsleefgnuabi.so.3.8
|
||||
|
|
Loading…
Add table
Reference in a new issue