archivers/py-blosc: Add py-blosc 1.11.2

Blosc is a high performance compressor optimized for binary data. It has been
designed to transmit data to the processor cache faster than the traditional,
non-compressed, direct memory fetch approach via a memcpy() OS call.

Blosc works well for compressing numerical arrays that contains data with
relatively low entropy, like sparse data, time series, grids with regular-spaced
values, etc.

python-blosc a Python package that wraps Blosc.
This commit is contained in:
Po-Chuan Hsieh 2024-11-03 21:20:40 +08:00
parent 1ab7cc7fb4
commit 5f1575b6a0
No known key found for this signature in database
GPG key ID: 9A4BD10F002DD04B
5 changed files with 52 additions and 0 deletions

View file

@ -184,6 +184,7 @@
SUBDIR += ppunpack
SUBDIR += py-acefile
SUBDIR += py-bitshuffle
SUBDIR += py-blosc
SUBDIR += py-blosc2
SUBDIR += py-borgbackup
SUBDIR += py-borgbackup12

View file

@ -0,0 +1,33 @@
PORTNAME= blosc
PORTVERSION= 1.11.2
CATEGORIES= archivers python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Blosc data compressor
WWW= https://www.blosc.org/python-blosc/python-blosc.html \
https://github.com/Blosc/python-blosc
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}py-cpuinfo>=0:sysutils/py-py-cpuinfo@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scikit-build>=0:devel/py-scikit-build@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
LIB_DEPENDS= libblosc.so:archivers/c-blosc
USES= cmake:indirect python
USE_PYTHON= autoplist concurrent pep517
MAKE_ENV= USE_SYSTEM_BLOSC=1
post-patch:
# Clean up bundled libraries
@${RM} -r ${WRKSRC}/blosc/c-blosc/
post-install:
${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR} -name '*.so' -exec ${STRIP_CMD} {} +
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
TIMESTAMP = 1730540888
SHA256 (blosc-1.11.2.tar.gz) = ac5e7c1bfc1c7232b900be94cddb5ffcf9ea49f313c8ae98a7ca0dd87b872bf4
SIZE (blosc-1.11.2.tar.gz) = 1434010

View file

@ -0,0 +1,6 @@
--- pyproject.toml.orig 2024-06-24 16:59:37 UTC
+++ pyproject.toml
@@ -1,2 +1,2 @@
[build-system]
-requires = ["setuptools", "scikit-build", "cmake", "ninja", "py-cpuinfo"]
+requires = ["setuptools", "scikit-build", "py-cpuinfo"]

View file

@ -0,0 +1,9 @@
Blosc is a high performance compressor optimized for binary data. It has been
designed to transmit data to the processor cache faster than the traditional,
non-compressed, direct memory fetch approach via a memcpy() OS call.
Blosc works well for compressing numerical arrays that contains data with
relatively low entropy, like sparse data, time series, grids with regular-spaced
values, etc.
python-blosc a Python package that wraps Blosc.