mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
comms/scrcpy: update to 3.2
Changelog: https://github.com/Genymobile/scrcpy/releases/tag/v3.2 Reported by: GitHub (watch releases)
This commit is contained in:
parent
a2e8ce4b6b
commit
5d15ec21a7
6 changed files with 24 additions and 24 deletions
|
@ -1,6 +1,6 @@
|
|||
PORTNAME= scrcpy
|
||||
DISTVERSIONPREFIX= v
|
||||
DISTVERSION= 3.1
|
||||
DISTVERSION= 3.2
|
||||
CATEGORIES= comms net
|
||||
MASTER_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/releases/download/${DISTVERSIONFULL}/:server
|
||||
DISTFILES= ${SERVER_FILE}:server
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
TIMESTAMP = 1735040933
|
||||
SHA256 (scrcpy-server-v3.1) = 958f0944a62f23b1f33a16e9eb14844c1a04b882ca175a738c16d23cb22b86c0
|
||||
SIZE (scrcpy-server-v3.1) = 90640
|
||||
SHA256 (Genymobile-scrcpy-v3.1_GH0.tar.gz) = beaa5050a3c45faa77cedc70ad13d88ef26b74d29d52f512b7708671e037d24d
|
||||
SIZE (Genymobile-scrcpy-v3.1_GH0.tar.gz) = 459749
|
||||
TIMESTAMP = 1745113327
|
||||
SHA256 (scrcpy-server-v3.2) = b920e0ea01936bf2482f4ba2fa985c22c13c621999e3d33b45baa5acfc1ea3d0
|
||||
SIZE (scrcpy-server-v3.2) = 90888
|
||||
SHA256 (Genymobile-scrcpy-v3.2_GH0.tar.gz) = 9902a3afd75f9a5da64898ac06ffaf77065dd713a58f47a408630b98f03ba9ce
|
||||
SIZE (Genymobile-scrcpy-v3.2_GH0.tar.gz) = 464967
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
--- app/meson.build.orig 2024-12-04 21:48:27 UTC
|
||||
--- app/meson.build.orig 2025-03-29 15:15:14 UTC
|
||||
+++ app/meson.build
|
||||
@@ -67,8 +67,8 @@ conf = configuration_data()
|
||||
|
||||
|
@ -13,9 +13,9 @@
|
|||
if host_machine.system() == 'windows'
|
||||
@@ -196,10 +196,10 @@ install_data('data/bash-completion/scrcpy',
|
||||
install_data('data/zsh-completion/_scrcpy',
|
||||
install_dir: join_paths(datadir, 'zsh/site-functions'))
|
||||
install_dir: datadir / 'zsh/site-functions')
|
||||
install_data('data/bash-completion/scrcpy',
|
||||
- install_dir: join_paths(datadir, 'bash-completion/completions'))
|
||||
- install_dir: datadir / 'bash-completion/completions')
|
||||
+ install_dir: 'etc/bash_completion.d')
|
||||
|
||||
# Desktop entry file for application launchers
|
||||
|
@ -23,4 +23,4 @@
|
|||
+if host_machine.system() == 'linux' or host_machine.system() == 'freebsd'
|
||||
# Install a launcher (ex: /usr/local/share/applications/scrcpy.desktop)
|
||||
install_data('data/scrcpy.desktop',
|
||||
install_dir: join_paths(datadir, 'applications'))
|
||||
install_dir: datadir / 'applications')
|
||||
|
|
11
comms/scrcpy/files/patch-app_src_usb_aoa__hid.c
Normal file
11
comms/scrcpy/files/patch-app_src_usb_aoa__hid.c
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- app/src/usb/aoa_hid.c.orig 2025-04-20 01:48:34 UTC
|
||||
+++ app/src/usb/aoa_hid.c
|
||||
@@ -5,7 +5,7 @@
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
#include <sys/types.h>
|
||||
-#include <libusb-1.0/libusb.h>
|
||||
+#include <libusb.h>
|
||||
|
||||
#include "events.h"
|
||||
#include "util/log.h"
|
|
@ -1,11 +0,0 @@
|
|||
--- app/src/usb/aoa_hid.h.orig 2024-12-04 21:48:27 UTC
|
||||
+++ app/src/usb/aoa_hid.h
|
||||
@@ -6,7 +6,7 @@
|
||||
#include <stdint.h>
|
||||
#include <stdbool.h>
|
||||
|
||||
-#include <libusb-1.0/libusb.h>
|
||||
+#include <libusb.h>
|
||||
|
||||
#include "hid/hid_event.h"
|
||||
#include "usb.h"
|
|
@ -1,11 +1,11 @@
|
|||
--- app/src/version.c.orig 2022-06-30 04:29:39 UTC
|
||||
--- app/src/version.c.orig 2025-03-29 15:15:14 UTC
|
||||
+++ app/src/version.c
|
||||
@@ -7,7 +7,7 @@
|
||||
@@ -8,7 +8,7 @@
|
||||
# include <libavdevice/avdevice.h>
|
||||
#endif
|
||||
#ifdef HAVE_USB
|
||||
-# include <libusb-1.0/libusb.h>
|
||||
+# include <libusb.h>
|
||||
#endif
|
||||
#include <SDL2/SDL_version.h>
|
||||
|
||||
void
|
||||
|
|
Loading…
Add table
Reference in a new issue