mirror of
https://git.freebsd.org/ports.git
synced 2025-05-22 03:45:17 -04:00
- Update to 1.4.4.
- Add an option to build with SASL support. - Unbreak on 8.x. [1] Bugs are mine. PR: ports/141857 [1] Submitted by: amdmi3 [1] Ok'ed by: mnag
This commit is contained in:
parent
a14855c912
commit
5b23b0e92d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=246413
3 changed files with 19 additions and 17 deletions
|
@ -6,7 +6,7 @@
|
|||
#
|
||||
|
||||
PORTNAME= memcached
|
||||
PORTVERSION= 1.4.1
|
||||
PORTVERSION= 1.4.4
|
||||
CATEGORIES= databases
|
||||
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
|
||||
${MASTER_SITE_GENTOO}
|
||||
|
@ -21,19 +21,20 @@ USE_RC_SUBR= memcached
|
|||
GNU_CONFIGURE= YES
|
||||
CONFIGURE_ARGS= --with-libevent=${LOCALBASE} --program-prefix=
|
||||
|
||||
OPTIONS= REPCACHED "Enable data replication feature" off
|
||||
OPTIONS= REPCACHED "Enable data replication feature" off \
|
||||
SASL "Enable SASL support" off
|
||||
|
||||
MAN1= memcached.1
|
||||
|
||||
PLIST_FILES= bin/memcached \
|
||||
bin/memcached-tool
|
||||
|
||||
PORTDOCS= memory_management.txt protocol.txt
|
||||
PORTDOCS= protocol.txt threads.txt readme.txt
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} >= 800000
|
||||
BROKEN= does not link
|
||||
CFLAGS+= -fstack-protector
|
||||
.endif
|
||||
|
||||
.if defined(WITH_REPCACHED)
|
||||
|
@ -45,6 +46,17 @@ PATCHFILES+= repcached-2.2-${PORTVERSION}.patch.gz
|
|||
CONFIGURE_ARGS+= --enable-replication --disable-threads
|
||||
.endif
|
||||
|
||||
.if defined(WITH_SASL) && !defined(WITHOUT_SASL)
|
||||
LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
|
||||
CONFIGURE_ARGS+= --enable-sasl
|
||||
CFLAGS+= -I${LOCALBASE}/include
|
||||
CPPFLAGS= ${CFLAGS}
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
|
||||
.else
|
||||
CONFIGURE_ARGS+= --disable-sasl
|
||||
.endif
|
||||
|
||||
post-configure:
|
||||
@${REINPLACE_CMD} -e 's#doc/memcached.1##' ${WRKSRC}/Makefile
|
||||
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
MD5 (memcached-1.4.1.tar.gz) = fb1b7e9fcf47b95c5ad3bbeb76342088
|
||||
SHA256 (memcached-1.4.1.tar.gz) = 6bb6e52290bbe987990e83d57856f762402c9a625e9c4f8da785dc7f53acbd83
|
||||
SIZE (memcached-1.4.1.tar.gz) = 277221
|
||||
MD5 (memcached-1.4.4.tar.gz) = 5ca5b24de347e97ac1f48f3785b4178a
|
||||
SHA256 (memcached-1.4.4.tar.gz) = 6bbca41460ded17c6d56c76d96309cd3dee518603fa093938e252262935f8bac
|
||||
SIZE (memcached-1.4.4.tar.gz) = 297920
|
||||
|
|
|
@ -1,10 +0,0 @@
|
|||
--- thread.c.orig 2009-01-27 00:34:19.000000000 -0200
|
||||
+++ thread.c 2009-01-27 00:34:04.000000000 -0200
|
||||
@@ -644,6 +644,7 @@
|
||||
perror("Can't allocate thread descriptors");
|
||||
exit(1);
|
||||
}
|
||||
+ memset(threads, 0, sizeof(LIBEVENT_THREAD) * nthreads);
|
||||
|
||||
threads[0].base = main_base;
|
||||
threads[0].thread_id = pthread_self();
|
Loading…
Add table
Reference in a new issue