- net/pacemaker: Update from 1.1.14 to 1.1.16

- Fix shebangs
- Changelog: https://github.com/ClusterLabs/pacemaker/blob/master/ChangeLog

PR:		219544
Submitted by:	David Shane Holden (maintainer)
Approved by:	miwi (mentor)
Differential Revision:	https://reviews.freebsd.org/D11109
This commit is contained in:
Jochen Neumeister 2017-06-13 14:32:23 +00:00
parent a13423f942
commit 55bb86bc79
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=443502
11 changed files with 137 additions and 270 deletions

View file

@ -2,9 +2,8 @@
# $FreeBSD$ # $FreeBSD$
PORTNAME= pacemaker PORTNAME= pacemaker
PORTVERSION= 1.1.14 PORTVERSION= 1.1.16
DISTVERSIONPREFIX= Pacemaker- DISTVERSIONPREFIX= Pacemaker-
PORTREVISION= 2
CATEGORIES= net CATEGORIES= net
MAINTAINER= dpejesh@yahoo.com MAINTAINER= dpejesh@yahoo.com
@ -13,7 +12,8 @@ COMMENT= Scalable High-Availability cluster resource manager
LICENSE= GPLv2 LICENSE= GPLv2
BUILD_DEPENDS= bash:shells/bash \ BUILD_DEPENDS= bash:shells/bash \
corosync:net/corosync corosync:net/corosync \
getopt>=0:misc/getopt
LIB_DEPENDS= libgnutls.so:security/gnutls \ LIB_DEPENDS= libgnutls.so:security/gnutls \
libltdl.so:devel/libltdl \ libltdl.so:devel/libltdl \
libqb.so:devel/libqb \ libqb.so:devel/libqb \
@ -21,7 +21,9 @@ LIB_DEPENDS= libgnutls.so:security/gnutls \
libxml2.so:textproc/libxml2 \ libxml2.so:textproc/libxml2 \
libxslt.so:textproc/libxslt libxslt.so:textproc/libxslt
RUN_DEPENDS= bash:shells/bash \ RUN_DEPENDS= bash:shells/bash \
corosync:net/corosync corosync:net/corosync \
getopt>=0:misc/getopt \
ocf-tester:net-mgmt/resource-agents
BROKEN_armv6= fails to install: help2man: can't get '--help' info from pacemakerd BROKEN_armv6= fails to install: help2man: can't get '--help' info from pacemakerd
BROKEN_powerpc64= fails to build BROKEN_powerpc64= fails to build
@ -35,27 +37,36 @@ USE_GITHUB= yes
GH_ACCOUNT= ClusterLabs GH_ACCOUNT= ClusterLabs
USES= autoreconf gmake libtool pathfix pkgconfig python shebangfix USES= autoreconf gmake libtool pathfix pkgconfig python shebangfix
USE_GCC= yes
USE_GNOME= glib20 USE_GNOME= glib20
USE_LDCONFIG= yes USE_LDCONFIG= yes
USE_RC_SUBR= ${PORTNAME} USE_RC_SUBR= ${PORTNAME}
GNU_CONFIGURE= yes GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-fatal-warnings \ CONFIGURE_ARGS= --disable-fatal-warnings \
--disable-hardening \
--with-corosync \ --with-corosync \
--without-heartbeat --without-heartbeat
INSTALL_TARGET= install-strip INSTALL_TARGET= install-strip
PATHFIX_MAKEFILEIN= Makefile.am
SHEBANG_LANG= sh SHEBANG_LANG= sh
sh_OLD_CMD= ${SH} sh_OLD_CMD= ${SH}
sh_CMD= ${LOCALBASE}/bin/bash sh_CMD= ${LOCALBASE}/bin/bash
SHEBANG_FILES= extra/resources/* \ SHEBANG_FILES= BasicSanity.sh \
coverage.sh.in \
cts/CTSlab.py \
cts/cts \
cts/lxc_autogen.sh.in \
extra/resources/* \
fencing/* \ fencing/* \
lrmd/* \ lrmd/* \
mcp/* \ mcp/* \
pengine/regression.sh \
tools/* \ tools/* \
xml/* xml/*
REPLACE_ARGS= -e 's,/usr/lib/ocf,${PREFIX}/etc/ocf,' REPLACE_ARGS_OCF= -e 's,/usr/lib/ocf,${PREFIX}/lib/ocf,'
REPLACE_ARGS_GETOPT= -e 's,getopt,${LOCALBASE}/bin/getopt,'
OPTIONS_DEFINE= DBUS DOCS MANPAGES SNMP OPTIONS_DEFINE= DBUS DOCS MANPAGES SNMP
OPTIONS_DEFAULT=MANPAGES OPTIONS_DEFAULT=MANPAGES
@ -74,10 +85,10 @@ SNMP_LIB_DEPENDS= libnetsnmp.so:net-mgmt/net-snmp
SNMP_CONFIGURE_WITH= snmp SNMP_CONFIGURE_WITH= snmp
post-patch: post-patch:
@${REINPLACE_CMD} ${REPLACE_ARGS} ${WRKSRC}/configure.ac @${REINPLACE_CMD} ${REPLACE_ARGS_OCF} ${WRKSRC}/configure.ac
@${REINPLACE_CMD} ${REPLACE_ARGS_GETOPT} ${WRKSRC}/tools/crm_failcount
post-install: @${REINPLACE_CMD} ${REPLACE_ARGS_GETOPT} ${WRKSRC}/tools/crm_master
${RM} ${STAGEDIR}${PREFIX}/etc/rc.d/pacemaker @${REINPLACE_CMD} ${REPLACE_ARGS_GETOPT} ${WRKSRC}/tools/crm_report.in
${RM} ${STAGEDIR}${PREFIX}/etc/rc.d/pacemaker_remote @${REINPLACE_CMD} ${REPLACE_ARGS_GETOPT} ${WRKSRC}/tools/crm_standby
.include <bsd.port.mk> .include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1464782071 TIMESTAMP = 1495733591
SHA256 (ClusterLabs-pacemaker-Pacemaker-1.1.14_GH0.tar.gz) = 2f73043a5de5e66a47462d37cd68c4c6861f71a03c0ea02eb4ae2b1a550cd7b0 SHA256 (ClusterLabs-pacemaker-Pacemaker-1.1.16_GH0.tar.gz) = 6b4b5c3f8571f57e46246a09c59b2ecbf59591b610bb3c9515e9ca84c834c75a
SIZE (ClusterLabs-pacemaker-Pacemaker-1.1.14_GH0.tar.gz) = 4729808 SIZE (ClusterLabs-pacemaker-Pacemaker-1.1.16_GH0.tar.gz) = 4897770

View file

@ -1,11 +0,0 @@
--- Makefile.common.orig 2016-01-14 21:43:08 UTC
+++ Makefile.common
@@ -38,8 +38,6 @@ endif
%.8: % $(MAN8DEPS)
chmod a+x $(abs_builddir)/$<
- $(PCMK_V) PATH=$(abs_builddir):$$PATH $(abs_builddir)/$< --help
- $(PCMK_V) PATH=$(abs_builddir):$$PATH $(abs_builddir)/$< --version
$(AM_V_MAN)PATH=$(abs_builddir):$$PATH $(HELP2MAN) --output $@ --no-info --section 8 --name "Part of the Pacemaker cluster resource manager" $(abs_builddir)/$<
%.xml: %

View file

@ -2,14 +2,14 @@ On FreeBSD the maximum IPC buffer size is defined by the kern.ipc.maxsockbuf
sysctl which defaults to 2M. This patch simply lowers the max message size sysctl which defaults to 2M. This patch simply lowers the max message size
in pengine from 5M to 1M to work out of the box without requiring any tuning. in pengine from 5M to 1M to work out of the box without requiring any tuning.
--- crmd/pengine.c.orig 2016-01-14 21:43:08 UTC --- crmd/pengine.c.orig 2016-11-30 19:51:58 UTC
+++ crmd/pengine.c +++ crmd/pengine.c
@@ -163,7 +163,7 @@ do_pe_control(long long action, @@ -165,7 +165,7 @@ do_pe_control(long long action,
pe_subsystem->source = pe_subsystem->source =
mainloop_add_ipc_client(CRM_SYSTEM_PENGINE, G_PRIORITY_DEFAULT, mainloop_add_ipc_client(CRM_SYSTEM_PENGINE, G_PRIORITY_DEFAULT,
- 5 * 1024 * 1024 /* 5Mb */ , NULL, &pe_callbacks); - 5 * 1024 * 1024 /* 5MB */ , NULL, &pe_callbacks);
+ 1024 * 1024 /* 1Mb */ , NULL, &pe_callbacks); + 1024 * 1024 /* 1MB */ , NULL, &pe_callbacks);
if (pe_subsystem->source == NULL) { if (pe_subsystem->source == NULL) {
crm_warn("Setup of client connection failed, not adding channel to mainloop"); crm_warn("Setup of client connection failed, not adding channel to mainloop");

View file

@ -1,11 +0,0 @@
--- crmd/throttle.c.orig 2016-01-14 21:43:08 UTC
+++ crmd/throttle.c
@@ -389,7 +389,7 @@ throttle_mode(void)
unsigned int blocked = 0;
enum throttle_state_e mode = throttle_none;
-#ifdef ON_SOLARIS
+#if defined(ON_BSD) || defined(ON_SOLARIS)
return throttle_none;
#endif

View file

@ -1,10 +0,0 @@
--- extra/resources/ping.orig 2016-03-21 16:27:02 UTC
+++ extra/resources/ping
@@ -262,6 +262,7 @@ ping_check() {
case `uname` in
Linux) p_args="-n -q -W $OCF_RESKEY_timeout -c $OCF_RESKEY_attempts";;
Darwin) p_args="-n -q -t $OCF_RESKEY_timeout -c $OCF_RESKEY_attempts -o";;
+ FreeBSD) p_args="-n -q -t $OCF_RESKEY_timeout -c $OCF_RESKEY_attempts -o";;
*) ocf_log err "Unknown host type: `uname`"; exit $OCF_ERR_INSTALLED;;
esac

View file

@ -1,12 +0,0 @@
--- lib/common/utils.c.orig 2016-01-14 21:43:08 UTC
+++ lib/common/utils.c
@@ -2270,7 +2270,8 @@ find_library_function(void **handle, con
}
a_function = dlsym(*handle, fn);
- if ((error = dlerror()) != NULL) {
+ if (a_function == NULL) {
+ error = dlerror();
crm_err("%sCould not find %s in %s: %s", fatal ? "Fatal: " : "", fn, lib, error);
if (fatal) {
crm_exit(DAEMON_RESPAWN_STOP);

View file

@ -1,180 +0,0 @@
--- lib/services/services_linux.c.orig 2016-01-14 21:43:08 UTC
+++ lib/services/services_linux.c
@@ -457,13 +457,19 @@ action_launch_child(svc_action_t *op)
_exit(op->rc);
}
+#ifndef HAVE_SYS_SIGNALFD_H
+static int sigchld_pipe[2];
+
static void
-action_synced_wait(svc_action_t * op, sigset_t mask)
+sigchld_handler()
{
+ write(sigchld_pipe[1], "", 1);
+}
+#endif
-#ifndef HAVE_SYS_SIGNALFD_H
- CRM_ASSERT(FALSE);
-#else
+static void
+action_synced_wait(svc_action_t * op, sigset_t *mask)
+{
int status = 0;
int timeout = op->timeout;
int sfd = -1;
@@ -471,10 +477,14 @@ action_synced_wait(svc_action_t * op, si
struct pollfd fds[3];
int wait_rc = 0;
- sfd = signalfd(-1, &mask, SFD_NONBLOCK);
+#ifdef HAVE_SYS_SIGNALFD_H
+ sfd = signalfd(-1, mask, SFD_NONBLOCK);
if (sfd < 0) {
crm_perror(LOG_ERR, "signalfd() failed");
}
+#else
+ sfd = sigchld_pipe[0];
+#endif
fds[0].fd = op->opaque->stdout_fd;
fds[0].events = POLLIN;
@@ -503,6 +513,7 @@ action_synced_wait(svc_action_t * op, si
}
if (fds[2].revents & POLLIN) {
+#ifdef HAVE_SYS_SIGNALFD_H
struct signalfd_siginfo fdsi;
ssize_t s;
@@ -511,6 +522,12 @@ action_synced_wait(svc_action_t * op, si
crm_perror(LOG_ERR, "Read from signal fd %d failed", sfd);
} else if (fdsi.ssi_signo == SIGCHLD) {
+#else
+ if (1) {
+ /* Clear out the sigchld pipe. */
+ char ch;
+ while (read(sfd, &ch, 1) == 1);
+#endif
wait_rc = waitpid(op->pid, &status, WNOHANG);
if (wait_rc < 0){
@@ -583,10 +600,10 @@ action_synced_wait(svc_action_t * op, si
close(op->opaque->stdout_fd);
close(op->opaque->stderr_fd);
- close(sfd);
+#ifdef HAVE_SYS_SIGNALFD_H
+ close(sfd);
#endif
-
}
/* For an asynchronous 'op', returns FALSE if 'op' should be free'd by the caller */
@@ -596,9 +613,30 @@ services_os_action_execute(svc_action_t
{
int stdout_fd[2];
int stderr_fd[2];
+ struct stat st;
+ sigset_t *pmask;
+
+#ifdef HAVE_SYS_SIGNALFD_H
sigset_t mask;
sigset_t old_mask;
- struct stat st;
+#define sigchld_cleanup() { \
+ if (sigismember(&old_mask, SIGCHLD) == 0) { \
+ if (sigprocmask(SIG_UNBLOCK, &mask, NULL) < 0) { \
+ crm_perror(LOG_ERR, "sigprocmask() failed to unblock sigchld"); \
+ } \
+ } \
+}
+#else
+ struct sigaction sa;
+ struct sigaction old_sa;
+#define sigchld_cleanup() { \
+ if (sigaction(SIGCHLD, &old_sa, NULL) < 0) { \
+ crm_perror(LOG_ERR, "sigaction() failed to remove sigchld handler"); \
+ } \
+ close(sigchld_pipe[0]); \
+ close(sigchld_pipe[1]); \
+}
+#endif
if (pipe(stdout_fd) < 0) {
crm_err("pipe() failed");
@@ -620,13 +658,33 @@ services_os_action_execute(svc_action_t
}
if (synchronous) {
+#ifdef HAVE_SYS_SIGNALFD_H
sigemptyset(&mask);
sigaddset(&mask, SIGCHLD);
sigemptyset(&old_mask);
if (sigprocmask(SIG_BLOCK, &mask, &old_mask) < 0) {
- crm_perror(LOG_ERR, "sigprocmask() failed");
+ crm_perror(LOG_ERR, "sigprocmask() failed to block sigchld");
+ }
+
+ pmask = &mask;
+#else
+ if(pipe(sigchld_pipe) == -1) {
+ crm_perror(LOG_ERR, "pipe() failed");
+ }
+
+ set_fd_opts(sigchld_pipe[0], O_NONBLOCK);
+ set_fd_opts(sigchld_pipe[1], O_NONBLOCK);
+
+ sa.sa_handler = sigchld_handler;
+ sa.sa_flags = 0;
+ sigemptyset(&sa.sa_mask);
+ if (sigaction(SIGCHLD, &sa, &old_sa) < 0) {
+ crm_perror(LOG_ERR, "sigaction() failed to set sigchld handler");
}
+
+ pmask = NULL;
+#endif
}
op->pid = fork();
@@ -645,6 +703,8 @@ services_os_action_execute(svc_action_t
if (!synchronous) {
return operation_finalize(op);
}
+
+ sigchld_cleanup();
return FALSE;
}
case 0: /* Child */
@@ -663,6 +723,10 @@ services_os_action_execute(svc_action_t
close(stderr_fd[1]);
}
+ if (synchronous) {
+ sigchld_cleanup();
+ }
+
action_launch_child(op);
}
@@ -677,14 +741,8 @@ services_os_action_execute(svc_action_t
set_fd_opts(op->opaque->stderr_fd, O_NONBLOCK);
if (synchronous) {
- action_synced_wait(op, mask);
-
- if (sigismember(&old_mask, SIGCHLD) == 0) {
- if (sigprocmask(SIG_UNBLOCK, &mask, NULL) < 0) {
- crm_perror(LOG_ERR, "sigprocmask() to unblocked failed");
- }
- }
-
+ action_synced_wait(op, pmask);
+ sigchld_cleanup();
} else {
crm_trace("Async waiting for %d - %s", op->pid, op->opaque->exec);

View file

@ -0,0 +1,11 @@
--- lrmd/Makefile.am.orig 2016-12-05 00:29:14 UTC
+++ lrmd/Makefile.am
@@ -25,8 +25,6 @@ lrmdlib_PROGRAMS += lrmd_test
testdir = $(datadir)/$(PACKAGE)/tests/lrmd
test_SCRIPTS = regression.py
-initdir = $(INITDIR)
-init_SCRIPTS = pacemaker_remote
sbin_PROGRAMS = pacemaker_remoted
if BUILD_SYSTEMD

View file

@ -0,0 +1,11 @@
--- mcp/Makefile.am.orig 2016-04-18 16:07:35 UTC
+++ mcp/Makefile.am
@@ -19,8 +19,6 @@ include $(top_srcdir)/Makefile.common
if BUILD_CS_SUPPORT
-initdir = $(INITDIR)
-init_SCRIPTS = pacemaker
sbin_PROGRAMS = pacemakerd
if BUILD_SYSTEMD

View file

@ -1,17 +1,18 @@
etc/logrotate.d/pacemaker etc/logrotate.d/pacemaker
etc/ocf/resource.d/.isolation/docker-wrapper lib/ocf/resource.d/.isolation/docker-wrapper
etc/ocf/resource.d/pacemaker/ClusterMon lib/ocf/resource.d/pacemaker/ClusterMon
etc/ocf/resource.d/pacemaker/Dummy lib/ocf/resource.d/pacemaker/Dummy
etc/ocf/resource.d/pacemaker/HealthCPU lib/ocf/resource.d/pacemaker/HealthCPU
etc/ocf/resource.d/pacemaker/HealthSMART lib/ocf/resource.d/pacemaker/HealthSMART
etc/ocf/resource.d/pacemaker/Stateful lib/ocf/resource.d/pacemaker/Stateful
etc/ocf/resource.d/pacemaker/SysInfo lib/ocf/resource.d/pacemaker/SysInfo
etc/ocf/resource.d/pacemaker/SystemHealth lib/ocf/resource.d/pacemaker/SystemHealth
etc/ocf/resource.d/pacemaker/controld lib/ocf/resource.d/pacemaker/attribute
etc/ocf/resource.d/pacemaker/o2cb lib/ocf/resource.d/pacemaker/controld
etc/ocf/resource.d/pacemaker/ping lib/ocf/resource.d/pacemaker/o2cb
etc/ocf/resource.d/pacemaker/pingd lib/ocf/resource.d/pacemaker/ping
etc/ocf/resource.d/pacemaker/remote lib/ocf/resource.d/pacemaker/pingd
lib/ocf/resource.d/pacemaker/remote
include/pacemaker/crm/attrd.h include/pacemaker/crm/attrd.h
include/pacemaker/crm/cib.h include/pacemaker/crm/cib.h
include/pacemaker/crm/cib/util.h include/pacemaker/crm/cib/util.h
@ -29,6 +30,7 @@ include/pacemaker/crm/lrmd.h
include/pacemaker/crm/msg_xml.h include/pacemaker/crm/msg_xml.h
include/pacemaker/crm/pengine/common.h include/pacemaker/crm/pengine/common.h
include/pacemaker/crm/pengine/complex.h include/pacemaker/crm/pengine/complex.h
include/pacemaker/crm/pengine/remote.h
include/pacemaker/crm/pengine/rules.h include/pacemaker/crm/pengine/rules.h
include/pacemaker/crm/pengine/status.h include/pacemaker/crm/pengine/status.h
include/pacemaker/crm/services.h include/pacemaker/crm/services.h
@ -38,43 +40,43 @@ include/pacemaker/crm_config.h
lib/libcib.a lib/libcib.a
lib/libcib.so lib/libcib.so
lib/libcib.so.4 lib/libcib.so.4
lib/libcib.so.4.1.0 lib/libcib.so.4.1.2
lib/libcrmcluster.a lib/libcrmcluster.a
lib/libcrmcluster.so lib/libcrmcluster.so
lib/libcrmcluster.so.4 lib/libcrmcluster.so.4
lib/libcrmcluster.so.4.1.0 lib/libcrmcluster.so.4.2.1
lib/libcrmcommon.a lib/libcrmcommon.a
lib/libcrmcommon.so lib/libcrmcommon.so
lib/libcrmcommon.so.3 lib/libcrmcommon.so.3
lib/libcrmcommon.so.3.5.0 lib/libcrmcommon.so.3.6.1
lib/libcrmservice.a lib/libcrmservice.a
lib/libcrmservice.so lib/libcrmservice.so
lib/libcrmservice.so.3 lib/libcrmservice.so.3
lib/libcrmservice.so.3.1.0 lib/libcrmservice.so.3.1.2
lib/liblrmd.a lib/liblrmd.a
lib/liblrmd.so lib/liblrmd.so
lib/liblrmd.so.1 lib/liblrmd.so.1
lib/liblrmd.so.1.2.1 lib/liblrmd.so.1.3.1
lib/libpe_rules.a lib/libpe_rules.a
lib/libpe_rules.so lib/libpe_rules.so
lib/libpe_rules.so.2 lib/libpe_rules.so.2
lib/libpe_rules.so.2.0.5 lib/libpe_rules.so.2.1.0
lib/libpe_status.a lib/libpe_status.a
lib/libpe_status.so lib/libpe_status.so
lib/libpe_status.so.10 lib/libpe_status.so.10
lib/libpe_status.so.10.0.0 lib/libpe_status.so.10.2.0
lib/libpengine.a lib/libpengine.a
lib/libpengine.so lib/libpengine.so
lib/libpengine.so.10 lib/libpengine.so.10
lib/libpengine.so.10.0.0 lib/libpengine.so.10.2.0
lib/libstonithd.a lib/libstonithd.a
lib/libstonithd.so lib/libstonithd.so
lib/libstonithd.so.2 lib/libstonithd.so.2
lib/libstonithd.so.2.2.0 lib/libstonithd.so.2.2.2
lib/libtransitioner.a lib/libtransitioner.a
lib/libtransitioner.so lib/libtransitioner.so
lib/libtransitioner.so.2 lib/libtransitioner.so.2
lib/libtransitioner.so.2.0.4 lib/libtransitioner.so.2.0.6
%%PYTHON_SITELIBDIR%%/cts/CIB.py %%PYTHON_SITELIBDIR%%/cts/CIB.py
%%PYTHON_SITELIBDIR%%/cts/CIB.pyc %%PYTHON_SITELIBDIR%%/cts/CIB.pyc
%%PYTHON_SITELIBDIR%%/cts/CIB.pyo %%PYTHON_SITELIBDIR%%/cts/CIB.pyo
@ -145,6 +147,7 @@ libexec/pacemaker/stonithd
%%MANPAGES%%man/man7/ocf_pacemaker_Stateful.7.gz %%MANPAGES%%man/man7/ocf_pacemaker_Stateful.7.gz
%%MANPAGES%%man/man7/ocf_pacemaker_SysInfo.7.gz %%MANPAGES%%man/man7/ocf_pacemaker_SysInfo.7.gz
%%MANPAGES%%man/man7/ocf_pacemaker_SystemHealth.7.gz %%MANPAGES%%man/man7/ocf_pacemaker_SystemHealth.7.gz
%%MANPAGES%%man/man7/ocf_pacemaker_attribute.7.gz
%%MANPAGES%%man/man7/ocf_pacemaker_controld.7.gz %%MANPAGES%%man/man7/ocf_pacemaker_controld.7.gz
%%MANPAGES%%man/man7/ocf_pacemaker_o2cb.7.gz %%MANPAGES%%man/man7/ocf_pacemaker_o2cb.7.gz
%%MANPAGES%%man/man7/ocf_pacemaker_ping.7.gz %%MANPAGES%%man/man7/ocf_pacemaker_ping.7.gz
@ -198,15 +201,22 @@ sbin/iso8601
sbin/pacemaker_remoted sbin/pacemaker_remoted
sbin/pacemakerd sbin/pacemakerd
sbin/stonith_admin sbin/stonith_admin
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/COPYING %%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/COPYING.LIB %%PORTDOCS%%%%DOCSDIR%%/README.markdown
%%PORTDOCS%%%%DOCSDIR%%/acls.html %%PORTDOCS%%%%DOCSDIR%%/acls.html
%%PORTDOCS%%%%DOCSDIR%%/acls.txt %%PORTDOCS%%%%DOCSDIR%%/acls.txt
%%PORTDOCS%%%%DOCSDIR%%/crm_fencing.html %%PORTDOCS%%%%DOCSDIR%%/crm_fencing.html
%%PORTDOCS%%%%DOCSDIR%%/crm_fencing.txt %%PORTDOCS%%%%DOCSDIR%%/crm_fencing.txt
%%PORTDOCS%%%%DOCSDIR%%/licenses/CC-BY-SA-4.0
%%PORTDOCS%%%%DOCSDIR%%/licenses/GPLv2
%%PORTDOCS%%%%DOCSDIR%%/licenses/LGPLv2.1
%%PORTDOCS%%%%DOCSDIR%%/licenses/RevisedBSD
%%DATADIR%%/acls-1.2.rng %%DATADIR%%/acls-1.2.rng
%%DATADIR%%/acls-2.0.rng %%DATADIR%%/acls-2.0.rng
%%DATADIR%%/alerts-2.5.rng
%%DATADIR%%/alerts/alert_file.sh.sample
%%DATADIR%%/alerts/alert_smtp.sh.sample
%%DATADIR%%/alerts/alert_snmp.sh.sample
%%DATADIR%%/cib-1.0.rng %%DATADIR%%/cib-1.0.rng
%%DATADIR%%/cib-1.2.rng %%DATADIR%%/cib-1.2.rng
%%DATADIR%%/constraints-1.0.rng %%DATADIR%%/constraints-1.0.rng
@ -214,6 +224,7 @@ sbin/stonith_admin
%%DATADIR%%/constraints-2.1.rng %%DATADIR%%/constraints-2.1.rng
%%DATADIR%%/constraints-2.2.rng %%DATADIR%%/constraints-2.2.rng
%%DATADIR%%/constraints-2.3.rng %%DATADIR%%/constraints-2.3.rng
%%DATADIR%%/constraints-2.6.rng
%%DATADIR%%/constraints-next.rng %%DATADIR%%/constraints-next.rng
%%DATADIR%%/crm-transitional.dtd %%DATADIR%%/crm-transitional.dtd
%%DATADIR%%/crm.dtd %%DATADIR%%/crm.dtd
@ -234,6 +245,8 @@ sbin/stonith_admin
%%DATADIR%%/pacemaker-2.2.rng %%DATADIR%%/pacemaker-2.2.rng
%%DATADIR%%/pacemaker-2.3.rng %%DATADIR%%/pacemaker-2.3.rng
%%DATADIR%%/pacemaker-2.4.rng %%DATADIR%%/pacemaker-2.4.rng
%%DATADIR%%/pacemaker-2.5.rng
%%DATADIR%%/pacemaker-2.6.rng
%%DATADIR%%/pacemaker-next.rng %%DATADIR%%/pacemaker-next.rng
%%DATADIR%%/pacemaker.rng %%DATADIR%%/pacemaker.rng
%%DATADIR%%/report.collector %%DATADIR%%/report.collector
@ -250,6 +263,7 @@ sbin/stonith_admin
%%DATADIR%%/tests/cli/regression.dates.exp %%DATADIR%%/tests/cli/regression.dates.exp
%%DATADIR%%/tests/cli/regression.sh %%DATADIR%%/tests/cli/regression.sh
%%DATADIR%%/tests/cli/regression.tools.exp %%DATADIR%%/tests/cli/regression.tools.exp
%%DATADIR%%/tests/cli/regression.validity.exp
%%DATADIR%%/tests/coverage.sh %%DATADIR%%/tests/coverage.sh
%%DATADIR%%/tests/cts/CTSlab.py %%DATADIR%%/tests/cts/CTSlab.py
%%DATADIR%%/tests/cts/HBDummy %%DATADIR%%/tests/cts/HBDummy
@ -396,16 +410,31 @@ sbin/stonith_admin
%%DATADIR%%/tests/pengine/test10/a-promote-then-b-migrate.scores %%DATADIR%%/tests/pengine/test10/a-promote-then-b-migrate.scores
%%DATADIR%%/tests/pengine/test10/a-promote-then-b-migrate.summary %%DATADIR%%/tests/pengine/test10/a-promote-then-b-migrate.summary
%%DATADIR%%/tests/pengine/test10/a-promote-then-b-migrate.xml %%DATADIR%%/tests/pengine/test10/a-promote-then-b-migrate.xml
%%DATADIR%%/tests/pengine/test10/anti-colocation-master.dot
%%DATADIR%%/tests/pengine/test10/anti-colocation-master.exp
%%DATADIR%%/tests/pengine/test10/anti-colocation-master.scores
%%DATADIR%%/tests/pengine/test10/anti-colocation-master.summary
%%DATADIR%%/tests/pengine/test10/anti-colocation-master.xml
%%DATADIR%%/tests/pengine/test10/anti-colocation-order.dot %%DATADIR%%/tests/pengine/test10/anti-colocation-order.dot
%%DATADIR%%/tests/pengine/test10/anti-colocation-order.exp %%DATADIR%%/tests/pengine/test10/anti-colocation-order.exp
%%DATADIR%%/tests/pengine/test10/anti-colocation-order.scores %%DATADIR%%/tests/pengine/test10/anti-colocation-order.scores
%%DATADIR%%/tests/pengine/test10/anti-colocation-order.summary %%DATADIR%%/tests/pengine/test10/anti-colocation-order.summary
%%DATADIR%%/tests/pengine/test10/anti-colocation-order.xml %%DATADIR%%/tests/pengine/test10/anti-colocation-order.xml
%%DATADIR%%/tests/pengine/test10/anti-colocation-slave.dot
%%DATADIR%%/tests/pengine/test10/anti-colocation-slave.exp
%%DATADIR%%/tests/pengine/test10/anti-colocation-slave.scores
%%DATADIR%%/tests/pengine/test10/anti-colocation-slave.summary
%%DATADIR%%/tests/pengine/test10/anti-colocation-slave.xml
%%DATADIR%%/tests/pengine/test10/asymmetric.dot %%DATADIR%%/tests/pengine/test10/asymmetric.dot
%%DATADIR%%/tests/pengine/test10/asymmetric.exp %%DATADIR%%/tests/pengine/test10/asymmetric.exp
%%DATADIR%%/tests/pengine/test10/asymmetric.scores %%DATADIR%%/tests/pengine/test10/asymmetric.scores
%%DATADIR%%/tests/pengine/test10/asymmetric.summary %%DATADIR%%/tests/pengine/test10/asymmetric.summary
%%DATADIR%%/tests/pengine/test10/asymmetric.xml %%DATADIR%%/tests/pengine/test10/asymmetric.xml
%%DATADIR%%/tests/pengine/test10/asymmetrical-order-move.dot
%%DATADIR%%/tests/pengine/test10/asymmetrical-order-move.exp
%%DATADIR%%/tests/pengine/test10/asymmetrical-order-move.scores
%%DATADIR%%/tests/pengine/test10/asymmetrical-order-move.summary
%%DATADIR%%/tests/pengine/test10/asymmetrical-order-move.xml
%%DATADIR%%/tests/pengine/test10/attrs1.dot %%DATADIR%%/tests/pengine/test10/attrs1.dot
%%DATADIR%%/tests/pengine/test10/attrs1.exp %%DATADIR%%/tests/pengine/test10/attrs1.exp
%%DATADIR%%/tests/pengine/test10/attrs1.scores %%DATADIR%%/tests/pengine/test10/attrs1.scores
@ -1136,6 +1165,11 @@ sbin/stonith_admin
%%DATADIR%%/tests/pengine/test10/complex_enforce_colo.scores %%DATADIR%%/tests/pengine/test10/complex_enforce_colo.scores
%%DATADIR%%/tests/pengine/test10/complex_enforce_colo.summary %%DATADIR%%/tests/pengine/test10/complex_enforce_colo.summary
%%DATADIR%%/tests/pengine/test10/complex_enforce_colo.xml %%DATADIR%%/tests/pengine/test10/complex_enforce_colo.xml
%%DATADIR%%/tests/pengine/test10/concurrent-fencing.dot
%%DATADIR%%/tests/pengine/test10/concurrent-fencing.exp
%%DATADIR%%/tests/pengine/test10/concurrent-fencing.scores
%%DATADIR%%/tests/pengine/test10/concurrent-fencing.summary
%%DATADIR%%/tests/pengine/test10/concurrent-fencing.xml
%%DATADIR%%/tests/pengine/test10/container-1.dot %%DATADIR%%/tests/pengine/test10/container-1.dot
%%DATADIR%%/tests/pengine/test10/container-1.exp %%DATADIR%%/tests/pengine/test10/container-1.exp
%%DATADIR%%/tests/pengine/test10/container-1.scores %%DATADIR%%/tests/pengine/test10/container-1.scores
@ -1871,6 +1905,11 @@ sbin/stonith_admin
%%DATADIR%%/tests/pengine/test10/multiple-active-block-group.scores %%DATADIR%%/tests/pengine/test10/multiple-active-block-group.scores
%%DATADIR%%/tests/pengine/test10/multiple-active-block-group.summary %%DATADIR%%/tests/pengine/test10/multiple-active-block-group.summary
%%DATADIR%%/tests/pengine/test10/multiple-active-block-group.xml %%DATADIR%%/tests/pengine/test10/multiple-active-block-group.xml
%%DATADIR%%/tests/pengine/test10/multiple-monitor-one-failed.dot
%%DATADIR%%/tests/pengine/test10/multiple-monitor-one-failed.exp
%%DATADIR%%/tests/pengine/test10/multiple-monitor-one-failed.scores
%%DATADIR%%/tests/pengine/test10/multiple-monitor-one-failed.summary
%%DATADIR%%/tests/pengine/test10/multiple-monitor-one-failed.xml
%%DATADIR%%/tests/pengine/test10/node-maintenance-1.dot %%DATADIR%%/tests/pengine/test10/node-maintenance-1.dot
%%DATADIR%%/tests/pengine/test10/node-maintenance-1.exp %%DATADIR%%/tests/pengine/test10/node-maintenance-1.exp
%%DATADIR%%/tests/pengine/test10/node-maintenance-1.scores %%DATADIR%%/tests/pengine/test10/node-maintenance-1.scores
@ -2532,6 +2571,11 @@ sbin/stonith_admin
%%DATADIR%%/tests/pengine/test10/rsc_dep8.scores %%DATADIR%%/tests/pengine/test10/rsc_dep8.scores
%%DATADIR%%/tests/pengine/test10/rsc_dep8.summary %%DATADIR%%/tests/pengine/test10/rsc_dep8.summary
%%DATADIR%%/tests/pengine/test10/rsc_dep8.xml %%DATADIR%%/tests/pengine/test10/rsc_dep8.xml
%%DATADIR%%/tests/pengine/test10/shutdown-maintenance-node.dot
%%DATADIR%%/tests/pengine/test10/shutdown-maintenance-node.exp
%%DATADIR%%/tests/pengine/test10/shutdown-maintenance-node.scores
%%DATADIR%%/tests/pengine/test10/shutdown-maintenance-node.summary
%%DATADIR%%/tests/pengine/test10/shutdown-maintenance-node.xml
%%DATADIR%%/tests/pengine/test10/simple1.dot %%DATADIR%%/tests/pengine/test10/simple1.dot
%%DATADIR%%/tests/pengine/test10/simple1.exp %%DATADIR%%/tests/pengine/test10/simple1.exp
%%DATADIR%%/tests/pengine/test10/simple1.scores %%DATADIR%%/tests/pengine/test10/simple1.scores
@ -2587,6 +2631,11 @@ sbin/stonith_admin
%%DATADIR%%/tests/pengine/test10/standby.scores %%DATADIR%%/tests/pengine/test10/standby.scores
%%DATADIR%%/tests/pengine/test10/standby.summary %%DATADIR%%/tests/pengine/test10/standby.summary
%%DATADIR%%/tests/pengine/test10/standby.xml %%DATADIR%%/tests/pengine/test10/standby.xml
%%DATADIR%%/tests/pengine/test10/start-then-stop-with-unfence.dot
%%DATADIR%%/tests/pengine/test10/start-then-stop-with-unfence.exp
%%DATADIR%%/tests/pengine/test10/start-then-stop-with-unfence.scores
%%DATADIR%%/tests/pengine/test10/start-then-stop-with-unfence.summary
%%DATADIR%%/tests/pengine/test10/start-then-stop-with-unfence.xml
%%DATADIR%%/tests/pengine/test10/stonith-0.dot %%DATADIR%%/tests/pengine/test10/stonith-0.dot
%%DATADIR%%/tests/pengine/test10/stonith-0.exp %%DATADIR%%/tests/pengine/test10/stonith-0.exp
%%DATADIR%%/tests/pengine/test10/stonith-0.scores %%DATADIR%%/tests/pengine/test10/stonith-0.scores
@ -3532,6 +3581,11 @@ sbin/stonith_admin
%%DATADIR%%/tests/pengine/test10/unrunnable-1.scores %%DATADIR%%/tests/pengine/test10/unrunnable-1.scores
%%DATADIR%%/tests/pengine/test10/unrunnable-1.summary %%DATADIR%%/tests/pengine/test10/unrunnable-1.summary
%%DATADIR%%/tests/pengine/test10/unrunnable-1.xml %%DATADIR%%/tests/pengine/test10/unrunnable-1.xml
%%DATADIR%%/tests/pengine/test10/unrunnable-2.dot
%%DATADIR%%/tests/pengine/test10/unrunnable-2.exp
%%DATADIR%%/tests/pengine/test10/unrunnable-2.scores
%%DATADIR%%/tests/pengine/test10/unrunnable-2.summary
%%DATADIR%%/tests/pengine/test10/unrunnable-2.xml
%%DATADIR%%/tests/pengine/test10/use-after-free-merge.dot %%DATADIR%%/tests/pengine/test10/use-after-free-merge.dot
%%DATADIR%%/tests/pengine/test10/use-after-free-merge.exp %%DATADIR%%/tests/pengine/test10/use-after-free-merge.exp
%%DATADIR%%/tests/pengine/test10/use-after-free-merge.scores %%DATADIR%%/tests/pengine/test10/use-after-free-merge.scores
@ -3607,6 +3661,11 @@ sbin/stonith_admin
%%DATADIR%%/tests/pengine/test10/whitebox-move.scores %%DATADIR%%/tests/pengine/test10/whitebox-move.scores
%%DATADIR%%/tests/pengine/test10/whitebox-move.summary %%DATADIR%%/tests/pengine/test10/whitebox-move.summary
%%DATADIR%%/tests/pengine/test10/whitebox-move.xml %%DATADIR%%/tests/pengine/test10/whitebox-move.xml
%%DATADIR%%/tests/pengine/test10/whitebox-ms-ordering-move.dot
%%DATADIR%%/tests/pengine/test10/whitebox-ms-ordering-move.exp
%%DATADIR%%/tests/pengine/test10/whitebox-ms-ordering-move.scores
%%DATADIR%%/tests/pengine/test10/whitebox-ms-ordering-move.summary
%%DATADIR%%/tests/pengine/test10/whitebox-ms-ordering-move.xml
%%DATADIR%%/tests/pengine/test10/whitebox-ms-ordering.dot %%DATADIR%%/tests/pengine/test10/whitebox-ms-ordering.dot
%%DATADIR%%/tests/pengine/test10/whitebox-ms-ordering.exp %%DATADIR%%/tests/pengine/test10/whitebox-ms-ordering.exp
%%DATADIR%%/tests/pengine/test10/whitebox-ms-ordering.scores %%DATADIR%%/tests/pengine/test10/whitebox-ms-ordering.scores
@ -3647,10 +3706,9 @@ sbin/stonith_admin
%%DATADIR%%/upgrade06.xsl %%DATADIR%%/upgrade06.xsl
%%DATADIR%%/versions.rng %%DATADIR%%/versions.rng
share/snmp/mibs/PCMK-MIB.txt share/snmp/mibs/PCMK-MIB.txt
@dir /usr/local/etc/rc.d
@dir /usr/local/etc
@dir /var/lib/pacemaker/blackbox @dir /var/lib/pacemaker/blackbox
@dir /var/lib/pacemaker/cib @dir /var/lib/pacemaker/cib
@dir /var/lib/pacemaker/cores
@dir /var/lib/pacemaker/pengine @dir /var/lib/pacemaker/pengine
@dir /var/lib/pacemaker @dir /var/lib/pacemaker
@dir /var/lib @dir /var/lib