www/py-dropbox: Convert to USE_PYTHON=pep517

- Bump PORTREVISION for package change
This commit is contained in:
Po-Chuan Hsieh 2024-05-13 22:12:36 +08:00
parent b0867dcc39
commit 557b0799b2
No known key found for this signature in database
GPG key ID: 9A4BD10F002DD04B
2 changed files with 11 additions and 3 deletions

View file

@ -1,5 +1,6 @@
PORTNAME= dropbox
PORTVERSION= 11.36.0
PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -12,12 +13,14 @@ WWW= https://dropbox-sdk-python.readthedocs.io/en/latest/ \
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}stone>=2.0:devel/py-stone@${PY_FLAVOR}
USES= python
USE_PYTHON= autoplist concurrent distutils
USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes

View file

@ -1,6 +1,11 @@
--- setup.py.orig 2022-07-13 18:09:08 UTC
--- setup.py.orig 2022-11-09 23:21:58 UTC
+++ setup.py
@@ -31,9 +31,6 @@ install_reqs = [
@@ -27,13 +27,10 @@ install_reqs = [
install_reqs = [
'requests >= 2.16.2',
'six >= 1.12.0',
- 'stone >= 2.*',
+ 'stone >= 2.0',
]
setup_requires = [