ports-mgmt/portrac: Update to 0.6

ChangeLog: https://github.com/e-soul/portrac/releases/tag/v0.6

 * Change default INDEX version to 14.
 * Add missing includes.
 * Update copyright statements.

PR:		284371
Reported by:	mario.g.pavlov@gmail.com (maintainer)
This commit is contained in:
Fernando Apesteguía 2025-01-30 10:31:29 +01:00
parent a95d0890a0
commit 53bb50a9c1
4 changed files with 10 additions and 30 deletions

View file

@ -1,8 +1,9 @@
PORTNAME= portrac
PORTVERSION= 0.5.1
PORTVERSION= 0.6
CATEGORIES= ports-mgmt
MASTER_SITES= http://e-soul.org/distfiles/ \
http://home.e-soul.org/~mgp/distfiles/
DISTNAME= v${PORTVERSION}
MASTER_SITES= https://github.com/e-soul/portrac/archive/refs/tags/
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAINTAINER= Mario.G.Pavlov@gmail.com
COMMENT= Simple GUI tool for tracking port updates
@ -10,7 +11,7 @@ WWW= https://portrac.e-soul.org/
LICENSE= BSD2CLAUSE
USES= compiler:c++11-lib gl qmake qt:5 tar:bzip2
USES= compiler:c++11-lib gl qmake qt:5
USE_CXXSTD= c++11
USE_GL= gl
USE_QT= buildtools:build core gui widgets
@ -21,8 +22,8 @@ PLIST_FILES= bin/portrac \
share/portrac/updates-available.png
do-install:
${INSTALL_PROGRAM} ${WRKDIR}/${DISTNAME}/portrac ${STAGEDIR}${PREFIX}/bin && \
${INSTALL_PROGRAM} ${WRKSRC}/portrac ${STAGEDIR}${PREFIX}/bin && \
${MKDIR} ${STAGEDIR}${DATADIR} && \
${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/*.png ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/*.png ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1634741583
SHA256 (portrac-0.5.1.tar.bz2) = 1cbd8e6059db7414f2cb3da903fc9750ca4fb4157a14218745926cd1c393b8cd
SIZE (portrac-0.5.1.tar.bz2) = 9692
TIMESTAMP = 1737922519
SHA256 (v0.6.tar.gz) = 9221682f36b2bd451107682383ebbd6d74ecdfb2cc0a4586c2f6e6123da12de2
SIZE (v0.6.tar.gz) = 9987

View file

@ -1,11 +0,0 @@
--- PortChecker.cc.orig 2014-09-29 18:19:21 UTC
+++ PortChecker.cc
@@ -31,6 +31,8 @@
#include <string>
#include <algorithm>
#include <iostream>
+#include <cstdio>
+#include <cerrno>
#include <QStringList>

View file

@ -1,10 +0,0 @@
--- Preferences.cc.orig 2014-09-29 18:19:21 UTC
+++ Preferences.cc
@@ -29,6 +29,7 @@
#include <map>
#include <iostream>
#include <fstream>
+#include <cstdlib>
#include "Preferences.hh"