security/py-python-jose: Add py-python-jose 3.4.0

python-jose provides a JOSE implementation in Python.

The JavaScript Object Signing and Encryption (JOSE) technologies - JSON Web
Signature (JWS), JSON Web Encryption (JWE), JSON Web Key (JWK), and JSON Web
Algorithms (JWA) - collectively can be used to encrypt and/or sign content using
a variety of algorithms. While the full set of permutations is extremely large,
and might be daunting to some, it is expected that most applications will only
use a small set of algorithms to meet their needs.
This commit is contained in:
Po-Chuan Hsieh 2025-04-10 01:41:39 +08:00
parent d8528757b4
commit 53a685aecc
No known key found for this signature in database
GPG key ID: 9A4BD10F002DD04B
6 changed files with 57 additions and 1 deletions

1
MOVED
View file

@ -4246,7 +4246,6 @@ finance/odoo14||2025-03-31|Has expired: Depends on expired converters/wkhtmltopd
net/nsscache||2025-03-31|Has expired: Depends on expired devel/py-pytest-runner
security/caldera4||2025-03-31|Has expired: Upgrade to a newer caldera version. 4.2.0 is vulnerable to remote code execution
net/opensips31||2025-03-31|Has expired: Deprecated upstream
security/py-python-jose||2025-03-31|Has expired: Depends on expired devel/py-pytest-runner
textproc/rubygem-nokogumbo||2025-03-31|Has expired: Upstream has merged into textproc/rubygem-nokogiri
net/libmediawiki||2025-03-31|Has expired: Project abandoned upstream
net/py-tacacs_plus||2025-03-31|Has expired: Depends on expired devel/py-pytest-runner

View file

@ -1035,6 +1035,7 @@
SUBDIR += py-python-cas
SUBDIR += py-python-gnupg
SUBDIR += py-python-gvm
SUBDIR += py-python-jose
SUBDIR += py-python-nss
SUBDIR += py-python-openid
SUBDIR += py-python-pam

View file

@ -0,0 +1,34 @@
PORTNAME= python-jose
PORTVERSION= 3.4.0
CATEGORIES= security
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= JOSE implementation in Python
WWW= https://python-jose.readthedocs.io/en/latest/ \
https://github.com/mpdavis/python-jose
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=39.2.0:devel/py-setuptools@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>=0.29.0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ecdsa>=0:security/py-ecdsa@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyasn1>=0.4.1:devel/py-pyasn1@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}rsa>=4.0<5.0:security/py-rsa@${PY_FLAVOR}
USES= python
USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
OPTIONS_DEFINE= CRYPTOGRAPHY PYCRYPTODOME
OPTIONS_DEFAULT=CRYPTOGRAPHY
CRYPTOGRAPHY_DESC= Use cryptography as cryptographic backend
PYCRYPTODOME_DESC= Use pycryptodome as cryptographic backend
CRYPTOGRAPHY_USE= PYTHON=cryptography
PYCRYPTODOME_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycryptodome>=3.3.1<4.0.0:security/py-pycryptodome@${PY_FLAVOR}
.include <bsd.port.mk>

View file

@ -0,0 +1,3 @@
TIMESTAMP = 1741448419
SHA256 (python-jose-3.4.0.tar.gz) = 9a9a40f418ced8ecaf7e3b28d69887ceaa76adad3bcaa6dae0d9e596fec1d680
SIZE (python-jose-3.4.0.tar.gz) = 92145

View file

@ -0,0 +1,11 @@
--- setup.cfg.orig 2025-02-14 18:05:26 UTC
+++ setup.cfg
@@ -34,7 +34,7 @@ install_requires =
install_requires =
ecdsa != 0.15
rsa >=4.0, <5.0, !=4.4, !=4.1.1
- pyasn1 >=0.4.1, <0.5.0
+ pyasn1 >=0.4.1
[options.extras_require]
test =

View file

@ -0,0 +1,8 @@
python-jose provides a JOSE implementation in Python.
The JavaScript Object Signing and Encryption (JOSE) technologies - JSON Web
Signature (JWS), JSON Web Encryption (JWE), JSON Web Key (JWK), and JSON Web
Algorithms (JWA) - collectively can be used to encrypt and/or sign content using
a variety of algorithms. While the full set of permutations is extremely large,
and might be daunting to some, it is expected that most applications will only
use a small set of algorithms to meet their needs.