mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
multiple_ports: moved man to share/man
Update my ports: graphics/mupdf x11-wm/herbstluftwm x11/stalonetray Fix order of variables in graphics/mupdf. Approved by: bofh (mentor) Differential Revision: https://reviews.freebsd.org/D44052
This commit is contained in:
parent
be907b0126
commit
537cbffa59
7 changed files with 32 additions and 24 deletions
|
@ -1,6 +1,7 @@
|
||||||
PORTNAME= mupdf
|
PORTNAME= mupdf
|
||||||
DISTVERSION= 1.23.9
|
DISTVERSION= 1.23.9
|
||||||
DISTVERSIONSUFFIX= -source
|
DISTVERSIONSUFFIX= -source
|
||||||
|
PORTREVISION= 1
|
||||||
PORTEPOCH= 1
|
PORTEPOCH= 1
|
||||||
CATEGORIES= graphics
|
CATEGORIES= graphics
|
||||||
MASTER_SITES= http://www.mupdf.com/downloads/archive/
|
MASTER_SITES= http://www.mupdf.com/downloads/archive/
|
||||||
|
@ -18,36 +19,40 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
|
||||||
libjbig2dec.so:graphics/jbig2dec \
|
libjbig2dec.so:graphics/jbig2dec \
|
||||||
libopenjp2.so:graphics/openjpeg
|
libopenjp2.so:graphics/openjpeg
|
||||||
|
|
||||||
USES= cpe compiler:c++11-lang gl gmake jpeg pkgconfig xorg
|
USES= compiler:c++11-lang cpe gl gmake jpeg pkgconfig xorg
|
||||||
USE_XORG= x11 xcursor xext xinerama xrandr
|
CPE_VENDOR= artifex
|
||||||
USE_GL= gl glut
|
USE_GL= gl glut
|
||||||
USE_LDCONFIG= yes
|
USE_LDCONFIG= yes
|
||||||
|
USE_XORG= x11 xcursor xext xinerama xrandr
|
||||||
|
|
||||||
CPE_VENDOR= artifex
|
MAKE_ARGS= build=release \
|
||||||
|
mandir=${PREFIX}/share/man \
|
||||||
|
prefix=${PREFIX} \
|
||||||
|
SOVERSION=${DISTVERSION} \
|
||||||
|
verbose=yes \
|
||||||
|
XCFLAGS+="-I${WRKSRC}/include/mupdf -fPIC" \
|
||||||
|
XLIBS+="-L${LOCALBASE}/lib -L${WRKSRC}/build/release"
|
||||||
|
ALL_TARGET= all extra-libs
|
||||||
|
|
||||||
# pkg-config to avoid the conflict with openjpeg15
|
# pkg-config to avoid the conflict with openjpeg15
|
||||||
CFLAGS+= `pkg-config --cflags libopenjp2`
|
CFLAGS+= `pkg-config --cflags libopenjp2`
|
||||||
LDFLAGS+= `pkg-config --libs libjpeg libopenjp2` -ljbig2dec
|
LDFLAGS+= `pkg-config --libs libjpeg libopenjp2` -ljbig2dec
|
||||||
|
|
||||||
MAKE_ARGS= build=release prefix=${PREFIX} mandir=${PREFIX}/man verbose=yes \
|
BINARY_ALIAS= bash=/bin/sh
|
||||||
XCFLAGS+="-I${WRKSRC}/include/mupdf -fPIC" \
|
|
||||||
XLIBS+="-L${LOCALBASE}/lib -L${WRKSRC}/build/release" \
|
|
||||||
SOVERSION=${DISTVERSION}
|
|
||||||
ALL_TARGET= all extra-libs
|
|
||||||
|
|
||||||
OPTIONS_DEFINE= DOCS JS SCROLL
|
PLIST_SUB= SOVERSION=${PORTVERSION}
|
||||||
|
|
||||||
|
OPTIONS_DEFINE= DOCS JS SCROLL
|
||||||
OPTIONS_DEFAULT= SCROLL
|
OPTIONS_DEFAULT= SCROLL
|
||||||
|
|
||||||
JS_DESC= JavaScript support (V8 engine)
|
JS_DESC= JavaScript support (V8 engine)
|
||||||
SCROLL_DESC= Build with scroll hacks
|
SCROLL_DESC= Build with scroll hacks
|
||||||
|
|
||||||
JS_LIB_DEPENDS= libv8.so:lang/v8
|
JS_LIB_DEPENDS= libv8.so:lang/v8
|
||||||
JS_MAKE_ARGS= V8_PRESENT=1 V8LIBS=-lv8
|
JS_MAKE_ARGS= V8_PRESENT=1 \
|
||||||
|
V8LIBS=-lv8
|
||||||
SCROLL_EXTRA_PATCHES= ${FILESDIR}/scroll_hack-platform__x11__pdfapp.c
|
SCROLL_EXTRA_PATCHES= ${FILESDIR}/scroll_hack-platform__x11__pdfapp.c
|
||||||
|
|
||||||
BINARY_ALIAS= bash=/bin/sh
|
|
||||||
PLIST_SUB= SOVERSION=${PORTVERSION}
|
|
||||||
|
|
||||||
post-patch:
|
post-patch:
|
||||||
@${REINPLACE_CMD} -e 's/-pipe -O2//' -e 's/-ldl//' ${WRKSRC}/Makerules
|
@${REINPLACE_CMD} -e 's/-pipe -O2//' -e 's/-ldl//' ${WRKSRC}/Makerules
|
||||||
|
|
||||||
|
|
|
@ -76,8 +76,8 @@ lib/libmupdf-third.so
|
||||||
lib/libmupdf-third.so.%%SOVERSION%%
|
lib/libmupdf-third.so.%%SOVERSION%%
|
||||||
lib/libmupdf.so
|
lib/libmupdf.so
|
||||||
lib/libmupdf.so.%%SOVERSION%%
|
lib/libmupdf.so.%%SOVERSION%%
|
||||||
man/man1/mupdf.1.gz
|
share/man/man1/mupdf.1.gz
|
||||||
man/man1/mutool.1.gz
|
share/man/man1/mutool.1.gz
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
|
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/COPYING
|
%%PORTDOCS%%%%DOCSDIR%%/COPYING
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||||
|
|
|
@ -1,5 +1,6 @@
|
||||||
PORTNAME= herbstluftwm
|
PORTNAME= herbstluftwm
|
||||||
DISTVERSION= 0.9.5
|
DISTVERSION= 0.9.5
|
||||||
|
PORTREVISION= 1
|
||||||
CATEGORIES= x11-wm
|
CATEGORIES= x11-wm
|
||||||
MASTER_SITES= https://herbstluftwm.org/tarballs/
|
MASTER_SITES= https://herbstluftwm.org/tarballs/
|
||||||
|
|
||||||
|
|
|
@ -1,4 +1,4 @@
|
||||||
--- CMakeLists.txt.orig 2021-02-17 10:06:29 UTC
|
--- CMakeLists.txt.orig 2022-07-30 05:55:21 UTC
|
||||||
+++ CMakeLists.txt
|
+++ CMakeLists.txt
|
||||||
@@ -20,13 +20,13 @@ include(ccache)
|
@@ -20,13 +20,13 @@ include(ccache)
|
||||||
|
|
||||||
|
@ -12,11 +12,11 @@
|
||||||
set(BINDIR bin)
|
set(BINDIR bin)
|
||||||
set(DATADIR share)
|
set(DATADIR share)
|
||||||
-set(MANDIR ${DATADIR}/man)
|
-set(MANDIR ${DATADIR}/man)
|
||||||
+set(MANDIR ${CMAKE_INSTALL_PREFIX}/man)
|
+set(MANDIR ${CMAKE_INSTALL_PREFIX}/share/man)
|
||||||
set(DOCDIR ${DATADIR}/doc/herbstluftwm)
|
set(DOCDIR ${DATADIR}/doc/herbstluftwm)
|
||||||
set(LICENSEDIR ${DOCDIR}
|
set(LICENSEDIR ${DOCDIR}
|
||||||
CACHE PATH "Install path for license file")
|
CACHE PATH "Install path for license file")
|
||||||
@@ -36,7 +36,7 @@ set(ZSHCOMPLETIONDIR ${DATADIR}/zsh/site-functions
|
@@ -36,7 +36,7 @@ set(FISHCOMPLETIONDIR ${DATADIR}/fish/vendor_completio
|
||||||
CACHE PATH "Install path for zsh completions file")
|
CACHE PATH "Install path for zsh completions file")
|
||||||
set(FISHCOMPLETIONDIR ${DATADIR}/fish/vendor_completions.d
|
set(FISHCOMPLETIONDIR ${DATADIR}/fish/vendor_completions.d
|
||||||
CACHE PATH "Install path for fish completions file")
|
CACHE PATH "Install path for fish completions file")
|
||||||
|
@ -25,7 +25,7 @@
|
||||||
CACHE PATH "Install path for bash completions file")
|
CACHE PATH "Install path for bash completions file")
|
||||||
|
|
||||||
## do the actual work
|
## do the actual work
|
||||||
@@ -47,7 +47,6 @@ add_subdirectory(share)
|
@@ -47,7 +47,6 @@ install(FILES NEWS DESTINATION ${DOCDIR})
|
||||||
|
|
||||||
## install everything that was not installed from subdirectories
|
## install everything that was not installed from subdirectories
|
||||||
install(FILES NEWS DESTINATION ${DOCDIR})
|
install(FILES NEWS DESTINATION ${DOCDIR})
|
||||||
|
|
|
@ -13,9 +13,9 @@ share/zsh/site-functions/_herbstclient
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/html/herbstclient.html
|
%%PORTDOCS%%%%DOCSDIR%%/html/herbstclient.html
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/html/herbstluftwm-tutorial.html
|
%%PORTDOCS%%%%DOCSDIR%%/html/herbstluftwm-tutorial.html
|
||||||
%%PORTDOCS%%%%DOCSDIR%%/html/herbstluftwm.html
|
%%PORTDOCS%%%%DOCSDIR%%/html/herbstluftwm.html
|
||||||
%%PORTDOCS%%man/man1/herbstclient.1.gz
|
%%PORTDOCS%%share/man/man1/herbstclient.1.gz
|
||||||
%%PORTDOCS%%man/man1/herbstluftwm.1.gz
|
%%PORTDOCS%%share/man/man1/herbstluftwm.1.gz
|
||||||
%%PORTDOCS%%man/man7/herbstluftwm-tutorial.7.gz
|
%%PORTDOCS%%share/man/man7/herbstluftwm-tutorial.7.gz
|
||||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README
|
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README
|
||||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dmenu.sh
|
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dmenu.sh
|
||||||
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dumpbeautify.sh
|
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dumpbeautify.sh
|
||||||
|
|
|
@ -1,6 +1,7 @@
|
||||||
PORTNAME= stalonetray
|
PORTNAME= stalonetray
|
||||||
DISTVERSIONPREFIX= v
|
DISTVERSIONPREFIX= v
|
||||||
DISTVERSION= 0.8.5
|
DISTVERSION= 0.8.5
|
||||||
|
PORTREVISION= 1
|
||||||
CATEGORIES= x11
|
CATEGORIES= x11
|
||||||
|
|
||||||
MAINTAINER= uzsolt@FreeBSD.org
|
MAINTAINER= uzsolt@FreeBSD.org
|
||||||
|
@ -18,6 +19,7 @@ GH_ACCOUNT= kolbusa
|
||||||
USE_XORG= sm ice x11 xpm
|
USE_XORG= sm ice x11 xpm
|
||||||
|
|
||||||
GNU_CONFIGURE= yes
|
GNU_CONFIGURE= yes
|
||||||
|
GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
|
||||||
CONFIGURE_ARGS= --disable-native-kde \
|
CONFIGURE_ARGS= --disable-native-kde \
|
||||||
--disable-debug
|
--disable-debug
|
||||||
|
|
||||||
|
|
|
@ -1,3 +1,3 @@
|
||||||
bin/stalonetray
|
bin/stalonetray
|
||||||
man/man1/stalonetray.1.gz
|
share/man/man1/stalonetray.1.gz
|
||||||
%%EXAMPLESDIR%%/stalonetrayrc.sample
|
%%EXAMPLESDIR%%/stalonetrayrc.sample
|
||||||
|
|
Loading…
Add table
Reference in a new issue