mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
cad/gmsh: upgrade to 4.13.1
Changelog at <https://gitlab.onelab.info/gmsh/gmsh/blob/master/CHANGELOG.txt>. Also: - take maintainership again - add alternative WWW, because the main one has been reported as defective - prefer external libraries when possible - always enable SHARED - add a test target
This commit is contained in:
parent
472fcaa9cf
commit
52fafbba27
5 changed files with 103 additions and 186 deletions
|
@ -1,46 +1,53 @@
|
|||
PORTNAME= gmsh
|
||||
DISTVERSION= 4.11.1
|
||||
PORTREVISION= 6
|
||||
DISTVERSION= 4.13.1
|
||||
CATEGORIES= cad
|
||||
MASTER_SITES= http://gmsh.info/src/
|
||||
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
|
||||
DIST_SUBDIR= gmsh
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= thierry@FreeBSD.org
|
||||
COMMENT= Automatic 3D finite element mesh generator
|
||||
WWW= https://www.geuz.org/gmsh/
|
||||
WWW= https://gmsh.info/
|
||||
|
||||
LICENSE= AGPLv3+ APACHE20 GPLv3+ GPLv2+ LGPL21
|
||||
LICENSE_COMB= multi
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
|
||||
|
||||
BUILD_DEPENDS= getdp:science/getdp
|
||||
LIB_DEPENDS= libfltk.so:x11-toolkits/fltk \
|
||||
libfontconfig.so:x11-fonts/fontconfig \
|
||||
libgmp.so:math/gmp \
|
||||
libmetis.so:math/metis \
|
||||
libhdf5.so:science/hdf5 \
|
||||
libpng.so:graphics/png \
|
||||
libsz.so:science/libaec \
|
||||
libfreetype.so:print/freetype2
|
||||
libmathex.so:math/mathex \
|
||||
libalglib.so:math/alglib \
|
||||
libvoro++.so:science/voro++ \
|
||||
libmesquite.so:math/mesquite \
|
||||
libfreetype.so:print/freetype2 \
|
||||
libtinyxml2.so:textproc/tinyxml2
|
||||
RUN_DEPENDS= getdp:science/getdp
|
||||
|
||||
USES= blaslapack compiler:c++11-lang cmake fortran gl jpeg tar:tgz \
|
||||
xorg
|
||||
USES= bison compiler:c++14-lang cmake:testing eigen:3 fortran gl \
|
||||
jpeg localbase tar:tgz xorg
|
||||
|
||||
USE_GL= gl glu
|
||||
USE_XORG= ice sm x11 xcursor xext xinerama xfixes xft xrender
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
CMAKE_ARGS= -DCMAKE_SKIP_RPATH:BOOL=YES
|
||||
CMAKE_ON= ENABLE_BUILD_DYNAMIC ENABLE_BUILD_SHARED ENABLE_SYSTEM_CONTRIB
|
||||
|
||||
CXXFLAGS_powerpc64= -mvsx
|
||||
LDFLAGS+= -lexecinfo
|
||||
|
||||
OPTIONS_DEFINE= CGNS DOCS MED OCC SHARED STATIC
|
||||
OPTIONS_DEFINE= CGNS DOCS MED OCC STATIC
|
||||
OPTIONS_DEFAULT= CGNS MED OCC
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
CGNS_DESC= Enable CGNS mesh import
|
||||
MED_DESC= Enable MED mesh and post file formats
|
||||
OCC_DESC= Enable OpenCASCADE geometrical models
|
||||
SHARED_DESC= Build shared library and install header files
|
||||
STATIC_DESC= Build static library
|
||||
|
||||
PLIST_SUB= VER=${PORTVERSION} VE=${PORTVERSION:R}
|
||||
|
@ -52,7 +59,7 @@ PLIST_SUB= VER=${PORTVERSION} VE=${PORTVERSION:R}
|
|||
|
||||
CGNS_CMAKE_BOOL= ENABLE_CGNS
|
||||
CGNS_LIB_DEPENDS= libcgns.so:science/cgnslib
|
||||
DOCS_CMAKE_BOOL= INSTALL_DOCS
|
||||
DOCS_USES= makeinfo
|
||||
MED_CMAKE_BOOL= ENABLE_MED
|
||||
MED_LIB_DEPENDS= libmed.so:french/med
|
||||
OCC_CMAKE_BOOL= ENABLE_OCC
|
||||
|
@ -60,11 +67,6 @@ OCC_CMAKE_ON= -DOCC_INC=${LOCALBASE}/include/OpenCASCADE
|
|||
OCC_LIB_DEPENDS= libopenblas.so:math/openblas libTKernel.so:cad/opencascade
|
||||
OCC_USES= gnome
|
||||
OCC_USE= gnome=cairo
|
||||
SHARED_CMAKE_BOOL= ENABLE_BUILD_SHARED
|
||||
SHARED_USE= LDCONFIG=yes
|
||||
STATIC_CMAKE_BOOL= ENABLE_BUILD_LIB
|
||||
|
||||
post-install-SHARED-on:
|
||||
${RM} -r ${STAGEDIR}/wrkdirs
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1685840975
|
||||
SHA256 (gmsh/gmsh-4.11.1-source.tgz) = c5fe1b7cbd403888a814929f2fd0f5d69e27600222a18c786db5b76e8005b365
|
||||
SIZE (gmsh/gmsh-4.11.1-source.tgz) = 17985611
|
||||
TIMESTAMP = 1718914009
|
||||
SHA256 (gmsh/gmsh-4.13.1-source.tgz) = 77972145f431726026d50596a6a44fb3c1c95c21255218d66955806b86edbe8d
|
||||
SIZE (gmsh/gmsh-4.13.1-source.tgz) = 18383962
|
||||
|
|
|
@ -1,170 +1,11 @@
|
|||
--- CMakeLists.txt.orig 2022-12-20 15:30:55 UTC
|
||||
--- CMakeLists.txt.orig 2024-05-07 15:55:05 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -1,4 +1,4 @@
|
||||
-# Gmsh - Copyright (C) 1997-2022 C. Geuzaine, J.-F. Remacle
|
||||
+# Gmsh - Copyright (C) 1997-2023 C. Geuzaine, J.-F. Remacle
|
||||
#
|
||||
# See the LICENSE.txt file in the Gmsh root directory for license information.
|
||||
# Please report all issues on https://gitlab.onelab.info/gmsh/gmsh/issues.
|
||||
@@ -107,8 +107,8 @@ set(GMSH_MAJOR_VERSION 4)
|
||||
opt(ZIPPER "Enable Zip file compression/decompression" OFF)
|
||||
|
||||
set(GMSH_MAJOR_VERSION 4)
|
||||
-set(GMSH_MINOR_VERSION 11)
|
||||
-set(GMSH_PATCH_VERSION 1)
|
||||
+set(GMSH_MINOR_VERSION 12)
|
||||
+set(GMSH_PATCH_VERSION 0)
|
||||
if(NOT GMSH_EXTRA_VERSION)
|
||||
set(GMSH_EXTRA_VERSION "")
|
||||
endif()
|
||||
@@ -343,13 +343,19 @@ if(ENABLE_OPENMP)
|
||||
"${CMAKE_CXX_FLAGS} -Xpreprocessor -fopenmp -I/opt/local/include/libomp")
|
||||
list(APPEND EXTERNAL_LIBRARIES "-L/opt/local/lib/libomp -lomp")
|
||||
elseif(APPLE AND EXISTS "/usr/local/lib/libomp.dylib")
|
||||
- # official Apple compiler with homebrew's libomp
|
||||
+ # official Apple compiler with homebrew's libomp on Intel
|
||||
set_config_option(HAVE_OPENMP "OpenMP[Homebrew]")
|
||||
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Xpreprocessor -fopenmp")
|
||||
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Xpreprocessor -fopenmp")
|
||||
+ list(APPEND EXTERNAL_LIBRARIES "-L/usr/local/lib -lomp")
|
||||
+ elseif(APPLE AND EXISTS "/opt/homebrew/opt/libomp")
|
||||
+ # official Apple compiler with homebrew's libomp on M processors
|
||||
+ set_config_option(HAVE_OPENMP "OpenMP[Homebrew]")
|
||||
set(CMAKE_C_FLAGS
|
||||
- "${CMAKE_C_FLAGS} -Xpreprocessor -fopenmp")
|
||||
+ "${CMAKE_C_FLAGS} -Xpreprocessor -fopenmp -I/opt/homebrew/opt/libomp/include")
|
||||
set(CMAKE_CXX_FLAGS
|
||||
- "${CMAKE_CXX_FLAGS} -Xpreprocessor -fopenmp")
|
||||
- list(APPEND EXTERNAL_LIBRARIES "-L/usr/local/lib -lomp")
|
||||
+ "${CMAKE_CXX_FLAGS} -Xpreprocessor -fopenmp -I/opt/homebrew/opt/libomp/include")
|
||||
+ list(APPEND EXTERNAL_LIBRARIES "-L/opt/homebrew/opt/libomp/lib -lomp")
|
||||
elseif(${CMAKE_SYSTEM_NAME} MATCHES "Linux" AND EXISTS "/usr/local/lib64/libgomp.a")
|
||||
# custom static openmp for official linux builds
|
||||
set_config_option(HAVE_OPENMP "OpenMP[static]")
|
||||
@@ -1101,9 +1107,9 @@ if(HAVE_SOLVER)
|
||||
string(REPLACE " " ";" PETSC_PACKAGES_INCLUDES ${PETSC_PACKAGES_INCLUDES})
|
||||
foreach(VAR ${PETSC_PACKAGES_INCLUDES})
|
||||
# seem to include unexisting directories (/usr/include/lib64)
|
||||
- # check to avoid warnings
|
||||
- if(EXISTS ${VAR})
|
||||
- list(APPEND EXTERNAL_INCLUDES ${VAR})
|
||||
+ # check to avoid warnings
|
||||
+ if(EXISTS ${VAR})
|
||||
+ list(APPEND EXTERNAL_INCLUDES ${VAR})
|
||||
endif()
|
||||
endforeach()
|
||||
endif()
|
||||
@@ -1119,10 +1125,10 @@ if(HAVE_SOLVER)
|
||||
endif()
|
||||
if(PETSC_LIBS)
|
||||
set_config_option(HAVE_PETSC "PETSc")
|
||||
- if(NOT HAVE_BLAS)
|
||||
+ if(NOT HAVE_BLAS)
|
||||
set_config_option(HAVE_BLAS "Blas[petsc]")
|
||||
endif()
|
||||
- if(NOT HAVE_LAPACK)
|
||||
+ if(NOT HAVE_LAPACK)
|
||||
set_config_option(HAVE_LAPACK "Lapack[petsc]")
|
||||
endif()
|
||||
endif()
|
||||
@@ -1264,21 +1270,34 @@ if(ENABLE_OCC)
|
||||
message(STATUS "Found OpenCASCADE version ${OCC_VERSION} in ${OCC_INC}")
|
||||
endif()
|
||||
endif()
|
||||
- if(OCC_VERSION AND OCC_VERSION STRLESS ${OCC_MINIMAL_VERSION})
|
||||
+ if(OCC_VERSION AND OCC_VERSION VERSION_LESS ${OCC_MINIMAL_VERSION})
|
||||
message(WARNING "Gmsh requires OpenCASCADE >= ${OCC_MINIMAL_VERSION}. "
|
||||
"Use CMAKE_PREFIX_PATH or the CASROOT environment variable "
|
||||
"to explicitly specify the installation path of OpenCASCADE")
|
||||
elseif(OCC_INC)
|
||||
- set(OCC_LIBS_REQUIRED
|
||||
- # subset of DataExchange
|
||||
- TKSTEP TKSTEP209 TKSTEPAttr TKSTEPBase TKIGES TKXSBase
|
||||
- # ModelingAlgorithms
|
||||
- TKOffset TKFeat TKFillet TKBool TKMesh TKHLR TKBO TKPrim TKShHealing
|
||||
- TKTopAlgo TKGeomAlgo
|
||||
- # ModelingData
|
||||
- TKBRep TKGeomBase TKG3d TKG2d
|
||||
- # FoundationClasses
|
||||
- TKMath TKernel)
|
||||
+ if(OCC_VERSION AND OCC_VERSION VERSION_GREATER_EQUAL "7.8.0")
|
||||
+ set(OCC_LIBS_REQUIRED
|
||||
+ # subset of DataExchange
|
||||
+ TKDESTEP TKDEIGES TKXSBase
|
||||
+ # ModelingAlgorithms
|
||||
+ TKOffset TKFeat TKFillet TKBool TKMesh TKHLR TKBO TKPrim TKShHealing
|
||||
+ TKTopAlgo TKGeomAlgo
|
||||
+ # ModelingData
|
||||
+ TKBRep TKGeomBase TKG3d TKG2d
|
||||
+ # FoundationClasses
|
||||
+ TKMath TKernel)
|
||||
+ else()
|
||||
+ set(OCC_LIBS_REQUIRED
|
||||
+ # subset of DataExchange
|
||||
+ TKSTEP TKSTEP209 TKSTEPAttr TKSTEPBase TKIGES TKXSBase
|
||||
+ # ModelingAlgorithms
|
||||
+ TKOffset TKFeat TKFillet TKBool TKMesh TKHLR TKBO TKPrim TKShHealing
|
||||
+ TKTopAlgo TKGeomAlgo
|
||||
+ # ModelingData
|
||||
+ TKBRep TKGeomBase TKG3d TKG2d
|
||||
+ # FoundationClasses
|
||||
+ TKMath TKernel)
|
||||
+ endif()
|
||||
if(ENABLE_OCC_TBB)
|
||||
list(APPEND OCC_LIBS_REQUIRED tbb tbbmalloc)
|
||||
endif()
|
||||
@@ -1310,8 +1329,13 @@ if(ENABLE_OCC)
|
||||
if(ENABLE_OCC_CAF)
|
||||
find_package(Freetype)
|
||||
if(FREETYPE_FOUND)
|
||||
- set(OCC_CAF_LIBS_REQUIRED
|
||||
- TKXDESTEP TKXDEIGES TKXCAF TKLCAF TKVCAF TKCAF TKV3d TKService TKCDF)
|
||||
+ if(OCC_VERSION AND OCC_VERSION VERSION_GREATER_EQUAL "7.8.0")
|
||||
+ set(OCC_CAF_LIBS_REQUIRED
|
||||
+ TKXCAF TKLCAF TKVCAF TKCAF TKV3d TKService TKCDF)
|
||||
+ else()
|
||||
+ set(OCC_CAF_LIBS_REQUIRED
|
||||
+ TKXDESTEP TKXDEIGES TKXCAF TKLCAF TKVCAF TKCAF TKV3d TKService TKCDF)
|
||||
+ endif()
|
||||
list(LENGTH OCC_CAF_LIBS_REQUIRED NUM_OCC_CAF_LIBS_REQUIRED)
|
||||
set(OCC_CAF_LIBS)
|
||||
foreach(OCC ${OCC_CAF_LIBS_REQUIRED})
|
||||
@@ -1493,6 +1517,10 @@ if(WALL AND NOT MSVC)
|
||||
# FIXME: remove this when GCC behaves more intelligently
|
||||
set(WF "${WF} -Wno-attributes")
|
||||
endif()
|
||||
+ check_cxx_compiler_flag("-Wno-unused-but-set-variable" WUNUSED)
|
||||
+ if(WUNUSED)
|
||||
+ set(WF "${WF} -Wno-unused-but-set-variable")
|
||||
+ endif()
|
||||
if(WIN32 OR NOT HAVE_64BIT_SIZE_T)
|
||||
# FIXME: remove printf family warnings on 32 bit systems and windows
|
||||
check_cxx_compiler_flag("-Wno-format" WFORMAT)
|
||||
@@ -1768,8 +1796,10 @@ elseif(APPLE)
|
||||
elseif(MSVC)
|
||||
set_target_properties(gmsh PROPERTIES LINK_FLAGS "/STACK:16777216 /SAFESEH:NO")
|
||||
elseif(APPLE)
|
||||
- # this remove ld warnings with PETSc+MUMPS on recent macOS versions
|
||||
- # set_target_properties(gmsh PROPERTIES LINK_FLAGS "-Wl,-no_compact_unwind")
|
||||
+ # this remove ld warnings with PETSc+MUMPS on recent macOS versions; but
|
||||
+ # breaks exception handling
|
||||
+ # set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,-no_compact_unwind")
|
||||
+ # set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,-no_compact_unwind")
|
||||
@@ -834,7 +834,7 @@ if(ENABLE_TINYXML2)
|
||||
endif()
|
||||
|
||||
# android target
|
||||
@@ -2203,9 +2233,6 @@ if(ENABLE_TESTS AND NOT DISABLE_GMSH_TESTS)
|
||||
set(FLAGS "${FLAGS} -mconsole")
|
||||
endif()
|
||||
set_target_properties(${TEST} PROPERTIES LINK_FLAGS "${FLAGS}")
|
||||
- elseif(APPLE)
|
||||
- # this remove ld warnings with PETSc+MUMPS on recent macOS versions
|
||||
- # set_target_properties(${TEST} PROPERTIES LINK_FLAGS "-Wl,-no_compact_unwind")
|
||||
endif()
|
||||
add_test(${TEST} ${TEST} -nopopup)
|
||||
endforeach()
|
||||
@@ -2245,3 +2272,4 @@ mark_as_advanced(ANN_INC ANN_LIB CAIRO_LIB CAIRO_INC C
|
||||
PETSC_LIBS SLEPC_INC SLEPC_INC2 SLEPC_LIB
|
||||
BISON FLEX MAKEINFO TEXI2PDF FLTK_CONFIG_SCRIPT
|
||||
GMSH_EXTERNAL_INCLUDE_DIRS GMSH_EXTERNAL_LIBRARIES)
|
||||
+
|
||||
if(ENABLE_TINYXML2)
|
||||
- find_library(TINYXML2_LIB mathex PATH_SUFFIXES lib)
|
||||
+ find_library(TINYXML2_LIB tinyxml2 PATH_SUFFIXES lib)
|
||||
find_path(TINYXML2_INC "tinyxml2.h" PATH_SUFFIXES src include)
|
||||
if(ENABLE_SYSTEM_CONTRIB AND TINYXML2_LIB AND TINYXML2_INC)
|
||||
list(APPEND EXTERNAL_LIBRARIES ${TINYXML2_LIB})
|
||||
|
|
|
@ -5,3 +5,6 @@ is built around four modules: geometry, mesh, solver and post-processing. The
|
|||
specification of any input to these modules is done either interactively using
|
||||
the graphical user interface or in ASCII text files using Gmsh's own scripting
|
||||
language.
|
||||
|
||||
See also <https://www.geuz.org/gmsh/>
|
||||
and <https://gitlab.onelab.info/gmsh/gmsh>.
|
||||
|
|
|
@ -1,5 +1,15 @@
|
|||
bin/gmsh
|
||||
bin/onelab.py
|
||||
include/gmsh.f90
|
||||
include/gmsh.h
|
||||
include/gmsh.h_cwrap
|
||||
include/gmshc.h
|
||||
lib/gmsh-%%VER%%.dev1.dist-info/METADATA
|
||||
lib/gmsh.jl
|
||||
lib/gmsh.py
|
||||
lib/libgmsh.so
|
||||
lib/libgmsh.so.%%VE%%
|
||||
lib/libgmsh.so.%%VER%%
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CREDITS.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
|
||||
|
@ -17,12 +27,14 @@ bin/onelab.py
|
|||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/bspline_bezier_patches.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/bspline_bezier_trimmed.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/bspline_filling.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/circle_arc.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/closest_point.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/copy_mesh.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/crack.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/crack3d.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/custom_gui.cpp
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/custom_gui.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/cylinderFFD.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/discrete.cpp
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/discrete.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/discrete.py
|
||||
|
@ -51,6 +63,7 @@ bin/onelab.py
|
|||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/mesh_from_discrete_curve.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/mesh_quality.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/mirror_mesh.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/msh_attributes.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/multi_process.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/multi_thread.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/naca_boundary_layer_2d.py
|
||||
|
@ -79,7 +92,10 @@ bin/onelab.py
|
|||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/prim_axis.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/raw_tetrahedralization.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/raw_triangulation.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/relocate_nodes.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/remesh_stl.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/remove_elements.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/renumbering.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/reparamOnFace.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/select_elements.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/simple.c
|
||||
|
@ -95,6 +111,8 @@ bin/onelab.py
|
|||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/step_assembly.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/step_boundary_colors.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/step_boundary_colors.stp
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/step_header_data.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/step_header_data.stp
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/stl_to_brep.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/stl_to_mesh.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/surface1.stl
|
||||
|
@ -111,7 +129,9 @@ bin/onelab.py
|
|||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/tube_boundary_layer.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/view.cpp
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/view.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/view_adaptive_to_mesh.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/view_combine.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/view_element_size.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/view_renumbering.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/viewlist.cpp
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/api/viewlist.py
|
||||
|
@ -140,6 +160,7 @@ bin/onelab.py
|
|||
%%PORTDOCS%%%%DOCSDIR%%/examples/boolean/import.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/boolean/import2.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/boolean/intersect_line_volume.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/boolean/mesh_size_per_volume.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/boolean/neuron.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/boolean/number_of_tets.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/boolean/periodic.geo
|
||||
|
@ -208,6 +229,36 @@ bin/onelab.py
|
|||
%%PORTDOCS%%%%DOCSDIR%%/examples/simple_geo/transfinite.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/struct/Exists_GetForced.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/examples/struct/struct.geo
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/gui.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/gui_add_rectangle.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/gui_mesh.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/t1.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/t10.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/t11.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/t12.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/t13.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/t14.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/t15.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/t16.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/t17.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/t18.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/t19.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/t2.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/t20.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/t21.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/t3.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/t4.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/t5.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/t6.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/t7.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/t8.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/t9.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/x1.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/x2.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/x3.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/x4.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/x5.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/images/x7.png
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/README.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/c++/README.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/c++/t1.cpp
|
||||
|
@ -268,12 +319,32 @@ bin/onelab.py
|
|||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/README.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/t1.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/t10.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/t11.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/t12.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/t13.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/t14.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/t15.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/t16.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/t17.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/t18.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/t19.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/t2.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/t20.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/t21.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/t3.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/t4.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/t5.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/t6.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/t7.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/t8.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/t9.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/x1.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/x2.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/x3.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/x4.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/x5.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/x6.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/julia/x7.jl
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/python/README.txt
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/python/t1.py
|
||||
%%PORTDOCS%%%%DOCSDIR%%/tutorials/python/t10.py
|
||||
|
|
Loading…
Add table
Reference in a new issue