mirror of
https://git.freebsd.org/ports.git
synced 2025-05-25 07:26:29 -04:00
Adding OpenKIM, an application programming interface (API) for
coupling atomistic simulation codes and interatomic potential subroutines. PR: ports/177692 Submitted by: Jason Bacon <jwbacon (at) tds.net>
This commit is contained in:
parent
d1c07899da
commit
52d72cd2b8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=345491
6 changed files with 79 additions and 0 deletions
|
@ -110,6 +110,7 @@
|
||||||
SUBDIR += netcdf4
|
SUBDIR += netcdf4
|
||||||
SUBDIR += nifticlib
|
SUBDIR += nifticlib
|
||||||
SUBDIR += openbabel
|
SUBDIR += openbabel
|
||||||
|
SUBDIR += openkim
|
||||||
SUBDIR += p5-Algorithm-SVMLight
|
SUBDIR += p5-Algorithm-SVMLight
|
||||||
SUBDIR += p5-Chemistry-3DBuilder
|
SUBDIR += p5-Chemistry-3DBuilder
|
||||||
SUBDIR += p5-Chemistry-Bond-Find
|
SUBDIR += p5-Chemistry-Bond-Find
|
||||||
|
|
51
science/openkim/Makefile
Normal file
51
science/openkim/Makefile
Normal file
|
@ -0,0 +1,51 @@
|
||||||
|
# Created by: Jason Bacon
|
||||||
|
# $FreeBSD$
|
||||||
|
|
||||||
|
PORTNAME= openkim
|
||||||
|
PORTVERSION= 1.1.1
|
||||||
|
CATEGORIES= science
|
||||||
|
MASTER_SITES= http://s3.openkim.org/openkim-api/
|
||||||
|
DISTNAME= ${PORTNAME}-api-v${PORTVERSION}
|
||||||
|
EXTRACT_SUFX= .tgz
|
||||||
|
|
||||||
|
MAINTAINER= jwbacon@tds.net
|
||||||
|
COMMENT= Knowledgebase of Interatomic Models
|
||||||
|
|
||||||
|
LICENSE= CDDL
|
||||||
|
|
||||||
|
MAKE_ENV+= KIM_DIR=${WRKSRC}
|
||||||
|
|
||||||
|
USES= gmake fortran
|
||||||
|
|
||||||
|
MAKE_JOBS_UNSAFE=yes
|
||||||
|
|
||||||
|
.include <bsd.port.options.mk>
|
||||||
|
|
||||||
|
# Is there a better way to detect 32-bit systems?
|
||||||
|
.if ${ARCH} == "i386" || ${ARCH} == "powerpc"
|
||||||
|
MAKE_ENV+= KIM_SYSTEM32="yes"
|
||||||
|
.endif
|
||||||
|
|
||||||
|
post-patch:
|
||||||
|
${REINPLACE_CMD} \
|
||||||
|
-e "s|gcc|${CC}|g" \
|
||||||
|
-e "s|g++|${CXX}|g" \
|
||||||
|
-e "s|= gfortran|= ${FC}|g" \
|
||||||
|
-e "s|-O3|${CFLAGS}|g" \
|
||||||
|
-e "s|LINKLIBFLAG =|LINKLIBFLAG = ${LDFLAGS}|" \
|
||||||
|
${WRKSRC}/KIM_API/GNU_compiler_settings.mk
|
||||||
|
|
||||||
|
# Required for main build to succeed
|
||||||
|
pre-build:
|
||||||
|
(cd ${WRKSRC} && ${MAKE_CMD} KIM_DIR=${WRKSRC} examples)
|
||||||
|
|
||||||
|
do-install:
|
||||||
|
${MKDIR} ${STAGEDIR}${PREFIX}/lib ${STAGEDIR}${PREFIX}/include/KIM_API
|
||||||
|
${INSTALL_DATA} ${WRKSRC}/KIM_API/libkim.a ${STAGEDIR}${PREFIX}/lib
|
||||||
|
${INSTALL_DATA} ${WRKSRC}/KIM_API/*.h ${STAGEDIR}${PREFIX}/include/KIM_API
|
||||||
|
|
||||||
|
regression-test:
|
||||||
|
(cd ${WRKSRC}/TESTs/ex_test_Ar_free_cluster_CLUSTER_F90 && \
|
||||||
|
${ECHO_CMD} "ex_model_Ar_P_MLJ_CLUSTER_C" | ./ex_test_Ar_free_cluster_CLUSTER_F90)
|
||||||
|
|
||||||
|
.include <bsd.port.mk>
|
2
science/openkim/distinfo
Normal file
2
science/openkim/distinfo
Normal file
|
@ -0,0 +1,2 @@
|
||||||
|
SHA256 (openkim-api-v1.1.1.tgz) = 683bda8011754b2525e6f935f52909c141e9d39c2184cefb98babb9e4e5e0959
|
||||||
|
SIZE (openkim-api-v1.1.1.tgz) = 1529043
|
|
@ -0,0 +1,10 @@
|
||||||
|
--- KIM_API/GNU_compiler_settings.mk.orig 2012-08-19 23:13:47.000000000 +0200
|
||||||
|
+++ KIM_API/GNU_compiler_settings.mk 2014-02-21 16:11:02.000000000 +0100
|
||||||
|
@@ -53,7 +53,3 @@
|
||||||
|
# Add libforgranbegin if needed.
|
||||||
|
LINKLIBFLAG += -lgfortranbegin
|
||||||
|
endif
|
||||||
|
-ifdef KIM_DYNAMIC
|
||||||
|
- # Add libdl if dynamic linking is being used
|
||||||
|
- LINKLIBFLAG += -ldl
|
||||||
|
-endif
|
6
science/openkim/pkg-descr
Normal file
6
science/openkim/pkg-descr
Normal file
|
@ -0,0 +1,6 @@
|
||||||
|
An online resource for standardized testing and long-term warehousing of
|
||||||
|
interatomic models and data. This includes the development of application
|
||||||
|
programming interface (API) standards for coupling atomistic simulation
|
||||||
|
codes and interatomic potential subroutines.
|
||||||
|
|
||||||
|
WWW: https://openkim.org/
|
9
science/openkim/pkg-plist
Normal file
9
science/openkim/pkg-plist
Normal file
|
@ -0,0 +1,9 @@
|
||||||
|
include/KIM_API/KIM_API.h
|
||||||
|
include/KIM_API/KIM_API_C.h
|
||||||
|
include/KIM_API/KIM_API_status.h
|
||||||
|
include/KIM_API/KIM_AUX.h
|
||||||
|
include/KIM_API/Unit_Handling.h
|
||||||
|
include/KIM_API/model_init_include.h
|
||||||
|
include/KIM_API/model_kim_str_include.h
|
||||||
|
lib/libkim.a
|
||||||
|
@dirrm include/KIM_API
|
Loading…
Add table
Reference in a new issue