mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
sysutils/dtc: Update to 1.7.1
* Convert to Meson * Import upstream PR 141 [1] 1: https://github.com/dgibson/dtc/pull/141 Changelog: https://github.com/dgibson/dtc/releases/tag/v1.7.1 PR: 281891 Approved by: portmgr (maintainer timeout, 2+ weeks)
This commit is contained in:
parent
d7d0d39091
commit
4eecaf5e73
4 changed files with 19 additions and 28 deletions
|
@ -1,10 +1,10 @@
|
||||||
PORTNAME= dtc
|
PORTNAME= dtc
|
||||||
PORTVERSION= 1.6.0
|
|
||||||
DISTVERSIONPREFIX= v
|
DISTVERSIONPREFIX= v
|
||||||
|
DISTVERSION= 1.7.1
|
||||||
CATEGORIES= sysutils
|
CATEGORIES= sysutils
|
||||||
|
|
||||||
PATCH_SITES= https://github.com/dgibson/dtc/commit/
|
PATCH_SITES= https://github.com/dgibson/dtc/commit/
|
||||||
PATCHFILES+= ca19c3db2b.patch:-p1 # https://github.com/dgibson/dtc/pull/41
|
PATCHFILES= 1b75550436433e150164715dedb417e4d234df6c.patch:-p1
|
||||||
|
|
||||||
MAINTAINER= uboot@FreeBSD.org
|
MAINTAINER= uboot@FreeBSD.org
|
||||||
COMMENT= Device Tree Compiler
|
COMMENT= Device Tree Compiler
|
||||||
|
@ -14,18 +14,20 @@ LICENSE= GPLv2
|
||||||
|
|
||||||
LIB_DEPENDS= libyaml.so:textproc/libyaml
|
LIB_DEPENDS= libyaml.so:textproc/libyaml
|
||||||
|
|
||||||
USES= bison compiler:c11 cpe gmake pkgconfig shebangfix
|
USES= bison compiler:c11 cpe meson pkgconfig shebangfix
|
||||||
CPE_VENDOR= ${PORTNAME}_project
|
CPE_VENDOR= ${PORTNAME}_project
|
||||||
|
SHEBANG_FILES= dtdiff
|
||||||
|
USE_LDCONFIG= yes
|
||||||
|
|
||||||
USE_GITHUB= yes
|
USE_GITHUB= yes
|
||||||
GH_ACCOUNT= dgibson
|
GH_ACCOUNT= dgibson
|
||||||
USE_LDCONFIG= yes
|
|
||||||
SHEBANG_FILES= dtdiff
|
|
||||||
|
|
||||||
TEST_TARGET= check
|
MESON_ARGS= --default-library=shared \
|
||||||
TEST_ENV= STATSZ="stat -f %Uz"
|
-Dpython=disabled \
|
||||||
|
-Dvalgrind=disabled
|
||||||
|
|
||||||
MAKE_ARGS+= PREFIX=${PREFIX} NO_PYTHON=yes \
|
OPTIONS_DEFINE= TEST
|
||||||
INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
|
|
||||||
INSTALL_LIB="${INSTALL_LIB}"
|
TEST_MESON_TRUE= tests
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
.include <bsd.port.mk>
|
||||||
|
|
|
@ -1,5 +1,5 @@
|
||||||
TIMESTAMP = 1598352412
|
TIMESTAMP = 1728145110
|
||||||
SHA256 (dgibson-dtc-v1.6.0_GH0.tar.gz) = 3d15dee7126a6c4a015ab47ec908cab13e39774b0315efaaebb223cb4a4d349c
|
SHA256 (dgibson-dtc-v1.7.1_GH0.tar.gz) = c4c4a47b8af98ad81c488d934da051f28bd2d0143a4622ea14d1920bc8c90f75
|
||||||
SIZE (dgibson-dtc-v1.6.0_GH0.tar.gz) = 200316
|
SIZE (dgibson-dtc-v1.7.1_GH0.tar.gz) = 216960
|
||||||
SHA256 (ca19c3db2b.patch) = 0026f5ece39859bbd5ad7a9bc6d7c4dd3fb2ff85b35bf88c2dd227cfdb28c9b4
|
SHA256 (1b75550436433e150164715dedb417e4d234df6c.patch) = 01ce4fcd2b0101a582bde67f372a29d9470e7ebb86f8e98785a90435f520047c
|
||||||
SIZE (ca19c3db2b.patch) = 735
|
SIZE (1b75550436433e150164715dedb417e4d234df6c.patch) = 4569
|
||||||
|
|
|
@ -1,11 +0,0 @@
|
||||||
--- libfdt/fdt_rw.c.orig 2020-03-04 06:14:58 UTC
|
|
||||||
+++ libfdt/fdt_rw.c
|
|
||||||
@@ -435,7 +435,7 @@ int fdt_open_into(const void *fdt, void *buf, int bufs
|
|
||||||
return struct_size;
|
|
||||||
}
|
|
||||||
|
|
||||||
- if (can_assume(LIBFDT_ORDER) |
|
|
||||||
+ if (can_assume(LIBFDT_ORDER) ||
|
|
||||||
!fdt_blocks_misordered_(fdt, mem_rsv_size, struct_size)) {
|
|
||||||
/* no further work necessary */
|
|
||||||
err = fdt_move(fdt, buf, bufsize);
|
|
|
@ -8,7 +8,7 @@ bin/fdtput
|
||||||
include/fdt.h
|
include/fdt.h
|
||||||
include/libfdt.h
|
include/libfdt.h
|
||||||
include/libfdt_env.h
|
include/libfdt_env.h
|
||||||
lib/libfdt-1.6.0.so
|
|
||||||
lib/libfdt.a
|
|
||||||
lib/libfdt.so
|
lib/libfdt.so
|
||||||
lib/libfdt.so.1
|
lib/libfdt.so.1
|
||||||
|
lib/libfdt.so.1.7.1
|
||||||
|
libdata/pkgconfig/libfdt.pc
|
||||||
|
|
Loading…
Add table
Reference in a new issue