mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 09:36:41 -04:00
multimedia/libmtp: Update to 1.1.22
* Revert upstream commit aa45292de4e9047ff38bb5da79f896709aa0293a as new API isn't implemented in FreeBSD's libusb * Do some slight rearrangement of port Makefile PR: 283020 Approved by: desktop (arrowd)
This commit is contained in:
parent
bec50be298
commit
4e60b6b06e
3 changed files with 33 additions and 15 deletions
|
@ -1,28 +1,35 @@
|
|||
PORTNAME= libmtp
|
||||
PORTVERSION= 1.1.18
|
||||
DISTVERSION= 1.1.22
|
||||
CATEGORIES= multimedia audio
|
||||
MASTER_SITES= SF
|
||||
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/v${DISTVERSION}/ \
|
||||
SF
|
||||
|
||||
MAINTAINER= desktop@FreeBSD.org
|
||||
COMMENT= Media Transfer Protocol (MTP) library
|
||||
WWW= https://libmtp.sourceforge.net/
|
||||
WWW= https://github.com/libmtp/libmtp
|
||||
|
||||
LICENSE= LGPL21+
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
CONFLICTS_INSTALL=libosmo-sccp # lib/libmtp.a
|
||||
|
||||
USES= cpe iconv libtool localbase pathfix pkgconfig
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --disable-doxygen
|
||||
INSTALL_TARGET= install-strip
|
||||
USE_LDCONFIG= yes
|
||||
USES= cpe gmake iconv libtool localbase pathfix pkgconfig
|
||||
CPE_VENDOR= libmtp_project
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
CONFIGURE_ARGS= --disable-doxygen \
|
||||
--disable-rpath
|
||||
|
||||
OPTIONS_DEFINE= MTPZ
|
||||
OPTIONS_DEFAULT=MTPZ
|
||||
|
||||
MTPZ_DESC= Enable functionality to connect to MTPZ devices
|
||||
MTPZ_CONFIGURE_ENABLE= mtpz
|
||||
|
||||
MTPZ_LIB_DEPENDS= libgcrypt.so:security/libgcrypt
|
||||
MTPZ_CONFIGURE_ENABLE= mtpz
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
TIMESTAMP = 1602415737
|
||||
SHA256 (libmtp-1.1.18.tar.gz) = 7280fe50c044c818a06667f45eabca884deab3193caa8682e0b581e847a281f0
|
||||
SIZE (libmtp-1.1.18.tar.gz) = 832463
|
||||
TIMESTAMP = 1732363669
|
||||
SHA256 (libmtp-1.1.22.tar.gz) = c3fcf411aea9cb9643590cbc9df99fa5fe30adcac695024442973d76fa5f87bc
|
||||
SIZE (libmtp-1.1.22.tar.gz) = 900914
|
||||
|
|
|
@ -2,14 +2,25 @@ Reset libusb_context for successive init_usb() calls instead of error
|
|||
|
||||
https://github.com/phatina/simple-mtpfs/issues/37
|
||||
|
||||
--- src/libusb1-glue.c.orig 2015-04-09 21:10:06 UTC
|
||||
--- src/libusb1-glue.c.orig 2023-12-21 08:27:04 UTC
|
||||
+++ src/libusb1-glue.c
|
||||
@@ -142,7 +142,7 @@ static LIBMTP_error_number_t init_usb()
|
||||
@@ -153,7 +153,7 @@ static LIBMTP_error_number_t init_usb()
|
||||
* We use the same level debug between MTP and USB.
|
||||
*/
|
||||
if (libusb1_initialized)
|
||||
- return LIBMTP_ERROR_NONE;
|
||||
+ libusb_exit(NULL);
|
||||
|
||||
if (libusb_init(NULL) < 0) {
|
||||
if (libusb_init(&libmtp_libusb_context) < 0) {
|
||||
LIBMTP_ERROR("Libusb1 init failed\n");
|
||||
@@ -163,8 +163,8 @@ static LIBMTP_error_number_t init_usb()
|
||||
libusb1_initialized = 1;
|
||||
|
||||
if ((LIBMTP_debug & LIBMTP_DEBUG_USB) != 0)
|
||||
- /*libusb_set_debug(libmtp_libusb_context,9);*/
|
||||
- libusb_set_option(libmtp_libusb_context, LIBUSB_OPTION_LOG_LEVEL, LIBUSB_LOG_LEVEL_DEBUG ); /* highest level */
|
||||
+ libusb_set_debug(libmtp_libusb_context,9);
|
||||
+ // libusb_set_option(libmtp_libusb_context, LIBUSB_OPTION_LOG_LEVEL, LIBUSB_LOG_LEVEL_DEBUG ); /* highest level */
|
||||
return LIBMTP_ERROR_NONE;
|
||||
}
|
||||
|
||||
|
|
Loading…
Add table
Reference in a new issue