net/realtek-re-kmod: fix build on FreeBSD 15.

I've opted for the simplest patch, the inclusion of if_private.h,
instead of a more invasive switch to IfAPI, to keep minimal changes
to vendor branch, hoping in a next vendor update to it.
This commit is contained in:
Alex Dupre 2024-11-28 10:10:44 +01:00
parent e18afbb46f
commit 4ca9ea9d40
2 changed files with 16 additions and 0 deletions

View file

@ -19,6 +19,12 @@ GH_ACCOUNT= alexdupre
GH_PROJECT= rtl_bsd_drv GH_PROJECT= rtl_bsd_drv
GH_TAGNAME= ea4ed1e GH_TAGNAME= ea4ed1e
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && (${OSVERSION} >= 1500000)
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-if__re.c
.endif
PLIST_FILES= ${KMODDIR}/if_re.ko PLIST_FILES= ${KMODDIR}/if_re.ko
.include <bsd.port.mk> .include <bsd.port.mk>

View file

@ -0,0 +1,10 @@
--- if_re.c.orig 2024-06-04 09:39:04 UTC
+++ if_re.c
@@ -67,6 +67,7 @@ __FBSDID("$FreeBSD: src/sys/dev/re/if_re.c,v " RE_VERS
#include <net/if.h>
#include <net/if_var.h>
+#include <net/if_private.h>
#include <net/if_arp.h>
#include <net/ethernet.h>
#include <net/if_dl.h>