mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
graphics/gimp-app: patch configure.ac instead of configure
This makes importing upstream commits or merge requests easier in addition to keeping track of our changes. Pre-generated configure scripts are only present in release tarballs, but all modifications after/separate from the fact only happen in configure.ac, so generate the configure script every time.
This commit is contained in:
parent
1ce890d549
commit
4a2804d130
3 changed files with 49 additions and 37 deletions
|
@ -14,9 +14,9 @@ LICENSE= GPLv3 LGPL3
|
|||
LICENSE_COMB= multi
|
||||
|
||||
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes \
|
||||
gtkdocize:textproc/gtk-doc \
|
||||
glib-networking>=0:net/glib-networking \
|
||||
mypaint-brushes>0:graphics/mypaint-brushes
|
||||
|
||||
LIB_DEPENDS= libasound.so:audio/alsa-lib \
|
||||
libbabl-0.1.so:x11/babl \
|
||||
libfontconfig.so:x11-fonts/fontconfig \
|
||||
|
@ -44,8 +44,8 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes \
|
|||
glib-networking>=0:net/glib-networking \
|
||||
mypaint-brushes>0:graphics/mypaint-brushes
|
||||
|
||||
USES= cpe compiler:c++14-lang desktop-file-utils gettext gmake gnome \
|
||||
jpeg libtool localbase pkgconfig shebangfix tar:bzip2 xorg
|
||||
USES= autoreconf:2.69 cpe compiler:c++14-lang desktop-file-utils gettext gmake \
|
||||
gnome jpeg libtool localbase pkgconfig shebangfix tar:bzip2 xorg
|
||||
CPE_VENDOR= gimp
|
||||
CPE_PRODUCT= gimp
|
||||
USE_GNOME+= cairo gtk20 intltool librsvg2
|
||||
|
@ -132,6 +132,6 @@ post-patch:
|
|||
${WRKSRC}/plug-ins/pygimp/Makefile.in
|
||||
@${REINPLACE_CMD} \
|
||||
-e 's|x86_64|amd64|g' \
|
||||
${WRKSRC}/configure
|
||||
${WRKSRC}/configure.ac
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
|
|
@ -1,33 +0,0 @@
|
|||
--- configure.orig 2024-05-03 00:36:33 UTC
|
||||
+++ configure
|
||||
@@ -30417,13 +30417,13 @@ if test "x$have_libheif" = xyes; then
|
||||
can_import_avif=no
|
||||
can_export_avif=no
|
||||
if test "x$have_libheif" = xyes; then
|
||||
- can_import_heic=`$PKG_CONFIG --variable=builtin_h265_decoder libheif`
|
||||
- can_export_heic=`$PKG_CONFIG --variable=builtin_h265_encoder libheif`
|
||||
+ can_import_heic=yes
|
||||
+ can_export_heic=yes
|
||||
if test "x$can_import_heic" = xyes; then
|
||||
MIME_TYPES="$MIME_TYPES;image/heif;image/heic"
|
||||
fi
|
||||
- can_import_avif=`$PKG_CONFIG --variable=builtin_avif_decoder libheif`
|
||||
- can_export_avif=`$PKG_CONFIG --variable=builtin_avif_encoder libheif`
|
||||
+ can_import_avif=yes
|
||||
+ can_export_avif=yes
|
||||
if test "x$can_import_avif" = xyes; then
|
||||
MIME_TYPES="$MIME_TYPES;image/avif"
|
||||
fi
|
||||
@@ -34797,9 +34797,9 @@ esac
|
||||
;;
|
||||
esac
|
||||
|
||||
-gimpdatadir="$datadir/$PACKAGE/2.0"
|
||||
-gimpplugindir="$libdir/$PACKAGE/2.0"
|
||||
-gimpsysconfdir="$sysconfdir/$PACKAGE/2.0"
|
||||
+gimpdatadir="$datadir/$PACKAGE"
|
||||
+gimpplugindir="$libexecdir/$PACKAGE/2.2"
|
||||
+gimpsysconfdir="$sysconfdir/$PACKAGE/2.2"
|
||||
|
||||
|
||||
|
45
graphics/gimp-app/files/patch-configure.ac
Normal file
45
graphics/gimp-app/files/patch-configure.ac
Normal file
|
@ -0,0 +1,45 @@
|
|||
--- configure.ac.orig 2025-03-12 15:49:07 UTC
|
||||
+++ configure.ac
|
||||
@@ -28,11 +28,11 @@ m4_define([gimp_app_version], [2.10])
|
||||
# Versions used for apps, plugins, tools, pkg-config files, and data,
|
||||
# as well as global and user prefs
|
||||
m4_define([gimp_app_version], [2.10])
|
||||
-m4_define([gimp_plugin_version], [2.0])
|
||||
+m4_define([gimp_plugin_version], [2.2])
|
||||
m4_define([gimp_tool_version], [2.0])
|
||||
m4_define([gimp_pkgconfig_version], [2.0])
|
||||
m4_define([gimp_data_version], [2.0])
|
||||
-m4_define([gimp_sysconf_version], [2.0])
|
||||
+m4_define([gimp_sysconf_version], [2.2])
|
||||
m4_define([gimp_user_version], [2.10])
|
||||
|
||||
m4_define([gimp_unstable],
|
||||
@@ -1843,13 +1843,13 @@ if test "x$have_libheif" = xyes; then
|
||||
can_import_avif=no
|
||||
can_export_avif=no
|
||||
if test "x$have_libheif" = xyes; then
|
||||
- can_import_heic=`$PKG_CONFIG --variable=builtin_h265_decoder libheif`
|
||||
- can_export_heic=`$PKG_CONFIG --variable=builtin_h265_encoder libheif`
|
||||
+ can_import_heic=yes
|
||||
+ can_export_heic=yes
|
||||
if test "x$can_import_heic" = xyes; then
|
||||
MIME_TYPES="$MIME_TYPES;image/heif;image/heic"
|
||||
fi
|
||||
- can_import_avif=`$PKG_CONFIG --variable=builtin_avif_decoder libheif`
|
||||
- can_export_avif=`$PKG_CONFIG --variable=builtin_avif_encoder libheif`
|
||||
+ can_import_avif=yes
|
||||
+ can_export_avif=yes
|
||||
if test "x$can_import_avif" = xyes; then
|
||||
MIME_TYPES="$MIME_TYPES;image/avif"
|
||||
fi
|
||||
@@ -2765,8 +2765,8 @@ esac
|
||||
;;
|
||||
esac
|
||||
|
||||
-gimpdatadir="$datadir/$PACKAGE/gimp_data_version"
|
||||
-gimpplugindir="$libdir/$PACKAGE/gimp_plugin_version"
|
||||
+gimpdatadir="$datadir/$PACKAGE"
|
||||
+gimpplugindir="$libexecdir/$PACKAGE/gimp_plugin_version"
|
||||
gimpsysconfdir="$sysconfdir/$PACKAGE/gimp_sysconf_version"
|
||||
|
||||
AC_SUBST(gimpdir)
|
Loading…
Add table
Reference in a new issue