comms/flwrap: Update version 1.3.5=>1.3.6

- Fix build with llvm16

Sponsored by:	The FreeBSD Foundation
This commit is contained in:
Muhammad Moinur Rahman 2023-07-21 16:13:53 +02:00
parent eec565a2d9
commit 47be664eb3
3 changed files with 5 additions and 21 deletions

View file

@ -1,5 +1,5 @@
PORTNAME= flwrap PORTNAME= flwrap
PORTVERSION= 1.3.5 PORTVERSION= 1.3.6
CATEGORIES= comms hamradio CATEGORIES= comms hamradio
MASTER_SITES= SF/fldigi/${PORTNAME} MASTER_SITES= SF/fldigi/${PORTNAME}
@ -22,7 +22,7 @@ post-configure:
@${REINPLACE_CMD} -e 's|^CPPFLAGS|#CPPFLAGS|' \ @${REINPLACE_CMD} -e 's|^CPPFLAGS|#CPPFLAGS|' \
${WRKSRC}/src/Makefile ${WRKSRC}/src/Makefile
post-install: post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR} @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR} ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1555663674 TIMESTAMP = 1689948480
SHA256 (flwrap-1.3.5.tar.gz) = efde2b3011c4394cccf046ce8b3f3b7360e1a7eb809c42e4796cab3c27de1163 SHA256 (flwrap-1.3.6.tar.gz) = 83557b6ce720547a43f8d767d36363e08deb188b6e436a8b1a5ad966c85f18ff
SIZE (flwrap-1.3.5.tar.gz) = 200807 SIZE (flwrap-1.3.6.tar.gz) = 205412

View file

@ -1,16 +0,0 @@
- fix the error: ./include/base64.h:24:2: error: reference to 'byte' is ambiguous
- the alternative 'byte' definition is std::byte
--- src/include/base64.h.orig 2023-07-16 16:44:53 UTC
+++ src/include/base64.h
@@ -21,8 +21,8 @@ class base64 { (private)
size_t iolen;
size_t iocp;
bool ateof;
- byte dtable[256];
- byte etable[256];
+ ::byte dtable[256];
+ ::byte etable[256];
int linelength;
bool crlf;
void init();