devel/py-posix_ipc: Update version 1.1.1=>1.2.0

Changelog: https://github.com/osvenskan/posix_ipc/releases/tag/rel1.2.0
This commit is contained in:
Muhammad Moinur Rahman 2025-04-17 08:46:17 +02:00
parent cbe041e7ca
commit 46c47af6cd
No known key found for this signature in database
GPG key ID: BDB9B5A617C0BC91
3 changed files with 18 additions and 17 deletions

View file

@ -1,6 +1,5 @@
PORTNAME= posix_ipc
PORTVERSION= 1.1.1
PORTREVISION= 1
DISTVERSION= 1.2.0
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -12,8 +11,11 @@ WWW= https://semanchuk.com/philip/posix_ipc/
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PY_SETUPTOOLS} \
${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
USES= python
USE_PYTHON= distutils autoplist
USE_PYTHON= autoplist pep517
post-install:
${STRIP_CMD} ${STAGEDIR}/${PYTHONPREFIX_SITELIBDIR}/posix_ipc*.so

View file

@ -1,3 +1,3 @@
TIMESTAMP = 1682272449
SHA256 (posix_ipc-1.1.1.tar.gz) = e2456ba0cfb2ee5ba14121450e8d825b3c4a1461fca0761220aab66d4111cbb7
SIZE (posix_ipc-1.1.1.tar.gz) = 94341
TIMESTAMP = 1744872086
SHA256 (posix_ipc-1.2.0.tar.gz) = b7444e2703c156b3cb9fcb568e85d716232f3e78f04529ebc881cfb2aedb3838
SIZE (posix_ipc-1.2.0.tar.gz) = 95859

View file

@ -1,18 +1,17 @@
--- setup.py.orig 2018-08-07 00:29:38 UTC
--- setup.py.orig 2025-04-16 23:35:26 UTC
+++ setup.py
@@ -39,6 +39,7 @@ license = "http://creativecommons.org/licenses/BSD/"
keywords = "ipc inter-process communication semaphore shared memory shm message queue"
@@ -19,6 +19,7 @@ libraries = []
DEPENDS = ["src/posix_ipc_module.c", "src/system_info.h"]
libraries = []
+test_suite = "tests"
d = prober.probe()
system_info = build_support.discover_system_info.discover()
@@ -69,5 +70,6 @@ distutools.setup(name=name,
classifiers=classifiers,
license=license,
keywords=keywords,
- ext_modules=ext_modules
+ ext_modules=ext_modules,
+ test_suite=test_suite
@@ -36,5 +37,6 @@ setuptools.setup(ext_modules=ext_modules,
)]
setuptools.setup(ext_modules=ext_modules,
+ test_suite=test_suite,
license=LICENSE,
)