mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 17:46:38 -04:00
multimedia/deforaos-camera: New port: Simple webcam viewer
DeforaOS-Camera is a simple webcam viewer, which can be used to take pictures from still frames. Reviewed by: jrm Sponsored by: The FreeBSD Foundation Differential Revision: https://reviews.freebsd.org/D49085
This commit is contained in:
parent
8447b93f36
commit
45d32e1e64
6 changed files with 89 additions and 0 deletions
|
@ -35,6 +35,7 @@
|
||||||
SUBDIR += cx88
|
SUBDIR += cx88
|
||||||
SUBDIR += dav1d
|
SUBDIR += dav1d
|
||||||
SUBDIR += decord
|
SUBDIR += decord
|
||||||
|
SUBDIR += deforaos-camera
|
||||||
SUBDIR += deforaos-player
|
SUBDIR += deforaos-player
|
||||||
SUBDIR += dirac
|
SUBDIR += dirac
|
||||||
SUBDIR += dovi_tool
|
SUBDIR += dovi_tool
|
||||||
|
|
48
multimedia/deforaos-camera/Makefile
Normal file
48
multimedia/deforaos-camera/Makefile
Normal file
|
@ -0,0 +1,48 @@
|
||||||
|
PORTNAME= camera
|
||||||
|
PORTVERSION= 0.3.1
|
||||||
|
CATEGORIES= multimedia
|
||||||
|
MASTER_SITES= https://ftp.defora.org/pub/DeforaOS/Apps/Desktop/src/Camera/
|
||||||
|
PKGNAMEPREFIX= deforaos-
|
||||||
|
DISTNAME= Camera-${PORTVERSION}
|
||||||
|
|
||||||
|
MAINTAINER= khorben@defora.org
|
||||||
|
COMMENT= DeforaOS desktop photo camera
|
||||||
|
WWW= https://www.defora.org/
|
||||||
|
|
||||||
|
LICENSE= BSD2CLAUSE
|
||||||
|
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||||
|
|
||||||
|
BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat \
|
||||||
|
${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl:textproc/docbook-xsl \
|
||||||
|
xsltproc:textproc/libxslt
|
||||||
|
LIB_DEPENDS= libDesktop.so:x11/deforaos-libdesktop \
|
||||||
|
libSystem.so:devel/deforaos-libsystem \
|
||||||
|
libX11.so:x11/libX11
|
||||||
|
RUN_DEPENDS= deforaos-browser:x11-fm/deforaos-browser
|
||||||
|
|
||||||
|
USES= gnome pkgconfig xorg
|
||||||
|
USE_GNOME= gtk30
|
||||||
|
USE_XORG= x11
|
||||||
|
|
||||||
|
MAKE_ARGS+= CPPFLAGS=-DPROGNAME_BROWSER=\\\"deforaos-browser\\\" \
|
||||||
|
PREFIX=${PREFIX}
|
||||||
|
MAKE_ENV+= MANDIR=${STAGEDIR}${PREFIX}/share/man
|
||||||
|
|
||||||
|
OPTIONS_DEFINE= DOCS NLS
|
||||||
|
OPTIONS_SUB= yes
|
||||||
|
NLS_USES= gettext
|
||||||
|
|
||||||
|
post-patch-DOCS-off:
|
||||||
|
${REINPLACE_CMD} 's|= data doc |= data |' \
|
||||||
|
${WRKSRC}/Makefile
|
||||||
|
|
||||||
|
post-patch-NLS-off:
|
||||||
|
${REINPLACE_CMD} 's| po src | src |' \
|
||||||
|
${WRKSRC}/Makefile
|
||||||
|
|
||||||
|
post-install: compress-man
|
||||||
|
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/camera \
|
||||||
|
${STAGEDIR}${PREFIX}/bin/gallery \
|
||||||
|
${STAGEDIR}${PREFIX}/lib/Desktop/widget/camera.so
|
||||||
|
|
||||||
|
.include <bsd.port.mk>
|
3
multimedia/deforaos-camera/distinfo
Normal file
3
multimedia/deforaos-camera/distinfo
Normal file
|
@ -0,0 +1,3 @@
|
||||||
|
TIMESTAMP = 1740447675
|
||||||
|
SHA256 (Camera-0.3.1.tar.gz) = 7a17ad11a5588ae8edd72abb6b1770bf23e1b8bab3166c6edb498b07b3aaa95b
|
||||||
|
SIZE (Camera-0.3.1.tar.gz) = 30211
|
23
multimedia/deforaos-camera/files/patch-doc_Makefile
Normal file
23
multimedia/deforaos-camera/files/patch-doc_Makefile
Normal file
|
@ -0,0 +1,23 @@
|
||||||
|
--- doc/Makefile.orig 2025-02-20 16:24:12 UTC
|
||||||
|
+++ doc/Makefile
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-TARGETS = $(OBJDIR)camera.1 $(OBJDIR)camera.html $(OBJDIR)gallery.1 $(OBJDIR)gallery.html
|
||||||
|
+TARGETS = $(OBJDIR)camera.1 $(OBJDIR)gallery.1
|
||||||
|
OBJDIR =
|
||||||
|
PREFIX = /usr/local
|
||||||
|
DESTDIR =
|
||||||
|
@@ -33,14 +33,10 @@ install: all
|
||||||
|
|
||||||
|
install: all
|
||||||
|
./docbook.sh -P "$(DESTDIR)$(PREFIX)" -i -- "$(OBJDIR)camera.1"
|
||||||
|
- ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -i -- "$(OBJDIR)camera.html"
|
||||||
|
./docbook.sh -P "$(DESTDIR)$(PREFIX)" -i -- "$(OBJDIR)gallery.1"
|
||||||
|
- ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -i -- "$(OBJDIR)gallery.html"
|
||||||
|
|
||||||
|
uninstall:
|
||||||
|
./docbook.sh -P "$(DESTDIR)$(PREFIX)" -u -- "camera.1"
|
||||||
|
- ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -u -- "camera.html"
|
||||||
|
./docbook.sh -P "$(DESTDIR)$(PREFIX)" -u -- "gallery.1"
|
||||||
|
- ./docbook.sh -P "$(DESTDIR)$(PREFIX)" -u -- "gallery.html"
|
||||||
|
|
||||||
|
.PHONY: all clean distclean install uninstall
|
4
multimedia/deforaos-camera/pkg-descr
Normal file
4
multimedia/deforaos-camera/pkg-descr
Normal file
|
@ -0,0 +1,4 @@
|
||||||
|
DeforaOS Desktop photo camera
|
||||||
|
|
||||||
|
Camera is a simple webcam viewer, which can be used to take pictures from still
|
||||||
|
frames.
|
10
multimedia/deforaos-camera/pkg-plist
Normal file
10
multimedia/deforaos-camera/pkg-plist
Normal file
|
@ -0,0 +1,10 @@
|
||||||
|
bin/camera
|
||||||
|
bin/gallery
|
||||||
|
lib/Desktop/widget/camera.so
|
||||||
|
share/applications/org.defora.camera.desktop
|
||||||
|
share/applications/org.defora.gallery.desktop
|
||||||
|
share/doc/Camera/COPYING
|
||||||
|
%%NLS%%share/locale/es/LC_MESSAGES/Camera.mo
|
||||||
|
%%NLS%%share/locale/fr/LC_MESSAGES/Camera.mo
|
||||||
|
%%PORTDOCS%%share/man/man1/camera.1.gz
|
||||||
|
%%PORTDOCS%%share/man/man1/gallery.1.gz
|
Loading…
Add table
Reference in a new issue