mirror of
https://git.freebsd.org/ports.git
synced 2025-04-28 01:26:39 -04:00
irc/ezbounce: Remove expired port
2025-01-28 irc/ezbounce: broken with modern Boost, broken with modern compilers, last release in 2009, upstream is dead
This commit is contained in:
parent
8e5fbc7513
commit
459d7b6ec4
8 changed files with 1 additions and 96 deletions
1
MOVED
1
MOVED
|
@ -4056,3 +4056,4 @@ chinese/kcfonts||2025-01-27|Has expired: GENTOO MASTER_SITES are no longer avail
|
|||
x11/fbdesk||2025-01-27|Has expired: Upstream disapear and distfile is no more available
|
||||
graphics/Hermes||2025-01-27|Has expired: Unmaintained, and no more public distfiles
|
||||
math/PDL|math/p5-PDL|2025-01-28|Move math/PDL to math/p5-PDL
|
||||
irc/ezbounce||2025-01-28|Has expired: broken with modern Boost, broken with modern compilers, last release in 2009, upstream is dead
|
||||
|
|
|
@ -19,7 +19,6 @@
|
|||
SUBDIR += epic4
|
||||
SUBDIR += epic5
|
||||
SUBDIR += ergo
|
||||
SUBDIR += ezbounce
|
||||
SUBDIR += gruftistats
|
||||
SUBDIR += halloy
|
||||
SUBDIR += hexchat
|
||||
|
|
|
@ -1,56 +0,0 @@
|
|||
PORTNAME= ezbounce
|
||||
PORTVERSION= 1.99.15
|
||||
PORTREVISION= 27
|
||||
CATEGORIES= irc
|
||||
MASTER_SITES= https://BSDforge.com/projects/source/irc/ezbounce/
|
||||
|
||||
MAINTAINER= portmaster@BSDforge.com
|
||||
COMMENT= Highly configurable IRC Proxy
|
||||
WWW= https://sourceforge.net/projects/ezbounce/
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/LICENSE
|
||||
|
||||
BROKEN= fails to build with boost-1.85+
|
||||
DEPRECATED= broken with modern Boost, broken with modern compilers, last release in 2009, upstream is dead
|
||||
EXPIRATION_DATE=2025-01-28
|
||||
|
||||
OPTIONS_DEFINE= DOCS SSL COMPRESS
|
||||
OPTIONS_DEFAULT=SSL COMPRESS
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
SSL_USES= ssl
|
||||
SSL_CONFIGURE_WITH= ssl
|
||||
COMPRESS_BUILD_DEPENDS= ${LOCALBASE}/include/boost/function.hpp:devel/boost-libs
|
||||
COMPRESS_CONFIGURE_WITH=boost
|
||||
COMPRESS_DESC= Chat log compression (requires boost)
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
GNU_CONFIGURE_MANPREFIX=${PREFIX}/share
|
||||
USES= compiler:c++0x cpe gmake
|
||||
USE_GCC= yes
|
||||
|
||||
# ezbounce 1.99.15 isn't compatible with C++11 and later, which some compilers
|
||||
# such as GCC 6 default to.
|
||||
USE_CXXSTD= gnu++98
|
||||
|
||||
SUB_FILES= pkg-message
|
||||
|
||||
post-patch:
|
||||
@${SED} -e "s:/path/to:${PREFIX}/sbin:" ${WRKSRC}/sample.conf > \
|
||||
${WRKSRC}/ezb.conf.default
|
||||
@${REINPLACE_CMD} -e 's|=-O2|="$$CXXFLAGS"|g' ${WRKSRC}/configure
|
||||
|
||||
do-install:
|
||||
${INSTALL_PROGRAM} ${WRKSRC}/ezbounce ${STAGEDIR}${PREFIX}/sbin
|
||||
${INSTALL_DATA} ${WRKSRC}/ezb.conf.default ${STAGEDIR}${PREFIX}/etc
|
||||
${INSTALL_MAN} ${WRKSRC}/docs/ezbounce.1 ${STAGEDIR}${PREFIX}/share/man/man1
|
||||
|
||||
do-install-DOCS-on:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/CHANGES ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/TODO ${STAGEDIR}${DOCSDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/docs/worklog ${STAGEDIR}${DOCSDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
|
@ -1,2 +0,0 @@
|
|||
SHA256 (ezbounce-1.99.15.tar.gz) = ee28c114596c0d4f12f6296a4cbe76c8f8016c869246b348fb4eaee7e2f6012d
|
||||
SIZE (ezbounce-1.99.15.tar.gz) = 429512
|
|
@ -1,13 +0,0 @@
|
|||
--- src/irc/flood.cc.orig 2008-07-01 02:53:36.000000000 +0000
|
||||
+++ src/irc/flood.cc
|
||||
@@ -204,8 +204,8 @@ void flood_protector::clear_expired(time
|
||||
const seconds_t &max = *std::max_element(vals, vals+n) + 1;
|
||||
|
||||
for (nick_hash_t::const_iterator i = nick_hash.begin(),
|
||||
- e = nick_hash.end();
|
||||
- i != e;
|
||||
+ ef = nick_hash.end();
|
||||
+ i != ef;
|
||||
++i) {
|
||||
flood_entry& e = *i->second;
|
||||
|
|
@ -1,8 +0,0 @@
|
|||
[
|
||||
{ type: install
|
||||
message: <<EOM
|
||||
You will need to edit %%PREFIX%%/etc/ezb.conf and read the docs in
|
||||
%%DOCSDIR%%/README to set up this program.
|
||||
EOM
|
||||
}
|
||||
]
|
|
@ -1,9 +0,0 @@
|
|||
ezbounce is a highly configurable IRC Proxy that features:
|
||||
|
||||
* Access control
|
||||
* Password protection
|
||||
* Ident spoofing
|
||||
* Can listen on virtual hosts
|
||||
* Ability to ``Detach'' from the proxy and stay connected
|
||||
to the IRC server.
|
||||
... and more!
|
|
@ -1,7 +0,0 @@
|
|||
@sample etc/ezb.conf.default etc/ezb.conf
|
||||
sbin/ezbounce
|
||||
share/man/man1/ezbounce.1.gz
|
||||
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
|
||||
%%PORTDOCS%%%%DOCSDIR%%/README
|
||||
%%PORTDOCS%%%%DOCSDIR%%/TODO
|
||||
%%PORTDOCS%%%%DOCSDIR%%/worklog
|
Loading…
Add table
Reference in a new issue